summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-21 14:48:54 +0200
committerRemi Collet <remi@remirepo.net>2019-10-21 14:48:54 +0200
commit710b61aef7e981d4534bbe4370d3c1b7b2f9bba3 (patch)
tree319db02f4dacb99e26c0b71005b192017dcea091
parent7242cd5b86ed5e0e38436884e5246f1f657cc346 (diff)
fix preload, add upstream patch for https://bugs.php.net/78512
-rw-r--r--05c5e5dfde91955263469daa2dd5afcbb5199d17.patch26
-rw-r--r--failed.txt6
-rw-r--r--php.spec7
3 files changed, 36 insertions, 3 deletions
diff --git a/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch b/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch
new file mode 100644
index 0000000..81cdc23
--- /dev/null
+++ b/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch
@@ -0,0 +1,26 @@
+From 05c5e5dfde91955263469daa2dd5afcbb5199d17 Mon Sep 17 00:00:00 2001
+From: Dmitry Stogov <dmitry@zend.com>
+Date: Mon, 21 Oct 2019 14:52:26 +0300
+Subject: [PATCH] Fixed bug #78512 (Cannot make preload work)
+
+---
+ NEWS | 3 +++
+ ext/opcache/ZendAccelerator.c | 5 +++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/ext/opcache/ZendAccelerator.c b/ext/opcache/ZendAccelerator.c
+index 056c7739a0b6..636058dd0875 100644
+--- a/ext/opcache/ZendAccelerator.c
++++ b/ext/opcache/ZendAccelerator.c
+@@ -4565,6 +4565,11 @@ static int accel_finish_startup(void)
+ zend_accel_error(ACCEL_LOG_FATAL, "Preloading failed to waitpid(%d)", pid);
+ return FAILURE;
+ }
++
++ if (ZCSG(preload_script)) {
++ preload_load();
++ }
++
+ zend_shared_alloc_unlock();
+ if (WIFEXITED(status) && WEXITSTATUS(status) == 0) {
+ return SUCCESS;
diff --git a/failed.txt b/failed.txt
index daea284..7cdeff8 100644
--- a/failed.txt
+++ b/failed.txt
@@ -2,13 +2,15 @@
$ grep -ar 'Tests failed' /var/lib/mock/scl74*/build.log
-/var/lib/mock/scl74el7x/build.log:Tests failed : 0
-/var/lib/mock/scl74el8x/build.log:Tests failed : 30
+/var/lib/mock/scl74el7x/build.log:Tests failed : 1
+/var/lib/mock/scl74el8x/build.log:Tests failed : 21
/var/lib/mock/scl74fc29x/build.log:Tests failed : 0
/var/lib/mock/scl74fc30x/build.log:Tests failed : 0
/var/lib/mock/scl74fc31x/build.log:Tests failed : 0
+el7x:
+ 6 SPL: DirectoryIterator and clone [ext/spl/tests/dit_004.phpt]
(1) proc_open give erratic test results :(
diff --git a/php.spec b/php.spec
index b1f7985..df70e44 100644
--- a/php.spec
+++ b/php.spec
@@ -108,7 +108,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 28%{?dist}
+Release: 29%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -174,6 +174,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
+Patch100: https://github.com/php/php-src/commit/05c5e5dfde91955263469daa2dd5afcbb5199d17.patch
BuildRequires: gnupg2
BuildRequires: bzip2-devel
@@ -945,6 +946,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch300 -p1 -b .datetests
# WIP patch
+%patch100 -p1
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1804,6 +1806,9 @@ fi
%changelog
+* Mon Oct 21 2019 Remi Collet <remi@remirepo.net> - 7.4.0~rc4-29
+- fix preload, add upstream patch for https://bugs.php.net/78512
+
* Tue Oct 15 2019 Remi Collet <remi@remirepo.net> - 7.4.0~rc4-28
- update to 7.4.0RC4