summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-14 15:23:25 +0100
committerRemi Collet <remi@php.net>2024-02-14 15:23:25 +0100
commit17420bc31fbfca54f7234082b8c59a05db1e4384 (patch)
tree99ce8b6eac48622b0ce2b031c1072a6dc6fe1948
parent9bcde6ae2d061b62df32ab8a763089b528eb633d (diff)
add build patch for GCC 14
use oracle client library version 21.13 on x86_64
-rw-r--r--php-7.4.33-gcc14.patch32
-rw-r--r--php.spec10
2 files changed, 40 insertions, 2 deletions
diff --git a/php-7.4.33-gcc14.patch b/php-7.4.33-gcc14.patch
new file mode 100644
index 0000000..7af776f
--- /dev/null
+++ b/php-7.4.33-gcc14.patch
@@ -0,0 +1,32 @@
+diff -up php-7.4.33/ext/pdo_oci/oci_statement.c.gcc14 php-7.4.33/ext/pdo_oci/oci_statement.c
+--- php-7.4.33/ext/pdo_oci/oci_statement.c.gcc14 2022-10-31 11:36:05.000000000 +0100
++++ php-7.4.33/ext/pdo_oci/oci_statement.c 2024-02-14 15:05:34.224568567 +0100
+@@ -654,7 +654,7 @@ static ssize_t oci_blob_write(php_stream
+ return amt;
+ }
+
+-static size_t oci_blob_read(php_stream *stream, char *buf, size_t count)
++static ssize_t oci_blob_read(php_stream *stream, char *buf, size_t count)
+ {
+ struct oci_lob_self *self = (struct oci_lob_self*)stream->abstract;
+ ub4 amt;
+@@ -666,7 +666,7 @@ static size_t oci_blob_read(php_stream *
+ NULL, NULL, 0, SQLCS_IMPLICIT);
+
+ if (r != OCI_SUCCESS && r != OCI_NEED_DATA) {
+- return (size_t)-1;
++ return -1;
+ }
+
+ self->offset += amt;
+diff -up php-7.4.33/sapi/litespeed/lsapi_main.c.gcc14 php-7.4.33/sapi/litespeed/lsapi_main.c
+--- php-7.4.33/sapi/litespeed/lsapi_main.c.gcc14 2024-02-14 15:09:59.523706463 +0100
++++ php-7.4.33/sapi/litespeed/lsapi_main.c 2024-02-14 15:10:13.979258854 +0100
+@@ -25,6 +25,7 @@
+ #include "zend.h"
+ #include "ext/standard/basic_functions.h"
+ #include "ext/standard/info.h"
++#include "ext/standard/head.h"
+ #include "lsapilib.h"
+
+ #include <stdio.h>
diff --git a/php.spec b/php.spec
index 3bd7ddb..d3cdc53 100644
--- a/php.spec
+++ b/php.spec
@@ -54,7 +54,7 @@
%global oraclelib 19.1
%global oracledir 19.19
%else
-%global oraclever 21.12
+%global oraclever 21.13
%global oraclelib 21.1
%global oracledir 21
%endif
@@ -117,7 +117,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 10%{?dist}
+Release: 11%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -161,6 +161,7 @@ Patch6: php-7.4.0-embed.patch
Patch7: php-7.4.33-libxml212.patch
Patch8: php-7.2.0-libdb.patch
Patch9: php-7.0.7-curl.patch
+Patch10: php-7.4.33-gcc14.patch
# Functional changes
Patch42: php-7.3.3-systzdata-v19.patch
@@ -958,6 +959,7 @@ in pure PHP.
%if 0%{?rhel} == 7
%patch -P9 -p1 -b .curltls
%endif
+%patch -P10 -p1 -b .gcc14
%patch -P42 -p1 -b .systzdata
%patch -P43 -p1 -b .headers
@@ -1873,6 +1875,10 @@ EOF
%changelog
+* Wed Feb 14 2024 Remi Collet <remi@remirepo.net> - 7.4.33-11
+- add build patch for GCC 14
+- use oracle client library version 21.13 on x86_64
+
* Tue Dec 12 2023 Remi Collet <remi@remirepo.net> - 7.4.33-10
- use ICU 73.2
- use oracle client library version 21.12 on x86_64, 19.19 on aarch64