summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec30
1 files changed, 12 insertions, 18 deletions
diff --git a/php.spec b/php.spec
index 842cb0c..9f98ac8 100644
--- a/php.spec
+++ b/php.spec
@@ -55,22 +55,8 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%if 0%{?rhel} == 6
-%ifarch x86_64
-%global oraclever 18.5
-%else
-%global oraclever 18.3
-%endif
-%global oraclelib 18.1
-
-%else
-%ifarch x86_64
-%global oraclever 19.9
-%else
-%global oraclever 19.6
-%endif
-%global oraclelib 19.1
-%endif
+%global oraclever 21.1
+%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
%global with_lsws 1
@@ -141,7 +127,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -203,8 +189,10 @@ Patch49: php-7.3.24-fpm.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-# Backported from 7.4.16
+# Backported from 7.4.16 - opcache and pcre.jit
Patch100: php-bug80682.patch
+# Backported from 7.4.18 - pdo_odbc
+Patch101: php-bug80783.patch
# Security fixes (200+)
@@ -975,6 +963,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
# upstream patches
%patch100 -p1 -b .bug80682
+%patch101 -p1 -b .bug80783
# security patches
@@ -1928,6 +1917,11 @@ fi
%changelog
+* Thu Apr 8 2021 Remi Collet <remi@remirepo.net> - 7.3.27-2
+- add upstream patch for https://bugs.php.net/80783
+ PDO ODBC truncates BLOB records at every 256th byte
+- use oracle client library version 21.1
+
* Tue Feb 2 2021 Remi Collet <remi@remirepo.net> - 7.3.27-1
- Update to 7.3.27 - http://www.php.net/releases/7_3_27.php