summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-14 15:49:49 +0100
committerRemi Collet <remi@php.net>2023-02-14 15:49:49 +0100
commit1b1f978a479f016248d1b2b00874db1d6e55cc1f (patch)
tree6ec0c9b6f53ddeb501c85efd11806139b5410179 /php.spec
parent49b132f929fc66d5badcf6cdec646e150ed94714 (diff)
fix #81744: Password_verify() always return true with some hash
CVE-2023-0567 fix #81746: 1-byte array overrun in common path resolve code CVE-2023-0568 fix DOS vulnerability when parsing multipart request body CVE-2023-0662 add dependency on pcre2 minimal version
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec23
1 files changed, 22 insertions, 1 deletions
diff --git a/php.spec b/php.spec
index 328e7a0..11c5546 100644
--- a/php.spec
+++ b/php.spec
@@ -126,7 +126,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 7%{?dist}
+Release: 8%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -204,6 +204,9 @@ Patch202: php-bug81727.patch
Patch203: php-bug81726.patch
Patch204: php-bug81738.patch
Patch205: php-bug81740.patch
+Patch206: php-bug81744.patch
+Patch207: php-bug81746.patch
+Patch208: php-cve-2023-0662.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -380,6 +383,12 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with_libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: %{?scl_prefix}php(api) = %{apiver}%{isasuffix}
Provides: %{?scl_prefix}php(zend-abi) = %{zendver}%{isasuffix}
@@ -979,6 +988,9 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch203 -p1 -b .bug81726
%patch204 -p1 -b .bug81738
%patch205 -p1 -b .bug81740
+%patch206 -p1 -b .bug81744
+%patch207 -p1 -b .bug81746
+%patch208 -p1 -b .cve0662
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1938,6 +1950,15 @@ EOF
%changelog
+* Tue Feb 14 2023 Remi Collet <remi@remirepo.net> - 7.3.33-8
+- fix #81744: Password_verify() always return true with some hash
+ CVE-2023-0567
+- fix #81746: 1-byte array overrun in common path resolve code
+ CVE-2023-0568
+- fix DOS vulnerability when parsing multipart request body
+ CVE-2023-0662
+- add dependency on pcre2 minimal version
+
* Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 7.3.33-7
- pdo: fix #81740: PDO::quote() may return unquoted string
CVE-2022-31631