summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-07 12:39:51 +0200
committerRemi Collet <remi@remirepo.net>2018-06-07 12:39:51 +0200
commit8529947f3ae0fdf43ee46cac6475a708d36c4291 (patch)
tree8152bf4d3e93203fc0b4a94dc3c5aed790c4d22f
parentc4509b199c30885490cc793a619fb17f02646642 (diff)
update to 7.3.0alpha1
switch from pcre to pcre2
-rw-r--r--Makefile2
-rw-r--r--failed.txt16
-rw-r--r--php-7.0.0-oldpcre.patch20
-rw-r--r--php-fpm.wants2
-rw-r--r--php.spec34
5 files changed, 25 insertions, 49 deletions
diff --git a/Makefile b/Makefile
index 619f3b7..5ed497c 100644
--- a/Makefile
+++ b/Makefile
@@ -3,4 +3,4 @@ NAME := $(shell basename $(SRCDIR))
include ../../common/Makefile
srpm:
- rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php72' -bs $(NAME).spec
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php73' -bs $(NAME).spec
diff --git a/failed.txt b/failed.txt
index 8e3d0e3..fdfd051 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,15 +1,15 @@
-===== 7.2.7RC1 (2018-06-07)
+===== 7.3.0alpha1 (2018-06-07)
-$ grep -r 'Tests failed' /var/lib/mock/scl72*/build.log
+$ grep -r 'Tests failed' /var/lib/mock/scl73*/build.log
-/var/lib/mock/scl72el6x/build.log:Tests failed : 0
-/var/lib/mock/scl72el7x/build.log:Tests failed : 0
-/var/lib/mock/scl72fc25x/build.log:Tests failed : 0
-/var/lib/mock/scl72fc26x/build.log:Tests failed : 0
-/var/lib/mock/scl72fc27x/build.log:Tests failed : 0
-/var/lib/mock/scl72fc28x/build.log:Tests failed : 0
+/var/lib/mock/scl72el6x/build.log:Tests failed : 1
+/var/lib/mock/scl72el7x/build.log:Tests failed : 1
+/var/lib/mock/scl72fc27x/build.log:Tests failed : 1
+/var/lib/mock/scl72fc28x/build.log:Tests failed : 1
+el6x, el7x, fc27x, fc28x
+ 5 gzfile() with various invalid params [ext/zlib/tests/004-mb.phpt]
(1) proc_open give erratic test results :(
diff --git a/php-7.0.0-oldpcre.patch b/php-7.0.0-oldpcre.patch
deleted file mode 100644
index 19f8064..0000000
--- a/php-7.0.0-oldpcre.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -up ./ext/pcre/tests/bug37911.phpt.pcre834 ./ext/pcre/tests/bug37911.phpt
---- ./ext/pcre/tests/bug37911.phpt.pcre834 2014-03-26 14:10:18.285452752 +0100
-+++ ./ext/pcre/tests/bug37911.phpt 2014-03-26 14:10:40.028526763 +0100
-@@ -37,5 +37,5 @@ array(3) {
- string(4) "blub"
- }
-
--Warning: preg_replace_callback(): Compilation failed: group name must start with a non-digit at offset %d in %sbug37911.php on line %d
-+Warning: preg_replace_callback(): Numeric named subpatterns are not allowed in %sbug37911.php on line %d
- NULL
-diff -up ./ext/pcre/tests/match_flags3.phpt.pcre834 ./ext/pcre/tests/match_flags3.phpt
---- ./ext/pcre/tests/match_flags3.phpt.pcre834 2014-03-26 14:06:48.792739665 +0100
-+++ ./ext/pcre/tests/match_flags3.phpt 2014-03-26 14:07:31.820886128 +0100
-@@ -42,5 +42,5 @@ array(1) {
- }
- }
-
--Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset %d in %smatch_flags3.php on line %d
-+Warning: preg_match(): Numeric named subpatterns are not allowed in %smatch_flags3.php on line %d
- bool(false)
diff --git a/php-fpm.wants b/php-fpm.wants
index b1f26a8..18fa4b1 100644
--- a/php-fpm.wants
+++ b/php-fpm.wants
@@ -1,3 +1,3 @@
[Unit]
-Wants=php72-php-fpm.service
+Wants=php73-php-fpm.service
diff --git a/php.spec b/php.spec
index b00bd40..1f9134e 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php72-php
+# remirepo spec file for php73-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -22,7 +22,7 @@
%endif
# API/ABI check
-%global apiver 20170718
+%global apiver 20180123
%global zendver 20170718
%global pdover 20170320
# Extension version
@@ -32,7 +32,7 @@
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 7.2
+%global embed_version 7.3
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -77,7 +77,7 @@
%global with_sqlite3 1
%global with_enchant 1
%global with_recode 1
-%if 0%{?fedora} >= 22 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global with_libpcre 1
%else
%global with_libpcre 0
@@ -124,8 +124,8 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.7
-%global rcver RC1
+%global upver 7.3.0
+%global rcver alpha1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -188,8 +188,6 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.0.10-datetests.patch
-# Revert changes for pcre < 8.34
-Patch301: php-7.0.0-oldpcre.patch
# WIP
@@ -209,9 +207,9 @@ BuildRequires: sqlite-devel >= 3.0.0
%endif
BuildRequires: zlib-devel, smtpdaemon, libedit-devel
%if %{with_libpcre}
-BuildRequires: pcre-devel >= 8.20
+BuildRequires: pcre2-devel >= 10.30
%else
-Provides: Provides: bundled(pcre) = 8.38
+Provides: Provides: bundled(pcre2) = 10.31
%endif
BuildRequires: bzip2
BuildRequires: perl
@@ -403,7 +401,7 @@ Requires: gcc
Requires: gcc-c++
Requires: libtool
%if %{with_libpcre}
-Requires: pcre-devel%{?_isa} >= 8.20
+Requires: pcre2-devel%{?_isa} >= 10.30
%endif
%description devel
@@ -927,12 +925,6 @@ low-level PHP extension for the libsodium cryptographic library.
# Fixes for tests
%patch300 -p1 -b .datetests
-%if %{with_libpcre}
-if ! pkg-config libpcre --atleast-version 8.34 ; then
-# Only apply when system libpcre < 8.34
-%patch301 -p1 -b .pcre834
-fi
-%endif
# WIP patch
@@ -948,7 +940,6 @@ cp ext/mbstring/libmbfl/LICENSE libmbfl_LICENSE
cp ext/mbstring/oniguruma/COPYING oniguruma_COPYING
cp ext/mbstring/ucgendat/OPENLDAP_LICENSE ucgendat_LICENSE
cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
-cp ext/phar/LICENSE phar_LICENSE
cp ext/bcmath/libbcmath/COPYING.LIB libbcmath_COPYING
cp ext/date/lib/LICENSE.rst timelib_LICENSE
@@ -971,6 +962,8 @@ rm ext/standard/tests/file/file_get_contents_error001.phpt
# cause stack exhausion
rm Zend/tests/bug54268.phpt
rm Zend/tests/bug68412.phpt
+# tar issue
+rm ext/zlib/tests/004-mb.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
@@ -1709,7 +1702,6 @@ fi
%doc CODING_STANDARDS CREDITS EXTENSIONS NEWS README*
%license LICENSE TSRM_LICENSE
%license libmagic_LICENSE
-%license phar_LICENSE
%license timelib_LICENSE
%doc php.ini-*
%config(noreplace) %{_sysconfdir}/php.ini
@@ -1862,6 +1854,10 @@ fi
%changelog
+* Thu Jun 7 2018 Remi Collet <remi@remirepo.net> - 7.3.0~alpha1-1
+- update to 7.3.0alpha1
+- switch from pcre to pcre2
+
* Wed Jun 6 2018 Remi Collet <remi@remirepo.net> - 7.2.7~RC1-1
- update to 7.2.7RC1