summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-05 16:56:50 +0100
committerRemi Collet <remi@remirepo.net>2018-11-05 16:56:50 +0100
commit429cdcff82ec363d50d4acd5d228a8931b5f3432 (patch)
tree479270fa85713ec79c41870594dde941e8e8ef4f
parent8bdcb18565889d18097d3fcd0b9f693ad0e10e03 (diff)
test build for https://github.com/php/php-src/pull/3652
-rw-r--r--3652.patch23
-rw-r--r--php.spec7
2 files changed, 29 insertions, 1 deletions
diff --git a/3652.patch b/3652.patch
new file mode 100644
index 0000000..f34db99
--- /dev/null
+++ b/3652.patch
@@ -0,0 +1,23 @@
+From 38b2641fd5e3893c7b152d7e218831a5e2fe6070 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 5 Nov 2018 15:58:42 +0100
+Subject: [PATCH] fix C++ compilation using zend_string_equals
+
+---
+ Zend/zend_string.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Zend/zend_string.h b/Zend/zend_string.h
+index 58975987eb02..4b375c5beceb 100644
+--- a/Zend/zend_string.h
++++ b/Zend/zend_string.h
+@@ -295,7 +295,9 @@ static zend_always_inline void zend_string_release_ex(zend_string *s, int persis
+ }
+
+ #if defined(__GNUC__) && (defined(__i386__) || defined(__x86_64__))
++BEGIN_EXTERN_C()
+ ZEND_API zend_bool ZEND_FASTCALL zend_string_equal_val(zend_string *s1, zend_string *s2);
++END_EXTERN_C()
+ #else
+ static zend_always_inline zend_bool zend_string_equal_val(zend_string *s1, zend_string *s2)
+ {
diff --git a/php.spec b/php.spec
index d07a01d..4c2a48f 100644
--- a/php.spec
+++ b/php.spec
@@ -131,7 +131,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -184,6 +184,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: https://patch-diff.githubusercontent.com/raw/php/php-src/pull/3652.patch
# Security fixes (200+)
@@ -924,6 +925,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .pr3652
# security patches
@@ -1858,6 +1860,9 @@ fi
%changelog
+* Mon Nov 5 2018 Remi Collet <remi@remirepo.net> - 7.3.0~rc4-2
+- test build for https://github.com/php/php-src/pull/3652
+
* Tue Oct 23 2018 Remi Collet <remi@remirepo.net> - 7.3.0~rc4-1
- update to 7.3.0RC4