summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt2
-rw-r--r--php-bug78412.patch37
-rw-r--r--php.spec11
3 files changed, 8 insertions, 42 deletions
diff --git a/failed.txt b/failed.txt
index aadaf48..d1b631a 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.2.22 (2019-08-29)
+===== 7.2.23RC1 (2019-09-12)
$ grep -ar 'Tests failed' /var/lib/mock/scl72*/build.log
diff --git a/php-bug78412.patch b/php-bug78412.patch
deleted file mode 100644
index f4f8b4a..0000000
--- a/php-bug78412.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From fcabe7e5e44067319f9c4123d71a7cea6a823af4 Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Wed, 14 Aug 2019 17:48:57 +0200
-Subject: [PATCH] Fixed bug #78412
-
-$this should only be included in the generator GC buffer, if it
-will be released on destruction.
----
- NEWS | 4 ++++
- Zend/zend_generators.c | 4 ++--
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/Zend/zend_generators.c b/Zend/zend_generators.c
-index 666a12f..042ddbc 100644
---- a/Zend/zend_generators.c
-+++ b/Zend/zend_generators.c
-@@ -271,7 +271,7 @@ static uint32_t calc_gc_buffer_size(zend_generator *generator) /* {{{ */
- if (EX_CALL_INFO() & ZEND_CALL_FREE_EXTRA_ARGS) {
- size += EX_NUM_ARGS() - op_array->num_args;
- }
-- size += Z_TYPE(execute_data->This) == IS_OBJECT; /* $this */
-+ size += (EX_CALL_INFO() & ZEND_CALL_RELEASE_THIS) != 0; /* $this */
- size += (EX_CALL_INFO() & ZEND_CALL_CLOSURE) != 0; /* Closure object */
-
- /* Live vars */
-@@ -352,7 +352,7 @@ static HashTable *zend_generator_get_gc(zval *object, zval **table, int *n) /* {
- }
- }
-
-- if (Z_TYPE(execute_data->This) == IS_OBJECT) {
-+ if (EX_CALL_INFO() & ZEND_CALL_RELEASE_THIS) {
- ZVAL_OBJ(gc_buffer++, Z_OBJ(execute_data->This));
- }
- if (EX_CALL_INFO() & ZEND_CALL_CLOSURE) {
---
-2.1.4
-
diff --git a/php.spec b/php.spec
index d8e644f..cc6c2a9 100644
--- a/php.spec
+++ b/php.spec
@@ -131,8 +131,8 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.22
-#global rcver RC1
+%global upver 7.2.23
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -194,7 +194,6 @@ Patch49: php-7.2.16-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug78412.patch
# Security fixes (200+)
@@ -948,7 +947,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .78412
# security patches
@@ -997,6 +995,8 @@ rm ext/date/tests/bug33414-1.phpt
rm ext/date/tests/bug33415-2.phpt
rm ext/date/tests/date_modify-1.phpt
%endif
+# too fast builder
+rm ext/date/tests/bug73837.phpt
# fails sometime
rm ext/sockets/tests/mcast_ipv?_recv.phpt
# Should be skipped but fails sometime
@@ -1894,6 +1894,9 @@ fi
%changelog
+* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 7.2.23~RC1-1
+- update to 7.2.23RC1
+
* Wed Aug 28 2019 Remi Collet <remi@remirepo.net> - 7.2.22-1
- Update to 7.2.22 - http://www.php.net/releases/7_2_22.php
- fix generator incorrectly reports non-releasable $this as GC child