summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-upstream.patch30
-rw-r--r--php.spec9
2 files changed, 37 insertions, 2 deletions
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..448fd7c
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,30 @@
+From 3239f6d6798d86fdbf8e03aa741d9990bcfffe79 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 31 Aug 2017 07:55:45 +0200
+Subject: [PATCH] move AC_DEFINE in the right position (in bundled lib
+ conditon)
+
+---
+ ext/sqlite3/config0.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
+index 0e5fbc5..78fd622 100644
+--- a/ext/sqlite3/config0.m4
++++ b/ext/sqlite3/config0.m4
+@@ -85,11 +85,11 @@ if test $PHP_SQLITE3 != "no"; then
+ other_flags="$other_flags -DSQLITE_ENABLE_ICU=1"
+ fi
+
++ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
+ PHP_INSTALL_HEADERS([ext/sqlite3/libsqlite/sqlite3.h])
+ fi
+
+- AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ AC_DEFINE(HAVE_SQLITE3,1,[ ])
+
+ sqlite3_sources="sqlite3.c $sqlite3_extra_sources"
+--
+2.1.4
+
diff --git a/php.spec b/php.spec
index 97f9f5a..d21075d 100644
--- a/php.spec
+++ b/php.spec
@@ -130,7 +130,7 @@
%global gh_owner php
%global gh_project php-src
%global rcver RC1
-%global rpmrel 21
+%global rpmrel 22
Summary: PHP scripting language for creating dynamic web sites
@@ -197,6 +197,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -925,6 +926,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -1269,7 +1271,7 @@ without_shared="--without-gd \
--disable-opcache \
--disable-json \
--disable-xmlreader --disable-xmlwriter \
- --without-sodium
+ --without-sodium \
--without-sqlite3 --disable-phar --disable-fileinfo \
--without-pspell --disable-wddx \
--without-curl --disable-posix --disable-xml \
@@ -1842,6 +1844,9 @@ fi
%changelog
+* Thu Aug 31 2017 Remi Collet <remi@fedoraproject.org> - 7.2.0-0.22.RC1
+- add patch for EL-6, fix undefined symbol: sqlite3_errstr
+
* Tue Aug 29 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.21.RC1
- update to 7.2.0RC1