summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-14 10:00:01 +0100
committerRemi Collet <remi@remirepo.net>2018-02-14 10:00:01 +0100
commita4bf2bd0322fe575e59ff6d2b0b06046633ceb46 (patch)
tree6e6ca1fd63572f7596bee7523c47f64b061cf5cf
parent2eccccb428deb34a46851bf8bbe1120c88aeb0b2 (diff)
apply upstream patch for date ext
-rw-r--r--failed.txt28
-rw-r--r--php-upstream.patch30
-rw-r--r--php.spec7
3 files changed, 41 insertions, 24 deletions
diff --git a/failed.txt b/failed.txt
index 0a722fe..c925984 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,17 +1,14 @@
===== 7.2.2 (2018-02-01)
$ grep -r 'Tests failed' /var/lib/mock/scl72*/build.log
-/var/lib/mock/scl72el6x/build.log:Tests failed : 2
-/var/lib/mock/scl72el7x/build.log:Tests failed : 2
-/var/lib/mock/scl70fc24x/build.log:Tests failed : 2
-/var/lib/mock/scl70fc25x/build.log:Tests failed : 2
-/var/lib/mock/scl70fc26x/build.log:Tests failed : 2
-/var/lib/mock/scl70fc27x/build.log:Tests failed : 2
+/var/lib/mock/scl72el6x/build.log:Tests failed : 0
+/var/lib/mock/scl72el7x/build.log:Tests failed : 0
+/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
+/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
+/var/lib/mock/scl70fc26x/build.log:Tests failed : 0
+/var/lib/mock/scl70fc27x/build.log:Tests failed : 0
-el6x, el7x, fc24x, fc25x, fc26x, fc27x:
- 5 Test serialization of DateTimeZone objects [ext/date/tests/DateTimeZone_serialize_type_1.phpt]
- 5 Bug #66985 (Some timezones are no longer valid in PHP 5.5.10) [ext/date/tests/bug66985.phpt]
(1) proc_open give erratic test results :(
@@ -19,16 +16,3 @@ el6x, el7x, fc24x, fc25x, fc26x, fc27x:
(3) known issue
(5) need investigation
-
-TEST FAILURE: ../ext/date/tests/bug66985.diff --
-144+ [timezone] => -60:00
-144- [timezone] => +01:00
-149+ [timezone] => +150:0^@
-149- [timezone] => -02:30
--- ../ext/date/tests/bug66985.diff result ends.
-TEST FAILURE: ../ext/date/tests/DateTimeZone_serialize_type_1.diff --
-005+ string(6) "-60:00"
-005- string(6) "+01:00"
-012+ string(6) "-60:00"
-012- string(6) "+01:00"
-
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..5ffc5a9
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,30 @@
+From 528bc00d84cce18d74528677c156d6aec1b7fcd9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Wed, 14 Feb 2018 08:59:24 +0100
+Subject: [PATCH] Fix timezone var_dump from
+ 51f2a5803fa4f09e212fed4b14ab8b4a003d4ef5
+
+---
+ ext/date/php_date.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/ext/date/php_date.c b/ext/date/php_date.c
+index 82ac9a6..2df19f7 100644
+--- a/ext/date/php_date.c
++++ b/ext/date/php_date.c
+@@ -2422,9 +2422,9 @@ static HashTable *date_object_get_debug_info_timezone(zval *object, int *is_temp
+ zend_string *tmpstr = zend_string_alloc(sizeof("UTC+05:00")-1, 0);
+
+ ZSTR_LEN(tmpstr) = snprintf(ZSTR_VAL(tmpstr), sizeof("+05:00"), "%c%02d:%02d",
+- tzobj->tzi.utc_offset > 0 ? '-' : '+',
+- abs(tzobj->tzi.utc_offset / 60),
+- abs((tzobj->tzi.utc_offset % 60)));
++ tzobj->tzi.utc_offset < 0 ? '-' : '+',
++ abs((int)(tzobj->tzi.utc_offset / 3600)),
++ abs(((int)(tzobj->tzi.utc_offset % 3600) / 60)));
+
+ ZVAL_NEW_STR(&zv, tmpstr);
+ }
+--
+2.1.4
+
diff --git a/php.spec b/php.spec
index 1ac385a..f5a0c43 100644
--- a/php.spec
+++ b/php.spec
@@ -130,7 +130,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -182,6 +182,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -910,6 +911,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .upstream
# security patches
@@ -1838,9 +1840,10 @@ fi
%changelog
-* Wed Feb 14 2018 Remi Collet <remi@remirepo.net> - 7.2.3~RC1-1
+* Wed Feb 14 2018 Remi Collet <remi@remirepo.net> - 7.2.3~RC1-2
- update to 7.2.3RC1
- adapt systzdata, fixheader and ldap_r patches
+- apply upstream patch for date ext
* Tue Jan 30 2018 Remi Collet <remi@remirepo.net> - 7.2.2-1
- Update to 7.2.2 - http://www.php.net/releases/7_2_2.php