summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-11 14:16:20 +0200
committerRemi Collet <remi@remirepo.net>2017-07-11 14:16:20 +0200
commit93dc94adf5a4b5218dfbc8b72c2be8d166741323 (patch)
treedd2c3c7a08ea8db575cc720831ef20559089616b
parent6ca55b65c26d9753f92d0811da6497208a05af9b (diff)
test build with sodium extension
-rw-r--r--php.spec39
1 files changed, 32 insertions, 7 deletions
diff --git a/php.spec b/php.spec
index 905613a..c7727e1 100644
--- a/php.spec
+++ b/php.spec
@@ -128,13 +128,13 @@
%global db_devel libdb-devel
%endif
-%global gh_commit a86c87df2dc2d3bf82bd87cddd888f899306a451
+%global gh_commit 249f75e7e423ce858827c1d13231e1f762a9b267
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20170602
+%global gh_date 20170711
%global gh_owner php
%global gh_project php-src
-%global rcver alpha3
-%global rpmrel 11
+#global rcver alpha3
+%global rpmrel 12
Summary: PHP scripting language for creating dynamic web sites
@@ -874,6 +874,23 @@ The %{?scl_prefix}php-json package provides an extension that will add
support for JavaScript Object Notation (JSON) to PHP.
+%package sodium
+Summary: Wrapper for the Sodium cryptographic library
+# All files licensed under PHP version 3.0.1
+License: PHP
+Group: System Environment/Libraries
+# Ensure libsodium-last is used
+BuildRequires: libsodium-devel >= 1.0.12
+
+Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
+# not provided as API is different
+Obsoletes: %{?scl_prefix}php-pecl-libsodium < 7
+
+%description sodium
+The %{?scl_prefix}php-sodium package provides a simple,
+low-level PHP extension for the libsodium cryptographic library.
+
+
%prep
: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%if 0%{?gh_date}
@@ -1245,7 +1262,8 @@ build --libdir=%{_libdir}/php \
%if %{with_recode}
--with-recode=shared,%{_root_prefix} \
%endif
- --enable-fileinfo=shared
+ --enable-fileinfo=shared \
+ --with-sodium=shared
popd
without_shared="--without-gd \
@@ -1253,6 +1271,7 @@ without_shared="--without-gd \
--disable-opcache \
--disable-json \
--disable-xmlreader --disable-xmlwriter \
+ --without-sodium
--without-sqlite3 --disable-phar --disable-fileinfo \
--without-pspell --disable-wddx \
--without-curl --disable-posix --disable-xml \
@@ -1510,6 +1529,7 @@ for mod in pgsql odbc ldap snmp xmlrpc \
%if %{with_zip}
zip \
%endif
+ sodium \
pspell curl wddx xml \
posix shmop sysvshm sysvsem sysvmsg
do
@@ -1535,8 +1555,8 @@ extension=${mod}.so
EOF
fi
cat > files.${mod} <<EOF
-%attr(755,root,root) %{_libdir}/php/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php.d/${ini}
+%{_libdir}/php/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php.d/${ini}
EOF
done
@@ -1818,9 +1838,14 @@ fi
%files zip -f files.zip
%endif
%files json -f files.json
+%files sodium -f files.sodium
%changelog
+* Tue Jul 11 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.12.20170611.249f75e
+- test build
+- add sodium extension in new sub-package
+
* Tue Jul 4 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.11.alpha3
- update to 7.2.0alpha3