summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-29 10:20:55 +0200
committerRemi Collet <remi@remirepo.net>2017-05-29 10:20:55 +0200
commit80cede16b1eb7e8b58552e3cab1c6863cb93b239 (patch)
tree0d24090f00100cf127d9c5545b43884e6db0a240
parente1a0145d9c045a57f99a87ff6abb9b225510efdb (diff)
test build for release process test (not official alpha0)
-rw-r--r--php-7.1.0-libdb.patch (renamed from php-7.0.2-libdb.patch)20
-rw-r--r--php.spec17
2 files changed, 22 insertions, 15 deletions
diff --git a/php-7.0.2-libdb.patch b/php-7.1.0-libdb.patch
index f9bff95..ca36d1a 100644
--- a/php-7.0.2-libdb.patch
+++ b/php-7.1.0-libdb.patch
@@ -1,7 +1,7 @@
-diff -up php-7.0.2RC1/ext/dba/config.m4.libdb php-7.0.2RC1/ext/dba/config.m4
---- php-7.0.2RC1/ext/dba/config.m4.libdb 2015-12-27 07:54:48.669923462 +0100
-+++ php-7.0.2RC1/ext/dba/config.m4 2015-12-27 07:55:03.607947034 +0100
-@@ -312,61 +312,13 @@ if test "$PHP_DB4" != "no"; then
+diff -up php-7.2.0alpha0/ext/dba/config.m4.libdb php-7.2.0alpha0/ext/dba/config.m4
+--- php-7.2.0alpha0/ext/dba/config.m4.libdb 2017-05-29 08:56:06.000000000 +0200
++++ php-7.2.0alpha0/ext/dba/config.m4 2017-05-29 09:13:52.014823282 +0200
+@@ -346,61 +346,13 @@ if test "$PHP_DB4" != "no"; then
dbdp4="/usr/local/BerkeleyDB.4."
dbdp5="/usr/local/BerkeleyDB.5."
for i in $PHP_DB4 ${dbdp5}1 ${dbdp5}0 ${dbdp4}8 ${dbdp4}7 ${dbdp4}6 ${dbdp4}5 ${dbdp4}4 ${dbdp4}3 ${dbdp4}2 ${dbdp4}1 ${dbdp}0 /usr/local /usr; do
@@ -65,12 +65,12 @@ diff -up php-7.0.2RC1/ext/dba/config.m4.libdb php-7.0.2RC1/ext/dba/config.m4
fi
PHP_DBA_STD_RESULT(db4,Berkeley DB4)
-diff -up php-7.0.2RC1/ext/dba/dba.c.libdb php-7.0.2RC1/ext/dba/dba.c
---- php-7.0.2RC1/ext/dba/dba.c.libdb 2015-12-22 16:19:29.000000000 +0100
-+++ php-7.0.2RC1/ext/dba/dba.c 2015-12-27 07:52:30.381638216 +0100
-@@ -52,6 +52,10 @@
- #include "php_qdbm.h"
+diff -up php-7.2.0alpha0/ext/dba/dba.c.libdb php-7.2.0alpha0/ext/dba/dba.c
+--- php-7.2.0alpha0/ext/dba/dba.c.libdb 2017-05-29 09:16:15.736628202 +0200
++++ php-7.2.0alpha0/ext/dba/dba.c 2017-05-29 09:16:20.494654746 +0200
+@@ -53,6 +53,10 @@
#include "php_tcadb.h"
+ #include "php_lmdb.h"
+#ifdef DB4_INCLUDE_FILE
+#include DB4_INCLUDE_FILE
@@ -79,7 +79,7 @@ diff -up php-7.0.2RC1/ext/dba/dba.c.libdb php-7.0.2RC1/ext/dba/dba.c
/* {{{ arginfo */
ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
ZEND_ARG_INFO(0, path)
-@@ -552,6 +556,10 @@ PHP_MINFO_FUNCTION(dba)
+@@ -558,6 +562,10 @@ PHP_MINFO_FUNCTION(dba)
php_info_print_table_start();
php_info_print_table_row(2, "DBA support", "enabled");
diff --git a/php.spec b/php.spec
index c22d919..a076511 100644
--- a/php.spec
+++ b/php.spec
@@ -125,11 +125,11 @@
%global gh_commit 0722a0188f24a68c18364e2a2bf1443ca2011763
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20170516
+#global gh_date 20170516
%global gh_owner php
%global gh_project php-src
-#global rcver RC1
-%global rpmrel 4
+%global rcver alpha0
+%global rpmrel 5
Summary: PHP scripting language for creating dynamic web sites
@@ -174,7 +174,7 @@ Source52: 20-oci8.ini
Patch5: php-7.2.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
-Patch8: php-7.0.2-libdb.patch
+Patch8: php-7.1.0-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
@@ -735,7 +735,9 @@ Summary: A database abstraction layer module for PHP applications
Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
-BuildRequires: %{db_devel}, tokyocabinet-devel
+BuildRequires: %{db_devel}
+BuildRequires: tokyocabinet-devel
+BuildRequires: lmdb-devel
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%description dba
@@ -1154,6 +1156,7 @@ build --libdir=%{_libdir}/php \
--enable-ctype=shared \
--enable-dba=shared --with-db4=%{_root_prefix} \
--with-tcadb=%{_root_prefix} \
+ --with-lmdb=%{_root_prefix} \
--enable-exif=shared \
--enable-ftp=shared \
--with-gettext=shared \
@@ -1798,6 +1801,10 @@ fi
%changelog
+* Mon May 29 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.5.alpha0
+- test build for release process test, 7.2.0alpha0
+- dba: add --with-lmdb build option
+
* Tue May 16 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.4.20170516.0722a01
- new snapshot