summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-06 08:44:48 +0200
committerRemi Collet <remi@remirepo.net>2017-05-06 08:44:48 +0200
commit149d4371492782247ce188ce32e3411ce9b262c3 (patch)
treecbf18b6aa902a210d283991a5351405ad364d769
parent06abef4eb207ad562eba2e8b0be30c782a56af24 (diff)
refresh + support .phar
-rw-r--r--failed.txt10
-rw-r--r--php-7.0.10-datetests.patch53
-rw-r--r--php.conf2
-rw-r--r--php.conf22
-rw-r--r--php.spec10
5 files changed, 65 insertions, 12 deletions
diff --git a/failed.txt b/failed.txt
index 230fba3..b7c9590 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,15 +1,13 @@
-===== 7.1.0-dev (20170424)
+===== 7.1.0-dev (20170504)
$ grep -r 'Tests failed' /var/lib/mock/scl72*/build.log
-/var/lib/mock/scl72el6x/build.log:Tests failed : 1
-/var/lib/mock/scl72el7x/build.log:Tests failed : 2
+/var/lib/mock/scl72el6x/build.log:Tests failed : 0
+/var/lib/mock/scl72el7x/build.log:Tests failed : 1
/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
/var/lib/mock/scl70fc26x/build.log:Tests failed : 0
-el6x, el7x
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
el7x
(1) Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
@@ -17,5 +15,3 @@ el7x
(1) proc_open give erratic test results :(
(2) test issue (fixed upstream)
(3) known issue
-(4) bugs related to tzdata 2017a (repo) vs 2017b (php)
-
diff --git a/php-7.0.10-datetests.patch b/php-7.0.10-datetests.patch
index 7df99a5..fc42326 100644
--- a/php-7.0.10-datetests.patch
+++ b/php-7.0.10-datetests.patch
@@ -42,3 +42,56 @@ diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strto
string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
bool(false)
string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
+diff -up ./ext/date/tests/bug33414-2.phpt.old ./ext/date/tests/bug33414-2.phpt
+--- ./ext/date/tests/bug33414-2.phpt.old 2017-04-25 15:47:21.675700587 +0200
++++ ./ext/date/tests/bug33414-2.phpt 2017-04-25 15:57:14.034681111 +0200
+@@ -74,10 +74,10 @@ $strtotime_tstamp = strtotime("next Frid
+ print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
+ print "wanted=Friday 00:00:00\n\n";
+ ?>
+---EXPECT--
++--EXPECTF--
+ TZ=Pacific/Rarotonga - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -1030 0
+-result=Tuesday 1970-01-06 00:00:00 -1030 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Tuesday 1970-01-06 00:00:00 %s
+ wanted=Tuesday 00:00:00
+
+ TZ=Atlantic/South_Georgia - wrong day.
+@@ -91,13 +91,13 @@ result=Monday 2005-04-04 00:00:00 EDT 1
+ wanted=Monday 00:00:00
+
+ TZ=Pacific/Enderbury - wrong day, off by 2 days.
+-tStamp=Thursday 1970-01-01 17:17:17 -12 0
+-result=Monday 1970-01-05 00:00:00 -12 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Monday 1970-01-05 00:00:00 %s
+ wanted=Monday 00:00:00
+
+ TZ=Pacific/Kiritimati - wrong day, off by 2 days.
+-tStamp=Thursday 1970-01-01 17:17:17 -1040 0
+-result=Monday 1970-01-05 00:00:00 -1040 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Monday 1970-01-05 00:00:00 %s
+ wanted=Monday 00:00:00
+
+ TZ=America/Managua - wrong day.
+@@ -106,13 +106,13 @@ result=Tuesday 2005-04-12 00:00:00 CDT 1
+ wanted=Tuesday 00:00:00
+
+ TZ=Pacific/Pitcairn - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -0830 0
+-result=Wednesday 1970-01-07 00:00:00 -0830 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Wednesday 1970-01-07 00:00:00 %s
+ wanted=Wednesday 00:00:00
+
+ TZ=Pacific/Fakaofo - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -11 0
+-result=Saturday 1970-01-03 00:00:00 -11 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Saturday 1970-01-03 00:00:00 %s
+ wanted=Saturday 00:00:00
+
+ TZ=Pacific/Johnston - wrong day.
diff --git a/php.conf b/php.conf
index 38f54ae..d192ccf 100644
--- a/php.conf
+++ b/php.conf
@@ -28,7 +28,7 @@ DirectoryIndex index.php
#
# Cause the PHP interpreter to handle files with a .php extension.
#
- <FilesMatch \.php$>
+ <FilesMatch \.(php|phar)$>
SetHandler application/x-httpd-php
</FilesMatch>
diff --git a/php.conf2 b/php.conf2
index fc6de6f..aeed80f 100644
--- a/php.conf2
+++ b/php.conf2
@@ -5,7 +5,7 @@
# Enable http authorization headers
SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
- <FilesMatch \.php$>
+ <FilesMatch \.(php|phar)$>
SetHandler "proxy:fcgi://127.0.0.1:9000"
</FilesMatch>
</IfModule>
diff --git a/php.spec b/php.spec
index 6ff4cd9..0debd2f 100644
--- a/php.spec
+++ b/php.spec
@@ -123,13 +123,13 @@
%global db_devel libdb-devel
%endif
-%global gh_commit eb68c0d525f21fd2f81e2c0833a75cc30df095ce
+%global gh_commit 5af997ed81fc3e86544679d7a07b152ee13d1e04
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20170424
+%global gh_date 20170504
%global gh_owner php
%global gh_project php-src
#global rcver RC1
-%global rpmrel 2
+%global rpmrel 3
Summary: PHP scripting language for creating dynamic web sites
@@ -1798,6 +1798,10 @@ fi
%changelog
+* Sat May 6 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.3.20170504.5af997e
+- new snapshot, May the 4th be with you
+- enable PHP execution of .phar files, see #1117140
+
* Tue Apr 25 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.2.20170424.eb68c0d
- refresh