summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-21 10:35:34 +0200
committerRemi Collet <remi@php.net>2023-06-21 10:35:34 +0200
commita1577464e2c16aac2e59056272c2f05f92faeabe (patch)
treef6720f11fbd3c7177c9324b1061b411b28291b34
parent780e979900cf8f6859a87f8004072845404c7693 (diff)
define %scl_vendor and %_scl_prefix in macros.php71-configHEADmaster
redefine %__phpize and %__phpconfig move man page out of scl tree improve the man page
-rw-r--r--.gitignore8
-rw-r--r--README18
-rw-r--r--macros-build6
-rw-r--r--php71.spec22
4 files changed, 38 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/README b/README
index 98cb9ef..e808e0b 100644
--- a/README
+++ b/README
@@ -23,12 +23,14 @@ which adds support for the PHP language to Apache HTTP server.
The %{?scl_prefix}php-fpm package provides the FastCGI process manager
which adds support for the PHP language to FastCGI compatible servers.
-FastCGI process manager (php-fpm) listens on local network soket
-(by default port 9000).
+FastCGI process manager (php-fpm) listens on local soket
+(by default %{_localstatedir}/run/php-fpm/www.sock).
When working with %{scl_name} collection, use the "scl" utility (see
scl(1) for usage) to enable the scl environment properly.
+You can alternatively use the "module" utility (see module(1) for usage).
+
Configuration for the %{scl_name} software collection is located under %{_sysconfdir}.
Examples:
@@ -46,9 +48,11 @@ scl enable %{scl_name} 'man php'
Show man pages for php command, which is part of the %{scl_name} software
collection.
-%if 0%{?rhel} >= 7
+module load %{scl_name}
+ Enable %{scl_name} software collection in current interactive shell.
+
+module unload %{scl_name}
+ Disable %{scl_name} software collection in current interactive shell.
+
systemctl start %{?scl_prefix}php-fpm
-%else
-service %{?scl_prefix}php-fpm start
-%endif
- Starts the php-fpm server from %{scl_name} software collection. \ No newline at end of file
+ Starts the php-fpm server from %{scl_name} software collection.
diff --git a/macros-build b/macros-build
index 03ff02d..c7cab7c 100644
--- a/macros-build
+++ b/macros-build
@@ -1,9 +1,13 @@
-%_sclreq (%{scl_vendor})
+%scl_vendor @VENDOR@
+%_scl_prefix @PREFIX@
+%_sclreq (@VENDOR@)
%scl_package_override() %{expand:
%{?@SCL@___pear:%global __pear %@SCL@___pear}
%{?@SCL@___pecl:%global __pecl %@SCL@___pecl}
%{?@SCL@___php:%global __php %@SCL@___php}
+ %{?@SCL@___phpize:%global __phpize %@SCL@___phpize}
+ %{?@SCL@___phpconfig:%global __phpconfig %@SCL@___phpconfig}
%{?@SCL@_pecl_xmldir:%global pecl_xmldir %@SCL@_pecl_xmldir}
%global pear_metadir %@SCL@_pear_metadir
%global pear_xmldir %@SCL@_pear_xmldir
diff --git a/php71.spec b/php71.spec
index 70854cd..c8ab483 100644
--- a/php71.spec
+++ b/php71.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php71 SCL metapackage
#
-# Copyright (c) 2016-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -33,10 +33,10 @@
Summary: Package that installs PHP 7.1
Name: %scl_name
-Version: 2.0
+Version: 7.1
Release: 1%{?dist}
Group: Development/Languages
-License: GPLv2+
+License: GPL-2.0-or-later
Source0: macros-build
Source1: README
@@ -162,7 +162,7 @@ cp %{SOURCE2} .
# generate a helper script that will be used by help2man
cat >h2m_helper <<'EOF'
#!/bin/bash
-[ "$1" == "--version" ] && echo "%{scl_name} %{version} Software Collection" || cat README
+[ "$1" == "--version" ] && echo "%{scl_name} Software Collection (PHP %{version})" || cat README
EOF
chmod a+x h2m_helper
@@ -178,7 +178,7 @@ install -D -m 644 envmod %{buildroot}%{_scl_scripts}/%{scl_name}
install -D -m 644 envmod %{buildroot}%{_root_datadir}/Modules/modulefiles/%{scl_name}
%endif
install -D -m 644 scldev %{buildroot}%{macrosdir}/macros.%{scl_name_base}-scldevel
-install -D -m 644 %{scl_name}.7 %{buildroot}%{_mandir}/man7/%{scl_name}.7
+install -D -m 644 %{scl_name}.7 %{buildroot}%{_root_mandir}/man7/%{scl_name}.7
install -d -m 755 %{buildroot}%{_datadir}/licenses
install -d -m 755 %{buildroot}%{_datadir}/doc/pecl
@@ -190,7 +190,7 @@ install -d -m 755 %{buildroot}%{_localstatedir}/lib/pear/pkgxml
cat %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Add the scl_package_override macro
-sed -e 's/@SCL@/%{scl}/g' %{SOURCE0} \
+sed -e 's/@SCL@/%{scl}/g;s:@PREFIX@:/opt/%{scl_vendor}:;s/@VENDOR@/%{scl_vendor}/' %{SOURCE0} \
| tee -a %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Move in correct location, if needed
@@ -238,7 +238,7 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%license LICENSE
%doc README
%scl_files
-%{_mandir}/man7/%{scl_name}.*
+%{_root_mandir}/man7/%{scl_name}.*
%{?_licensedir:%{_datadir}/licenses}
%{_datadir}/tests
%if ! %{with_modules}
@@ -268,6 +268,12 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%changelog
+* Tue Jun 20 2023 Remi Collet <remi@remirepo.net> 7.1-1
+- define %%scl_vendor and %%_scl_prefix in macros.php71-config
+- redefine %%__phpize and %%__phpconfig
+- move man page out of scl tree
+- improve the man page
+
* Wed Feb 20 2019 Remi Collet <remi@remirepo.net> 2.0-1
- add syspaths sub package providing system-wide wrappers