summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-27 17:13:53 +0200
committerRemi Collet <remi@php.net>2022-09-27 17:13:53 +0200
commit0ad5510126784df49f176445cfdb353abe90a4ff (patch)
tree2863751acc56ac3fe8af5c972ffef62efb0c7281 /php.spec
parent2f58ffda72fa3c0f60ac62d49396bc194148f89c (diff)
phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
core: fix #81727 Don't mangle HTTP variable names that clash with ones that have a specific semantic meaning. CVE-2022-31629 use oracle client library version 21.7
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec29
1 files changed, 20 insertions, 9 deletions
diff --git a/php.spec b/php.spec
index 83a5de0..b3b44e2 100644
--- a/php.spec
+++ b/php.spec
@@ -55,7 +55,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -126,7 +126,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 20%{?dist}
+Release: 21%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -221,6 +221,8 @@ Patch228: php-bug81026.patch
Patch229: php-bug79971.patch
Patch230: php-bug81719.patch
Patch231: php-bug81720.patch
+Patch232: php-bug81727.patch
+Patch233: php-bug81726.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -276,6 +278,10 @@ Requires(pre): httpd-filesystem
%else
Requires(pre): httpd
%endif
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# httpd have threaded MPM by default
+Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+%endif
# Don't provides extensions, or shared libraries (embedded)
@@ -324,7 +330,6 @@ The %{?scl_prefix}php-dbg package contains the interactive PHP debugger.
Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
-Requires(pre): %{_root_sbindir}/useradd
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%if %{with_systemd}
BuildRequires: systemd-devel
@@ -344,10 +349,8 @@ Requires(pre): httpd-filesystem
# For php.conf in /etc/httpd/conf.d
# and version 2.4.10 for proxy support in SetHandler
Requires: httpd-filesystem >= 2.4.10
-%endif
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-# httpd have threaded MPM by default
-Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+%else
+Requires(pre): %{_root_sbindir}/useradd
%endif
%description fpm
@@ -863,8 +866,8 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last
-BuildRequires: libicu-devel >= 69
+# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+BuildRequires: libicu-devel = 69.1
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -982,6 +985,8 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch229 -p1 -b .bug79971
%patch230 -p1 -b .bug81719
%patch231 -p1 -b .bug81720
+%patch232 -p1 -b .bug81727
+%patch233 -p1 -b .bug81726
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1945,6 +1950,12 @@ EOF
%changelog
+* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 7.1.33-21
+- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
+- core: fix #81727 Don't mangle HTTP variable names that clash with ones
+ that have a specific semantic meaning. CVE-2022-31629
+- use oracle client library version 21.7
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.1.33-20
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626