summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-11 17:28:48 +0200
committerRemi Collet <remi@remirepo.net>2018-09-11 17:28:48 +0200
commite32148ae460814be3ebb53dddaa9842f07f1f5b6 (patch)
treeafafbe95a10ed8e44c3c2c873f064a421bad0b92
parentb3a2776b7740e27f5aff3893bb4072b655e8badf (diff)
Update to 7.1.22 - http://www.php.net/releases/7_1_22.php
-rw-r--r--be50a72715c141befe6f34ece660745da894aaf3.patch37
-rw-r--r--failed.txt2
-rw-r--r--php.spec7
3 files changed, 44 insertions, 2 deletions
diff --git a/be50a72715c141befe6f34ece660745da894aaf3.patch b/be50a72715c141befe6f34ece660745da894aaf3.patch
new file mode 100644
index 0000000..2bcf82d
--- /dev/null
+++ b/be50a72715c141befe6f34ece660745da894aaf3.patch
@@ -0,0 +1,37 @@
+From be50a72715c141befe6f34ece660745da894aaf3 Mon Sep 17 00:00:00 2001
+From: Jakub Zelenka <bukka@php.net>
+Date: Sun, 9 Sep 2018 18:53:37 +0100
+Subject: [PATCH] Fix ssl stream reneg limit test to print only after first
+ renegotiation
+
+It has been reported that in some setup the test does multiple
+renegotiations which is allowed.
+---
+ ext/openssl/tests/stream_server_reneg_limit.phpt | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/ext/openssl/tests/stream_server_reneg_limit.phpt b/ext/openssl/tests/stream_server_reneg_limit.phpt
+index f0353351a23a..f033cbabe343 100644
+--- a/ext/openssl/tests/stream_server_reneg_limit.phpt
++++ b/ext/openssl/tests/stream_server_reneg_limit.phpt
+@@ -22,14 +22,18 @@ if(substr(PHP_OS, 0, 3) == 'WIN') {
+ */
+
+ $serverCode = <<<'CODE'
++ $printed = false;
+ $serverUri = "ssl://127.0.0.1:64321";
+ $serverFlags = STREAM_SERVER_BIND | STREAM_SERVER_LISTEN;
+ $serverCtx = stream_context_create(['ssl' => [
+ 'local_cert' => __DIR__ . '/bug54992.pem',
+ 'reneg_limit' => 0,
+ 'reneg_window' => 30,
+- 'reneg_limit_callback' => function($stream) {
+- var_dump($stream);
++ 'reneg_limit_callback' => function($stream) use (&$printed) {
++ if (!$printed) {
++ $printed = true;
++ var_dump($stream);
++ }
+ }
+ ]]);
+
diff --git a/failed.txt b/failed.txt
index 9d4795d..b81f137 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.1.22RC1 (2018-08-30)
+===== 7.1.22 (2018-09-13)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
diff --git a/php.spec b/php.spec
index 93855c7..4056aa1 100644
--- a/php.spec
+++ b/php.spec
@@ -121,7 +121,7 @@
%endif
%global upver 7.1.22
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -183,6 +183,7 @@ Patch48: php-7.1.9-openssl-load-config.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: https://github.com/php/php-src/commit/be50a72715c141befe6f34ece660745da894aaf3.patch
# Security fixes (200+)
@@ -904,6 +905,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up1
# security patches
@@ -1844,6 +1846,9 @@ fi
%changelog
+* Tue Sep 11 2018 Remi Collet <remi@remirepo.net> - 7.1.22-1
+- Update to 7.1.22 - http://www.php.net/releases/7_1_22.php
+
* Thu Aug 30 2018 Remi Collet <remi@remirepo.net> - 7.1.22~RC1-1
- update to 7.1.22RC1