summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-03 12:22:27 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-03 12:22:27 +0200
commitdf1ab15ba832b294f61bbfb18938f6253bec6af5 (patch)
tree58e8f763ec0a36c5cb245ded72e961ef6043cf6b
parent3e9f10edd74fdc2f829915b402eb83c74f6251b2 (diff)
PHP 7.1.0beta2
-rw-r--r--failed.txt11
-rw-r--r--php-5.6.3-datetests.patch23
-rw-r--r--php-7.0.10-datetests.patch68
-rw-r--r--php.spec9
4 files changed, 78 insertions, 33 deletions
diff --git a/failed.txt b/failed.txt
index 8d8014b..228f4a7 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,18 +1,15 @@
-===== 7.1.0beta1 (2016-07-21)
+===== 7.1.0beta2 (2016-08-04)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
-/var/lib/mock/scl70el6x/build.log:Tests failed : 3
-/var/lib/mock/scl70el7x/build.log:Tests failed : 3
+/var/lib/mock/scl70el6x/build.log:Tests failed : 1
+/var/lib/mock/scl70el7x/build.log:Tests failed : 1
/var/lib/mock/scl70fc22x/build.log:Tests failed : 1
/var/lib/mock/scl70fc23x/build.log:Tests failed : 1
/var/lib/mock/scl70fc24x/build.log:Tests failed : 1
-el6x, el7x
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
- strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
el6x, el7x, fc22x, fc23x, fc24x
- gzfile() with various invalid params [ext/zlib/tests/004-mb.phpt]
+ ** Test base64_decode() function : basic functionality - padding and whitespace [ext/standard/tests/url/base64_decode_basic_003.phpt]
* proc_open give erratic test results :(
diff --git a/php-5.6.3-datetests.patch b/php-5.6.3-datetests.patch
deleted file mode 100644
index a29bb63..0000000
--- a/php-5.6.3-datetests.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/ext/date/tests/bug66985.phpt 2014-10-30 07:32:03.297693403 +0100
-+++ b/ext/date/tests/bug66985.phpt 2014-10-30 07:32:45.138877977 +0100
-@@ -3,7 +3,7 @@
- --FILE--
- <?php
- $zones = array(
-- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
-+ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
- "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
- "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
- "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
-@@ -45,11 +45,6 @@
- )
- DateTimeZone Object
- (
-- [timezone_type] => 3
-- [timezone] => Factory
--)
--DateTimeZone Object
--(
- [timezone_type] => 3
- [timezone] => GB-Eire
- )
diff --git a/php-7.0.10-datetests.patch b/php-7.0.10-datetests.patch
new file mode 100644
index 0000000..c3a65e9
--- /dev/null
+++ b/php-7.0.10-datetests.patch
@@ -0,0 +1,68 @@
+--- a/ext/date/tests/bug66985.phpt 2014-10-30 07:32:03.297693403 +0100
++++ b/ext/date/tests/bug66985.phpt 2014-10-30 07:32:45.138877977 +0100
+@@ -3,7 +3,7 @@
+ --FILE--
+ <?php
+ $zones = array(
+- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
++ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
+ "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
+ "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
+ "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
+@@ -45,11 +45,6 @@
+ )
+ DateTimeZone Object
+ (
+- [timezone_type] => 3
+- [timezone] => Factory
+-)
+-DateTimeZone Object
+-(
+ [timezone_type] => 3
+ [timezone] => GB-Eire
+ )
+diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strtotime3-64bit.phpt
+--- ./ext/date/tests/strtotime3-64bit.phpt.datetests 2016-07-21 02:23:03.000000000 +0200
++++ ./ext/date/tests/strtotime3-64bit.phpt 2016-07-26 07:39:45.713272263 +0200
+@@ -44,7 +44,7 @@ foreach ($strs as $str) {
+ }
+
+ ?>
+---EXPECT--
++--EXPECTF--
+ bool(false)
+ bool(false)
+ string(31) "Thu, 15 Jun 2006 00:00:00 +0100"
+@@ -53,7 +53,7 @@ bool(false)
+ string(31) "Fri, 16 Jun 2006 23:49:12 +0100"
+ bool(false)
+ string(31) "Fri, 16 Jun 2006 02:22:00 +0100"
+-string(31) "Sun, 16 Jun 0222 02:22:00 -0036"
++string(31) "Sun, 16 Jun 0222 02:22:00 %s"
+ string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
+ bool(false)
+ string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
+diff -up ./ext/date/tests/bug33414-2.phpt.datetests ./ext/date/tests/bug33414-2.phpt
+--- ./ext/date/tests/bug33414-2.phpt.datetests 2016-07-21 02:23:03.000000000 +0200
++++ ./ext/date/tests/bug33414-2.phpt 2016-07-26 07:28:10.323598643 +0200
+@@ -74,7 +74,7 @@ $strtotime_tstamp = strtotime("next Frid
+ print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
+ print "wanted=Friday 00:00:00\n\n";
+ ?>
+---EXPECT--
++--EXPECTF--
+ TZ=Pacific/Rarotonga - wrong day.
+ tStamp=Thursday 1970-01-01 17:17:17 CKT 0
+ result=Tuesday 1970-01-06 00:00:00 CKT 0
+@@ -106,8 +106,8 @@ result=Tuesday 2005-04-12 00:00:00 CDT 1
+ wanted=Tuesday 00:00:00
+
+ TZ=Pacific/Pitcairn - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 PNT 0
+-result=Wednesday 1970-01-07 00:00:00 PNT 0
++tStamp=Thursday 1970-%s
++result=Wednesday 1970-%s
+ wanted=Wednesday 00:00:00
+
+ TZ=Pacific/Fakaofo - wrong day.
+
diff --git a/php.spec b/php.spec
index 8e351d4..933728e 100644
--- a/php.spec
+++ b/php.spec
@@ -124,8 +124,8 @@
%global db_devel libdb-devel
%endif
-%global rcver beta1
-%global rpmrel 6
+%global rcver beta2
+%global rpmrel 7
Summary: PHP scripting language for creating dynamic web sites
@@ -188,7 +188,7 @@ Patch91: php-5.6.3-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
-Patch300: php-5.6.3-datetests.patch
+Patch300: php-7.0.10-datetests.patch
# Revert changes for pcre < 8.34
Patch301: php-7.0.0-oldpcre.patch
@@ -1824,6 +1824,9 @@ fi
%changelog
+* Wed Aug 3 2016 Remi Collet <remi@fedoraproject.org> 7.1.0-0.7.beta2
+- Update to 7.1.0beta2
+
* Thu Jul 21 2016 Remi Collet <remi@fedoraproject.org> 7.1.0-0.6.beta1
- Update to 7.1.0beta1