summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-26 07:05:12 +0200
committerRemi Collet <remi@remirepo.net>2017-04-26 07:05:12 +0200
commitcb56e500719a8e2ac77cda44776be87f9a69ff77 (patch)
tree0b60f16ac773e4f8bd4a65d63e7d05cd39c0d2a9
parent8a73ccb1f5583da2578bdf5903bc41f40b10b1e9 (diff)
7.1.5RC1
-rw-r--r--failed.txt14
-rw-r--r--php-7.0.10-datetests.patch53
-rw-r--r--php.spec30
3 files changed, 74 insertions, 23 deletions
diff --git a/failed.txt b/failed.txt
index 9773c34..7673995 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,24 +1,18 @@
-===== 7.1.4 (2017-04-13)
+===== 7.1.5RC1 (2017-04-27)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
-/var/lib/mock/scl70el6x/build.log:Tests failed : 1
-/var/lib/mock/scl70el7x/build.log:Tests failed : 1
+/var/lib/mock/scl70el6x/build.log:Tests failed : 0
+/var/lib/mock/scl70el7x/build.log:Tests failed : 0
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc24x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
/var/lib/mock/scl70fc26x/build.log:Tests failed : 1
-el6x, el7x
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
-fc24x
- (4) Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
fc26x
(3) ext/openssl/tests/sni_server.phpt
(1) proc_open give erratic test results :(
(2) test issue (fixed upstream)
(3) known issue
-(4) bugs related to tzdata 2017a (repo) vs 2017b (php)
-
diff --git a/php-7.0.10-datetests.patch b/php-7.0.10-datetests.patch
index 7df99a5..fc42326 100644
--- a/php-7.0.10-datetests.patch
+++ b/php-7.0.10-datetests.patch
@@ -42,3 +42,56 @@ diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strto
string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
bool(false)
string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
+diff -up ./ext/date/tests/bug33414-2.phpt.old ./ext/date/tests/bug33414-2.phpt
+--- ./ext/date/tests/bug33414-2.phpt.old 2017-04-25 15:47:21.675700587 +0200
++++ ./ext/date/tests/bug33414-2.phpt 2017-04-25 15:57:14.034681111 +0200
+@@ -74,10 +74,10 @@ $strtotime_tstamp = strtotime("next Frid
+ print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
+ print "wanted=Friday 00:00:00\n\n";
+ ?>
+---EXPECT--
++--EXPECTF--
+ TZ=Pacific/Rarotonga - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -1030 0
+-result=Tuesday 1970-01-06 00:00:00 -1030 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Tuesday 1970-01-06 00:00:00 %s
+ wanted=Tuesday 00:00:00
+
+ TZ=Atlantic/South_Georgia - wrong day.
+@@ -91,13 +91,13 @@ result=Monday 2005-04-04 00:00:00 EDT 1
+ wanted=Monday 00:00:00
+
+ TZ=Pacific/Enderbury - wrong day, off by 2 days.
+-tStamp=Thursday 1970-01-01 17:17:17 -12 0
+-result=Monday 1970-01-05 00:00:00 -12 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Monday 1970-01-05 00:00:00 %s
+ wanted=Monday 00:00:00
+
+ TZ=Pacific/Kiritimati - wrong day, off by 2 days.
+-tStamp=Thursday 1970-01-01 17:17:17 -1040 0
+-result=Monday 1970-01-05 00:00:00 -1040 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Monday 1970-01-05 00:00:00 %s
+ wanted=Monday 00:00:00
+
+ TZ=America/Managua - wrong day.
+@@ -106,13 +106,13 @@ result=Tuesday 2005-04-12 00:00:00 CDT 1
+ wanted=Tuesday 00:00:00
+
+ TZ=Pacific/Pitcairn - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -0830 0
+-result=Wednesday 1970-01-07 00:00:00 -0830 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Wednesday 1970-01-07 00:00:00 %s
+ wanted=Wednesday 00:00:00
+
+ TZ=Pacific/Fakaofo - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 -11 0
+-result=Saturday 1970-01-03 00:00:00 -11 0
++tStamp=Thursday 1970-01-01 17:17:17 %s
++result=Saturday 1970-01-03 00:00:00 %s
+ wanted=Saturday 00:00:00
+
+ TZ=Pacific/Johnston - wrong day.
diff --git a/php.spec b/php.spec
index ef731f1..b94b127 100644
--- a/php.spec
+++ b/php.spec
@@ -26,7 +26,7 @@
%global zendver 20160303
%global pdover 20150127
# Extension version
-%global oci8ver 2.1.3
+%global oci8ver 2.1.4
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -124,14 +124,14 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
-%global rpmrel 1
+%global upver 7.1.5
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.1.4
-Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
+Version: %{upver}%{?rcver:~%{rcver}}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -144,7 +144,7 @@ URL: http://www.php.net/
%if 0%{?gh_date}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}%{?gh_short:-%{gh_short}}.tar.gz
%else
-Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
+Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
%endif
Source1: php.conf
Source2: php.ini
@@ -862,11 +862,11 @@ support for JavaScript Object Notation (JSON) to PHP.
%prep
-: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
+: Building %{name}-%{upver}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%if 0%{?gh_date}
%setup -q -n %{gh_project}-%{gh_commit}
%else
-%setup -q -n php-%{version}%{?rcver}
+%setup -q -n php-%{upver}%{?rcver}
%endif
%patch5 -p1 -b .includedir
@@ -943,8 +943,8 @@ rm Zend/tests/bug68412.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
-if test "x${pver}" != "x%{version}%{?rcver}%{!?rcver:%{?gh_date:-dev}}"; then
- : Error: Upstream PHP version is now ${pver}, expecting %{version}%{?rcver}%{!?rcver:%{?gh_date:-dev}}.
+if test "x${pver}" != "x%{upver}%{?rcver}%{!?rcver:%{?gh_date:-dev}}"; then
+ : Error: Upstream PHP version is now ${pver}, expecting %{upver}%{?rcver}%{!?rcver:%{?gh_date:-dev}}.
: Update the version/rcver macros and rebuild.
exit 1
fi
@@ -998,7 +998,7 @@ chmod 644 README.*
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "s/@PHP_ZENDVER@/%{zendver}%{isasuffix}/" \
-e "s/@PHP_PDOVER@/%{pdover}%{isasuffix}/" \
- -e "s/@PHP_VERSION@/%{version}/" \
+ -e "s/@PHP_VERSION@/%{upver}/" \
-e "s:@LIBDIR@:%{_libdir}:" \
-e "s:@ETCDIR@:%{_sysconfdir}:" \
-e "s:@INCDIR@:%{_includedir}:" \
@@ -1524,8 +1524,8 @@ extension=${mod}.so
EOF
fi
cat > files.${mod} <<EOF
-%attr(755,root,root) %{_libdir}/php/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php.d/${ini}
+%{_libdir}/php/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php.d/${ini}
EOF
done
@@ -1813,6 +1813,10 @@ fi
%changelog
+* Tue Apr 25 2017 Remi Collet <remi@fedoraproject.org> - 7.1.5~RC1-1
+- Update to 7.1.5RC1
+- oci8 version is now 2.1.4
+
* Tue Apr 11 2017 Remi Collet <remi@fedoraproject.org> - 7.1.4-1
- Update to 7.1.4 - http://www.php.net/releases/7_1_4.php