summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-16 19:18:51 +0200
committerRemi Collet <remi@remirepo.net>2017-08-16 19:18:51 +0200
commit9e58eb27b2b0412f05fc5814efc57e703b362cec (patch)
tree187643a56579f373273fe5dcbc8ebfbd3aead95b
parent6272b285455841ae1b684610d31f6341c7f7731d (diff)
Update to 7.1.9RC1
oci8 version is now 2.1.7
-rw-r--r--failed.txt6
-rw-r--r--php-sqlite3.patch53
-rw-r--r--php.spec15
3 files changed, 12 insertions, 62 deletions
diff --git a/failed.txt b/failed.txt
index 4ead7aa..8554c6f 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.1.8 (2017-08-03)
+===== 7.1.9RC1 (2017-08-17)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
@@ -6,10 +6,12 @@ $ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
/var/lib/mock/scl70el7x/build.log:Tests failed : 0
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
+/var/lib/mock/scl70fc25x/build.log:Tests failed : 1
/var/lib/mock/scl70fc26x/build.log:Tests failed : 0
+fc25x
+ 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
1 proc_open give erratic test results :(
diff --git a/php-sqlite3.patch b/php-sqlite3.patch
deleted file mode 100644
index cdb7d84..0000000
--- a/php-sqlite3.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 666cb6c80226467be262c088a26246c48cdef7e5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 2 Aug 2017 14:01:56 +0200
-Subject: [PATCH] fix build with old system libsqlite (sqlite3_errstr may be
- missing)
-
----
- ext/sqlite3/config0.m4 | 5 ++++-
- ext/sqlite3/sqlite3.c | 4 ++++
- 2 files changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
-index 3aa4492..ba760e1 100644
---- a/ext/sqlite3/config0.m4
-+++ b/ext/sqlite3/config0.m4
-@@ -53,6 +53,9 @@ if test $PHP_SQLITE3 != "no"; then
- PHP_CHECK_LIBRARY(sqlite3,sqlite3_column_table_name,[
- AC_DEFINE(SQLITE_ENABLE_COLUMN_METADATA, 1, [have sqlite3 with column metadata enabled])
- ])
-+ PHP_CHECK_LIBRARY(sqlite3,sqlite3_errstr,[
-+ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
-+ ])
-
- PHP_CHECK_LIBRARY(sqlite3,sqlite3_load_extension,
- [],
-@@ -75,7 +78,7 @@ if test $PHP_SQLITE3 != "no"; then
- debug_flags="-DSQLITE_DEBUG=1"
- fi
-
-- other_flags="-DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS4=1 -DSQLITE_ENABLE_FTS5=1 -DSQLITE_CORE=1 -DSQLITE_ENABLE_COLUMN_METADATA=1"
-+ other_flags="-DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS4=1 -DSQLITE_ENABLE_FTS5=1 -DSQLITE_CORE=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DHAVE_SQLITE3_ERRSTR=1"
-
- dnl As long as intl is not shared we can have ICU support
- if test "$PHP_INTL" = "yes" && test "$PHP_INTL_SHARED" != "yes"; then
-diff --git a/ext/sqlite3/sqlite3.c b/ext/sqlite3/sqlite3.c
-index dcbc03c..a22f455 100644
---- a/ext/sqlite3/sqlite3.c
-+++ b/ext/sqlite3/sqlite3.c
-@@ -148,7 +148,11 @@ PHP_METHOD(sqlite3, open)
- #endif
- if (rc != SQLITE_OK) {
- zend_throw_exception_ex(zend_ce_exception, 0, "Unable to open database: %s",
-+#ifdef HAVE_SQLITE3_ERRSTR
- db_obj->db ? sqlite3_errmsg(db_obj->db) : sqlite3_errstr(rc));
-+#else
-+ db_obj->db ? sqlite3_errmsg(db_obj->db) : "");
-+#endif
- if (fullpath != filename) {
- efree(fullpath);
- }
---
-2.1.4
-
diff --git a/php.spec b/php.spec
index 9dbef1c..559c2f9 100644
--- a/php.spec
+++ b/php.spec
@@ -26,7 +26,7 @@
%global zendver 20160303
%global pdover 20150127
# Extension version
-%global oci8ver 2.1.6
+%global oci8ver 2.1.7
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -124,14 +124,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.8
-#global rcver RC1
-
+%global upver 7.1.9
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -168,7 +167,6 @@ Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
-Patch10: php-sqlite3.patch
# Functional changes
Patch40: php-7.1.3-dlopen.patch
@@ -877,7 +875,6 @@ support for JavaScript Object Notation (JSON) to PHP.
%if 0%{?rhel}
%patch9 -p1 -b .curltls
%endif
-%patch10 -p1 -b .errstr
%patch40 -p1 -b .dlopen
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 5
@@ -1815,6 +1812,10 @@ fi
%changelog
+* Wed Aug 16 2017 Remi Collet <remi@fedoraproject.org> - 7.1.9~RC1-1
+- Update to 7.1.9RC1
+- oci8 version is now 2.1.7
+
* Wed Aug 2 2017 Remi Collet <remi@fedoraproject.org> - 7.1.8-2
- add patch for EL-6, fix undefined symbol: sqlite3_errstr