summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-18 09:25:39 +0100
committerRemi Collet <remi@remirepo.net>2019-01-18 09:25:39 +0100
commit9bed2bb4736eec26b858d651407cf24f65e70a05 (patch)
treed2c22653084b2ea49363b901071f3800909656b1
parent1262f4d8c44c648545661f06997e0ff34749957f (diff)
cleanup for EL-8
-rw-r--r--php.spec28
1 files changed, 18 insertions, 10 deletions
diff --git a/php.spec b/php.spec
index 1830605..04114a2 100644
--- a/php.spec
+++ b/php.spec
@@ -71,7 +71,12 @@
# Optional components; pass "--with mssql" etc to rpmbuild.
%global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
%global with_imap 1
+# until firebird available in EPEL
+%if 0%{?rhel} == 8
+%global with_interbase 0
+%else
%global with_interbase 1
+%endif
%global with_mcrypt 1
%global with_freetds 1
%global with_tidy 1
@@ -104,7 +109,7 @@
%global with_systemd 0
%endif
# httpd 2.4.10 with httpd-filesystem and sethandler support
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
%global with_httpd2410 1
%else
%global with_httpd2410 0
@@ -126,7 +131,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -308,7 +313,7 @@ Requires(pre): httpd-filesystem
# and version 2.4.10 for proxy support in SetHandler
Requires: httpd-filesystem >= 2.4.10
%endif
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# httpd have threaded MPM by default
Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
%endif
@@ -1023,7 +1028,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "s:@BINDIR@:%{_bindir}:" \
-e "s:@SCL@:%{?scl:%{scl}_}:" \
%{SOURCE3} | tee macros.php
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
echo '%%%{?scl:%{scl}_}pecl_xmldir %{_localstatedir}/lib/php/peclxml' | tee -a macros.php
%endif
@@ -1381,7 +1386,7 @@ install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/opcache
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/peclxml
install -m 755 -d $RPM_BUILD_ROOT%{_docdir}/pecl
install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/tests/pecl
@@ -1414,7 +1419,7 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default .
# install systemd unit files and scripts for handling server startup
%if %{with_systemd}
install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
@@ -1457,7 +1462,7 @@ sed -e 's:/run:%{_localstatedir}/run:' \
-i $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
# Environment file
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
%else
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
@@ -1703,7 +1708,7 @@ fi
%dir %{_libdir}/php/modules
%dir %{_localstatedir}/lib/php
%dir %{_datadir}/php
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
%dir %{_localstatedir}/lib/php/peclxml
%dir %{_docdir}/pecl
%dir %{_datadir}/tests
@@ -1749,13 +1754,13 @@ fi
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
-%if 0%{?fedora} < 26
+%if 0%{?fedora} < 26 && 0%{?rhel} < 8
%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
%endif
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
@@ -1849,6 +1854,9 @@ fi
%changelog
+* Fri Jan 18 2019 Remi Collet <remi@remirepo.net> - 7.1.26-2
+- cleanup for EL-8
+
* Wed Jan 9 2019 Remi Collet <remi@remirepo.net> - 7.1.26-1
- Update to 7.1.26 - http://www.php.net/releases/7_1_26.php