summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-28 13:03:15 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-28 13:03:15 +0100
commit462cc938d67e400e7bcff04bee041b1d2661292e (patch)
tree272dc147390aabdbee9a97eea136fbf71b130b83
parenta54cbbc2cb2e7690e8391c7c31a0b58b485447ec (diff)
PHP 7.1.3RC1
-rw-r--r--failed.txt14
-rw-r--r--php-7.1.3-dlopen.patch (renamed from php-7.0.0-dlopen.patch)18
-rw-r--r--php.spec9
3 files changed, 23 insertions, 18 deletions
diff --git a/failed.txt b/failed.txt
index 6c3c2f1..6e18e6a 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,15 +1,17 @@
-===== 7.1.2 (2017-02-16)
+===== 7.1.3RC1 (2017-03-02)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
/var/lib/mock/scl70el6x/build.log:Tests failed : 0
-/var/lib/mock/scl70el7x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc22x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
+/var/lib/mock/scl70el7x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc22x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc23x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc24x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc25x/build.log:Tests failed : 1
+el7x, fc22x, fc23x, fc24x, fc25x:
+ ** Bug #74093 (Maximum execution time of n+2 seconds exceed not written in error_log) [Zend/tests/bug74093.phpt]
* proc_open give erratic test results :(
diff --git a/php-7.0.0-dlopen.patch b/php-7.1.3-dlopen.patch
index 4047460..cd35dc0 100644
--- a/php-7.0.0-dlopen.patch
+++ b/php-7.1.3-dlopen.patch
@@ -1,7 +1,7 @@
-diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespeed/lsapilib.c
---- php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen 2015-08-18 23:39:17.000000000 +0200
-+++ php-7.0.0RC1/sapi/litespeed/lsapilib.c 2015-08-22 07:46:31.729721983 +0200
-@@ -582,7 +582,7 @@ static int (*fp_lve_leave)(struct liblve
+diff -up php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen php-7.1.3RC1/sapi/litespeed/lsapilib.c
+--- php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen 2017-02-28 10:12:34.000000000 +0100
++++ php-7.1.3RC1/sapi/litespeed/lsapilib.c 2017-02-28 10:23:11.384521740 +0100
+@@ -616,7 +616,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
static int lsapi_load_lve_lib()
{
@@ -10,16 +10,16 @@ diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespe
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-7.0.0RC1/Zend/zend_portability.h.dlopen php-7.0.0RC1/Zend/zend_portability.h
---- php-7.0.0RC1/Zend/zend_portability.h.dlopen 2015-08-18 23:39:16.000000000 +0200
-+++ php-7.0.0RC1/Zend/zend_portability.h 2015-08-22 07:46:31.729721983 +0200
-@@ -136,11 +136,11 @@
+diff -up php-7.1.3RC1/Zend/zend_portability.h.dlopen php-7.1.3RC1/Zend/zend_portability.h
+--- php-7.1.3RC1/Zend/zend_portability.h.dlopen 2017-02-28 10:23:11.384521740 +0100
++++ php-7.1.3RC1/Zend/zend_portability.h 2017-02-28 10:26:08.960308560 +0100
+@@ -146,11 +146,11 @@
# endif
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
- # elif defined(RTLD_DEEPBIND)
+ # elif defined(RTLD_DEEPBIND) && !defined(__SANITIZE_ADDRESS__)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_DEEPBIND)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND)
# else
diff --git a/php.spec b/php.spec
index 463ed65..abcddd0 100644
--- a/php.spec
+++ b/php.spec
@@ -124,13 +124,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.1.2
+Version: 7.1.3
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -168,7 +168,7 @@ Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch40: php-7.0.0-dlopen.patch
+Patch40: php-7.1.3-dlopen.patch
Patch42: php-7.1.0-systzdata-v14.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
@@ -1808,6 +1808,9 @@ fi
%changelog
+* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> 7.1.3-0.1.RC1
+- Update to 7.1.3RC1
+
* Wed Feb 15 2017 Remi Collet <remi@fedoraproject.org> - 7.1.2-1
- Update to 7.1.2 - http://www.php.net/releases/7_1_2.php