summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-14 14:36:52 +0100
committerRemi Collet <remi@remirepo.net>2018-03-14 14:36:52 +0100
commit25208813ba6020722084797f7474029745ad87e4 (patch)
tree094b015c378ae41a280dc45081e424d0bfbccb9c
parent9dba473bacb55479bc934501af9410bda2c968dc (diff)
v7.1.16RC1
-rw-r--r--failed.txt12
-rw-r--r--php-7.1.16-dlopen.patch (renamed from php-7.1.3-dlopen.patch)16
-rw-r--r--php.spec11
3 files changed, 20 insertions, 19 deletions
diff --git a/failed.txt b/failed.txt
index 5539f69..53cfde3 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,19 +1,17 @@
-===== 7.1.15 (2018-03-01)
+===== 7.1.16RC1 (2018-03-15)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
/var/lib/mock/scl71el6x/build.log:Tests failed : 0
/var/lib/mock/scl71el7x/build.log:Tests failed : 0
-/var/lib/mock/scl71fc25x/build.log:Tests failed : 1
-/var/lib/mock/scl71fc26x/build.log:Tests failed : 1
-/var/lib/mock/scl71fc27x/build.log:Tests failed : 0
+/var/lib/mock/scl71fc25x/build.log:Tests failed : 0
+/var/lib/mock/scl71fc26x/build.log:Tests failed : 0
+/var/lib/mock/scl71fc27x/build.log:Tests failed : 1
/var/lib/mock/scl71fc28x/build.log:Tests failed : 0
-fc25x:
+fc27x
1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-fc26x:
- 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
1 proc_open give erratic test results :(
diff --git a/php-7.1.3-dlopen.patch b/php-7.1.16-dlopen.patch
index cd35dc0..7ace226 100644
--- a/php-7.1.3-dlopen.patch
+++ b/php-7.1.16-dlopen.patch
@@ -1,18 +1,18 @@
-diff -up php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen php-7.1.3RC1/sapi/litespeed/lsapilib.c
---- php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen 2017-02-28 10:12:34.000000000 +0100
-+++ php-7.1.3RC1/sapi/litespeed/lsapilib.c 2017-02-28 10:23:11.384521740 +0100
-@@ -616,7 +616,7 @@ static int (*fp_lve_leave)(struct liblve
+diff -up php-7.1.16RC1/sapi/litespeed/lsapilib.c.dlopen php-7.1.16RC1/sapi/litespeed/lsapilib.c
+--- php-7.1.16RC1/sapi/litespeed/lsapilib.c.dlopen 2018-03-14 13:19:47.998931942 +0100
++++ php-7.1.16RC1/sapi/litespeed/lsapilib.c 2018-03-14 13:20:30.942148432 +0100
+@@ -755,7 +755,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
- static int lsapi_load_lve_lib()
+ static int lsapi_load_lve_lib(void)
{
- s_liblve = dlopen("liblve.so.0", RTLD_LAZY);
+ s_liblve = dlopen("liblve.so.0", RTLD_NOW);
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-7.1.3RC1/Zend/zend_portability.h.dlopen php-7.1.3RC1/Zend/zend_portability.h
---- php-7.1.3RC1/Zend/zend_portability.h.dlopen 2017-02-28 10:23:11.384521740 +0100
-+++ php-7.1.3RC1/Zend/zend_portability.h 2017-02-28 10:26:08.960308560 +0100
+diff -up php-7.1.16RC1/Zend/zend_portability.h.dlopen php-7.1.16RC1/Zend/zend_portability.h
+--- php-7.1.16RC1/Zend/zend_portability.h.dlopen 2018-03-14 06:00:31.000000000 +0100
++++ php-7.1.16RC1/Zend/zend_portability.h 2018-03-14 13:19:47.998931942 +0100
@@ -146,11 +146,11 @@
# endif
diff --git a/php.spec b/php.spec
index bd0cdb2..05ee324 100644
--- a/php.spec
+++ b/php.spec
@@ -120,13 +120,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.15
-#global rcver RC1
+%global upver 7.1.16
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -167,7 +167,7 @@ Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch40: php-7.1.3-dlopen.patch
+Patch40: php-7.1.16-dlopen.patch
Patch42: php-7.1.0-systzdata-v14.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
@@ -1833,6 +1833,9 @@ fi
%changelog
+* Wed Mar 14 2018 Remi Collet <remi@remirepo.net> - 7.1.16~RC1-1
+- Update to 7.1.16RC1
+
* Fri Mar 2 2018 Remi Collet <remi@remirepo.net> - 7.1.15-2
- devel: drop dependency on devtoolset