summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-31 08:20:16 +0200
committerRemi Collet <remi@remirepo.net>2017-08-31 08:20:16 +0200
commit0fd0943e1c752bafc7ca85c6009bbccc2a30697a (patch)
treef3a4760cc20f9e7849f70a1a24222f72020fb16a
parent75b0e84ddbead52d7eccaf3eb700c2a955b3bbaa (diff)
add patch for EL-6, fix undefined symbol: sqlite3_errstr
-rw-r--r--php-upstream.patch30
-rw-r--r--php.spec7
2 files changed, 36 insertions, 1 deletions
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..448fd7c
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,30 @@
+From 3239f6d6798d86fdbf8e03aa741d9990bcfffe79 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 31 Aug 2017 07:55:45 +0200
+Subject: [PATCH] move AC_DEFINE in the right position (in bundled lib
+ conditon)
+
+---
+ ext/sqlite3/config0.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
+index 0e5fbc5..78fd622 100644
+--- a/ext/sqlite3/config0.m4
++++ b/ext/sqlite3/config0.m4
+@@ -85,11 +85,11 @@ if test $PHP_SQLITE3 != "no"; then
+ other_flags="$other_flags -DSQLITE_ENABLE_ICU=1"
+ fi
+
++ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
+ PHP_INSTALL_HEADERS([ext/sqlite3/libsqlite/sqlite3.h])
+ fi
+
+- AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ AC_DEFINE(HAVE_SQLITE3,1,[ ])
+
+ sqlite3_sources="sqlite3.c $sqlite3_extra_sources"
+--
+2.1.4
+
diff --git a/php.spec b/php.spec
index 9647cd3..50d6a75 100644
--- a/php.spec
+++ b/php.spec
@@ -126,7 +126,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -181,6 +181,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -888,6 +889,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -1806,6 +1808,9 @@ fi
%changelog
+* Thu Aug 31 2017 Remi Collet <remi@fedoraproject.org> - 7.1.9-2
+- add patch for EL-6, fix undefined symbol: sqlite3_errstr
+
* Wed Aug 30 2017 Remi Collet <remi@fedoraproject.org> - 7.1.9-1
- Update to 7.1.9 - http://www.php.net/releases/7_1_9.php