summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-22 07:39:19 +0100
committerRemi Collet <remi@remirepo.net>2018-11-22 07:39:19 +0100
commit017223a1e4841dab610a69b81c14348abee67e6c (patch)
treed9bd03e8fd0d137bbd39c7c211a1e107f29551a5
parent11dd2d528215ac2a5af1f992f86fa9a1796aadcc (diff)
v7.1.25RC1
-rw-r--r--3666.patch29
-rw-r--r--failed.txt2
-rw-r--r--php.spec13
3 files changed, 8 insertions, 36 deletions
diff --git a/3666.patch b/3666.patch
deleted file mode 100644
index cd88697..0000000
--- a/3666.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7ded74876ff287a4d6d8a12d933e003b61f6488a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 15 Nov 2018 08:58:08 +0100
-Subject: [PATCH] Fix #77151 ftp_close(): SSL_read on shutdown
-
-Regression introduced in fix for #76972
----
- ext/ftp/ftp.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/ext/ftp/ftp.c b/ext/ftp/ftp.c
-index 88553b969c29..a7d5ebbea13c 100644
---- a/ext/ftp/ftp.c
-+++ b/ext/ftp/ftp.c
-@@ -1770,10 +1770,10 @@ static void ftp_ssl_shutdown(ftpbuf_t *ftp, php_socket_t fd, SSL *ssl_handle) {
- done = 0;
- }
-
-- while (!done) {
-- if (data_available(ftp, fd)) {
-- ERR_clear_error();
-- nread = SSL_read(ssl_handle, buf, sizeof(buf));
-+ while (!done && data_available(ftp, fd)) {
-+ ERR_clear_error();
-+ nread = SSL_read(ssl_handle, buf, sizeof(buf));
-+ if (nread <= 0) {
- err = SSL_get_error(ssl_handle, nread);
- switch (err) {
- case SSL_ERROR_NONE: /* this is not an error */
diff --git a/failed.txt b/failed.txt
index 85be6c3..f4fe290 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.1.24 (2018-11-08)
+===== 7.1.25RC1 (2018-11-22)
$ grep -r 'Tests failed' /var/lib/mock/scl71*/build.log
diff --git a/php.spec b/php.spec
index 6319d2b..cd31434 100644
--- a/php.spec
+++ b/php.spec
@@ -120,13 +120,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.24
-#global rcver RC1
+%global upver 7.1.25
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -195,7 +195,6 @@ Patch300: php-7.0.10-datetests.patch
Patch301: php-7.0.0-oldpcre.patch
# WIP
-Patch400: https://patch-diff.githubusercontent.com/raw/php/php-src/pull/3666.patch
BuildRequires: bzip2-devel, curl-devel >= 7.9, %{db_devel}
BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
@@ -919,7 +918,6 @@ if ! pkg-config libpcre --atleast-version 8.34 ; then
%patch301 -p1 -b .pcre834
fi
%endif
-%patch400 -p1 -b .pr3666
# WIP patch
@@ -1851,7 +1849,10 @@ fi
%changelog
-* Thu Nov 15 2018 Remi Collet <remi@remirepo.net> - 7.1.24-2
+* Thu Nov 22 2018 Remi Collet <remi@remirepo.net> - 7.1.25~RC1-1
+- update to 7.1.25RC1
+
+* Thu Nov 15 2018 Remi Collet <remi@remirepo.net> - 7.1.24-3
- test build for https://github.com/php/php-src/pull/3666
* Wed Nov 7 2018 Remi Collet <remi@remirepo.net> - 7.1.24-1