summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--10-opcache.ini2
-rw-r--r--failed.txt10
-rw-r--r--php.spec11
3 files changed, 17 insertions, 6 deletions
diff --git a/10-opcache.ini b/10-opcache.ini
index cfbff55..8e127cb 100644
--- a/10-opcache.ini
+++ b/10-opcache.ini
@@ -108,4 +108,4 @@ opcache.blacklist_filename=/etc/php.d/opcache*.blacklist
; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
; This should improve performance, but requires appropriate OS configuration.
-;opcache.huge_code_pages=0
+opcache.huge_code_pages=0
diff --git a/failed.txt b/failed.txt
index a1ffe5e..b006ad2 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,16 +1,20 @@
-===== 7.0.0-0.24.RC7 (2015-11-12)
+===== 7.0.0-0.25.RC8 (2015-11-25)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
/var/lib/mock/scl70el6x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
-/var/lib/mock/scl70el7x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70el7x/build.log:Tests failed : 6 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc20x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%
-/var/lib/mock/scl70fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70fc22x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
el6x, el7x, fc20x
Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
+el7x
+ Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
+fc22x
+ Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
* proc_open give erratic test results :(
diff --git a/php.spec b/php.spec
index a081cc8..d0316e0 100644
--- a/php.spec
+++ b/php.spec
@@ -130,8 +130,8 @@
#global gh_date 20150623
#global gh_owner php
#global gh_project php-src
-%global rcver RC7
-%global rpmrel 24
+%global rcver RC8
+%global rpmrel 25
Summary: PHP scripting language for creating dynamic web sites
@@ -1027,6 +1027,9 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
# Some extensions have their own configuration file
cp %{SOURCE50} 10-opcache.ini
+%ifarch x86_64
+sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
+%endif
cp %{SOURCE51} .
sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
-i 10-opcache.ini
@@ -1803,6 +1806,10 @@ fi
%changelog
+* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.25.RC8
+- Update to 7.0.0RC8
+- set opcache.huge_code_pages=1 on x86_64
+
* Thu Nov 12 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.24.RC7
- Update to 7.0.0RC7 (retagged)