summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt12
-rw-r--r--php-5.6.3-phpinfo.patch14
-rw-r--r--php-7.0.0-dlopen.patch15
-rw-r--r--php-7.0.0-odbctimer.patch12
-rw-r--r--php-7.0.0-systzdata-v12.patch26
-rw-r--r--php.spec7
6 files changed, 44 insertions, 42 deletions
diff --git a/failed.txt b/failed.txt
index 306478b..a5f77f7 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,16 +1,14 @@
-===== 7.0.0-0.13.beta3
+===== 7.0.0-0.14.RC1
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
/var/lib/mock/scl70el6x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/scl70el7x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
-/var/lib/mock/scl70fc20x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70el7x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70fc20x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%
-/var/lib/mock/scl70fc22x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-el7, f20, f22
+f20
Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
-f20, f22
- Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
* proc_open give erratic test results :(
diff --git a/php-5.6.3-phpinfo.patch b/php-5.6.3-phpinfo.patch
index 690e121..086be15 100644
--- a/php-5.6.3-phpinfo.patch
+++ b/php-5.6.3-phpinfo.patch
@@ -3,9 +3,10 @@ Drop "Configure Command" from phpinfo as it doesn't
provide any useful information.
The available extensions are not related to this command.
---- a/ext/standard/info.c.orig 2012-12-11 10:43:02.450578276 +0100
-+++ b/ext/standard/info.c 2012-12-11 10:44:12.530820821 +0100
-@@ -660,9 +660,6 @@
+diff -up php-7.0.0RC1/ext/standard/info.c.phpinfo php-7.0.0RC1/ext/standard/info.c
+--- php-7.0.0RC1/ext/standard/info.c.phpinfo 2015-08-18 23:39:24.000000000 +0200
++++ php-7.0.0RC1/ext/standard/info.c 2015-08-22 07:56:18.344761928 +0200
+@@ -870,9 +870,6 @@ PHPAPI void php_print_info(int flag)
#ifdef ARCHITECTURE
php_info_print_table_row(2, "Architecture", ARCHITECTURE);
#endif
@@ -15,9 +16,10 @@ The available extensions are not related to this command.
if (sapi_module.pretty_name) {
php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
---- a/ext/standard/tests/general_functions/phpinfo.phpt.orig 2012-12-11 11:07:26.959156091 +0100
-+++ b/ext/standard/tests/general_functions/phpinfo.phpt 2012-12-11 11:07:30.899170970 +0100
-@@ -20,7 +20,6 @@
+diff -up php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt
+--- php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo 2015-08-18 23:39:22.000000000 +0200
++++ php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt 2015-08-22 07:56:18.344761928 +0200
+@@ -20,7 +20,6 @@ PHP Version => %s
System => %s
Build Date => %s%a
diff --git a/php-7.0.0-dlopen.patch b/php-7.0.0-dlopen.patch
index 0cef75f..4047460 100644
--- a/php-7.0.0-dlopen.patch
+++ b/php-7.0.0-dlopen.patch
@@ -1,6 +1,6 @@
-diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/sapi/litespeed/lsapilib.c.dlopen php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/sapi/litespeed/lsapilib.c
---- php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/sapi/litespeed/lsapilib.c.dlopen 2015-03-25 08:54:25.529213259 +0100
-+++ php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/sapi/litespeed/lsapilib.c 2015-03-25 08:54:57.937345809 +0100
+diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespeed/lsapilib.c
+--- php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen 2015-08-18 23:39:17.000000000 +0200
++++ php-7.0.0RC1/sapi/litespeed/lsapilib.c 2015-08-22 07:46:31.729721983 +0200
@@ -582,7 +582,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
static int lsapi_load_lve_lib()
@@ -10,11 +10,10 @@ diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/sapi/litespeed/lsapili
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/Zend/zend.h.dlopen php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/Zend/zend.h
-diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/Zend/zend_portability.h.dlopen php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/Zend/zend_portability.h
---- php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/Zend/zend_portability.h.dlopen 2015-03-25 08:53:31.701993105 +0100
-+++ php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/Zend/zend_portability.h 2015-03-25 08:56:09.976640451 +0100
-@@ -122,11 +122,11 @@
+diff -up php-7.0.0RC1/Zend/zend_portability.h.dlopen php-7.0.0RC1/Zend/zend_portability.h
+--- php-7.0.0RC1/Zend/zend_portability.h.dlopen 2015-08-18 23:39:16.000000000 +0200
++++ php-7.0.0RC1/Zend/zend_portability.h 2015-08-22 07:46:31.729721983 +0200
+@@ -136,11 +136,11 @@
# endif
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
diff --git a/php-7.0.0-odbctimer.patch b/php-7.0.0-odbctimer.patch
index 6f43dcd..18bcf0f 100644
--- a/php-7.0.0-odbctimer.patch
+++ b/php-7.0.0-odbctimer.patch
@@ -1,7 +1,7 @@
-diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/ext/odbc/php_odbc.c.odbctimer php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/ext/odbc/php_odbc.c
---- php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/ext/odbc/php_odbc.c.odbctimer 2015-03-25 07:01:04.000000000 +0100
-+++ php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/ext/odbc/php_odbc.c 2015-03-25 08:45:27.265011747 +0100
-@@ -431,7 +431,8 @@ static void _free_odbc_result(zend_resou
+diff -up php-7.0.0RC1/ext/odbc/php_odbc.c.odbctimer php-7.0.0RC1/ext/odbc/php_odbc.c
+--- php-7.0.0RC1/ext/odbc/php_odbc.c.odbctimer 2015-08-18 23:39:26.000000000 +0200
++++ php-7.0.0RC1/ext/odbc/php_odbc.c 2015-08-22 07:44:51.170196466 +0200
+@@ -434,7 +434,8 @@ static void _free_odbc_result(zend_resou
efree(res->values);
res->values = NULL;
}
@@ -11,7 +11,7 @@ diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/ext/odbc/php_odbc.c.od
#if defined(HAVE_SOLID) || defined(HAVE_SOLID_30) || defined(HAVE_SOLID_35)
SQLTransact(res->conn_ptr->henv, res->conn_ptr->hdbc,
(SQLUSMALLINT) SQL_COMMIT);
-@@ -481,9 +482,12 @@ static void _close_odbc_conn(zend_resour
+@@ -484,9 +485,12 @@ static void _close_odbc_conn(zend_resour
}
} ZEND_HASH_FOREACH_END();
@@ -27,7 +27,7 @@ diff -up php-src-02be73b5fac63a02313b9fe0f204c65d4828edeb/ext/odbc/php_odbc.c.od
efree(conn);
ODBCG(num_links)--;
}
-@@ -506,9 +510,12 @@ static void _close_odbc_pconn(zend_resou
+@@ -509,9 +513,12 @@ static void _close_odbc_pconn(zend_resou
}
} ZEND_HASH_FOREACH_END();
diff --git a/php-7.0.0-systzdata-v12.patch b/php-7.0.0-systzdata-v12.patch
index af5b3a6..560faef 100644
--- a/php-7.0.0-systzdata-v12.patch
+++ b/php-7.0.0-systzdata-v12.patch
@@ -20,9 +20,9 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
-diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.c.systzdata php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.c
---- php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.c.systzdata 2015-05-07 07:46:56.000000000 +0200
-+++ php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.c 2015-05-07 08:31:21.444876177 +0200
+diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/lib/parse_tz.c
+--- php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata 2015-08-18 23:39:24.000000000 +0200
++++ php-7.0.0RC1/ext/date/lib/parse_tz.c 2015-08-22 07:54:38.097258458 +0200
@@ -20,6 +20,16 @@
#include "timelib.h"
@@ -40,12 +40,12 @@ diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.
#include <stdio.h>
#ifdef HAVE_LOCALE_H
-@@ -31,7 +41,12 @@
- #else
+@@ -32,8 +42,12 @@
#include <strings.h>
#endif
-+
+
+#ifndef HAVE_SYSTEM_TZDATA
+ #define TIMELIB_SUPPORTS_V2DATA
#include "timezonedb.h"
+#endif
+
@@ -53,7 +53,7 @@ diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
# if defined(__LITTLE_ENDIAN__)
-@@ -53,6 +68,11 @@ static int read_preamble(const unsigned
+@@ -55,6 +69,11 @@ static int read_preamble(const unsigned
{
uint32_t version;
@@ -65,7 +65,7 @@ diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.
/* read ID */
version = (*tzf)[3] - '0';
*tzf += 4;
-@@ -296,7 +316,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -298,7 +317,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
}
}
@@ -485,7 +485,7 @@ diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.
{
int left = 0, right = tzdb->index_size - 1;
#ifdef HAVE_SETLOCALE
-@@ -335,21 +766,88 @@ static int seek_to_tz_position(const uns
+@@ -337,21 +767,88 @@ static int seek_to_tz_position(const uns
return 0;
}
@@ -575,7 +575,7 @@ diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.
}
static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -374,24 +872,54 @@ static void read_64bit_header(const unsi
+@@ -376,24 +873,54 @@ static void read_64bit_header(const unsi
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
{
const unsigned char *tzf;
@@ -639,9 +639,9 @@ diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/parse_tz.
} else {
tmp = NULL;
}
-diff -up php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/timelib.m4.systzdata php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/timelib.m4
---- php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/timelib.m4.systzdata 2015-05-07 07:46:56.000000000 +0200
-+++ php-src-dd0b602381fad375d8f29a97f25f099be7c9db35/ext/date/lib/timelib.m4 2015-05-07 08:27:21.541863417 +0200
+diff -up php-7.0.0RC1/ext/date/lib/timelib.m4.systzdata php-7.0.0RC1/ext/date/lib/timelib.m4
+--- php-7.0.0RC1/ext/date/lib/timelib.m4.systzdata 2015-08-18 23:39:24.000000000 +0200
++++ php-7.0.0RC1/ext/date/lib/timelib.m4 2015-08-22 07:47:34.854055364 +0200
@@ -78,3 +78,17 @@ stdlib.h
dnl Check for strtoll, atoll
diff --git a/php.spec b/php.spec
index 73c644a..8bb1aa7 100644
--- a/php.spec
+++ b/php.spec
@@ -133,8 +133,8 @@
#global gh_date 20150623
#global gh_owner php
#global gh_project php-src
-%global rcver beta3
-%global rpmrel 13
+%global rcver RC1
+%global rpmrel 14
Summary: PHP scripting language for creating dynamic web sites
@@ -1804,6 +1804,9 @@ fi
%changelog
+* Sat Aug 22 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.14.RC1
+- Update to 7.0.0RC1
+
* Wed Aug 5 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.13.beta3
- Update to 7.0.0beta3