summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-7.0.0-oldpcre.patch (renamed from php-5.6.0-oldpcre.patch)19
-rw-r--r--php.spec10
2 files changed, 6 insertions, 23 deletions
diff --git a/php-5.6.0-oldpcre.patch b/php-7.0.0-oldpcre.patch
index df6edb2..19f8064 100644
--- a/php-5.6.0-oldpcre.patch
+++ b/php-7.0.0-oldpcre.patch
@@ -8,24 +8,6 @@ diff -up ./ext/pcre/tests/bug37911.phpt.pcre834 ./ext/pcre/tests/bug37911.phpt
-Warning: preg_replace_callback(): Compilation failed: group name must start with a non-digit at offset %d in %sbug37911.php on line %d
+Warning: preg_replace_callback(): Numeric named subpatterns are not allowed in %sbug37911.php on line %d
NULL
-diff -up ./ext/pcre/tests/grep2.phpt.pcre834 ./ext/pcre/tests/grep2.phpt
---- ./ext/pcre/tests/grep2.phpt.pcre834 2014-03-26 14:08:26.583072531 +0100
-+++ ./ext/pcre/tests/grep2.phpt 2014-03-26 14:09:09.345218089 +0100
-@@ -40,12 +40,6 @@ array(1) {
- string(1) "1"
- }
- bool(true)
--array(3) {
-- [5]=>
-- string(1) "a"
-- ["xyz"]=>
-- string(2) "q6"
-- [6]=>
-- string(3) "h20"
-+array(0) {
- }
--bool(false)
-+bool(true)
diff -up ./ext/pcre/tests/match_flags3.phpt.pcre834 ./ext/pcre/tests/match_flags3.phpt
--- ./ext/pcre/tests/match_flags3.phpt.pcre834 2014-03-26 14:06:48.792739665 +0100
+++ ./ext/pcre/tests/match_flags3.phpt 2014-03-26 14:07:31.820886128 +0100
@@ -36,4 +18,3 @@ diff -up ./ext/pcre/tests/match_flags3.phpt.pcre834 ./ext/pcre/tests/match_flags
-Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset %d in %smatch_flags3.php on line %d
+Warning: preg_match(): Numeric named subpatterns are not allowed in %smatch_flags3.php on line %d
bool(false)
-diff -up ./ext/standard/tests/strings/setlocale_variation2.phpt.pcre834 ./ext/standard/tests/strings/setlocale_variation2.phpt
diff --git a/php.spec b/php.spec
index 28d4f39..f27fd61 100644
--- a/php.spec
+++ b/php.spec
@@ -125,7 +125,7 @@
%global db_devel libdb-devel
%endif
-%global gh_commit dd0b602381fad375d8f29a97f25f099be7c9db35
+%global gh_commit 62b1293e3df520d104c678bc520b413386b628c5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_date 20150507
%global gh_owner php
@@ -198,7 +198,7 @@ Patch91: php-5.6.3-oci8conf.patch
# Factory is droped from system tzdata
Patch300: php-5.6.3-datetests.patch
# Revert changes for pcre < 8.34
-Patch301: php-5.6.0-oldpcre.patch
+Patch301: php-7.0.0-oldpcre.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -908,10 +908,10 @@ support for JavaScript Object Notation (JSON) to PHP.
# Fixes for tests
%patch300 -p1 -b .datetests
%if %{with_libpcre}
-%if 0%{?fedora} < 21
+if ! pkg-config libpcre --atleast-version 8.34 ; then
# Only apply when system libpcre < 8.34
%patch301 -p1 -b .pcre834
-%endif
+fi
%endif
# Prevent %%doc confusion over LICENSE files
@@ -943,6 +943,8 @@ rm ext/date/tests/timezone_version_get.phpt
rm ext/date/tests/timezone_version_get_basic1.phpt
# fails sometime
rm ext/sockets/tests/mcast_ipv?_recv.phpt
+# Should be skipped but fails sometime
+rm ext/standard/tests/file/file_get_contents_error001.phpt
# cause stack exhausion
rm Zend/tests/bug54268.phpt
rm Zend/tests/bug68412.phpt