summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-13 13:54:30 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-13 13:54:30 +0100
commitda9dff8406487cb05e853c859c9a40f1d55ae948 (patch)
tree555c86e4bb2c919c9e0cf17ab3dd226d1a70855b /php.spec
parentca93b4752bfe22855a6708c4355aa9e4b30118c0 (diff)
php: cleanup PIDFile and EnvironmentFile
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec6
1 files changed, 6 insertions, 0 deletions
diff --git a/php.spec b/php.spec
index 775146a..0e62e3a 100644
--- a/php.spec
+++ b/php.spec
@@ -1447,10 +1447,14 @@ sed -e 's:/run:%{_localstatedir}/run:' \
-i $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
# Environment file
+%if 0%{?fedora} >= 26
+sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_root_initddir}/%{?scl_prefix}php-fpm
+%else
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
sed -e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
+%endif
# make the cli commands available in standard root for SCL build
%if 0%{?scl:1}
@@ -1728,7 +1732,9 @@ fi
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
+%if 0%{?fedora} < 26
%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
+%endif
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service