summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-25 17:53:12 +0200
committerRemi Collet <remi@remirepo.net>2017-04-25 17:53:12 +0200
commitb66854c81a7de45a5d1894a14a3d585ee8fcdc66 (patch)
tree7953e6823c86943fa900d485b0a62cdbdd113c9e /php.spec
parentecf17b35c6c9652dc15174bd91bbcb14afeb2e14 (diff)
7.0.19RC1
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec48
1 files changed, 16 insertions, 32 deletions
diff --git a/php.spec b/php.spec
index db32a42..d78bda3 100644
--- a/php.spec
+++ b/php.spec
@@ -25,7 +25,7 @@
%global zendver 20151012
%global pdover 20150127
# Extension version
-%global oci8ver 2.1.3
+%global oci8ver 2.1.4
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -123,14 +123,14 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
-%global rpmrel 1
+%global upver 7.0.19
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.0.18
-Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
+Version: %{upver}%{?rcver:~%{rcver}}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -143,7 +143,7 @@ URL: http://www.php.net/
%if 0%{?gh_date}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}%{?gh_short:-%{gh_short}}.tar.gz
%else
-Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
+Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
%endif
Source1: php.conf
Source2: php.ini
@@ -163,7 +163,6 @@ Source52: 20-oci8.ini
# Build fixes
Patch1: php-7.0.17-interbase.patch
-Patch2: php-7.0.17-openssl11.patch
Patch5: php-7.0.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
@@ -197,8 +196,6 @@ Patch301: php-7.0.0-oldpcre.patch
# WIP
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
BuildRequires: bzip2-devel, curl-devel >= 7.9, %{db_devel}
BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
%if %{with_httpd2410}
@@ -870,13 +867,10 @@ support for JavaScript Object Notation (JSON) to PHP.
%if 0%{?gh_date}
%setup -q -n %{gh_project}-%{gh_commit}
%else
-%setup -q -n php-%{version}%{?rcver}
+%setup -q -n php-%{upver}%{?rcver}
%endif
%patch1 -p1 -b .fb_config
-%if 0%{?fedora} >= 26
-%patch2 -p1 -b .openssl11
-%endif
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
@@ -951,8 +945,8 @@ rm Zend/tests/bug68412.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
-if test "x${pver}" != "x%{version}%{?rcver}%{!?rcver:%{?gh_date:-dev}}"; then
- : Error: Upstream PHP version is now ${pver}, expecting %{version}%{?rcver}%{!?rcver:%{?gh_date:-dev}}.
+if test "x${pver}" != "x%{upver}%{?rcver}%{!?rcver:%{?gh_date:-dev}}"; then
+ : Error: Upstream PHP version is now ${pver}, expecting %{upver}%{?rcver}%{!?rcver:%{?gh_date:-dev}}.
: Update the version/rcver macros and rebuild.
exit 1
fi
@@ -1006,7 +1000,7 @@ chmod 644 README.*
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "s/@PHP_ZENDVER@/%{zendver}%{isasuffix}/" \
-e "s/@PHP_PDOVER@/%{pdover}%{isasuffix}/" \
- -e "s/@PHP_VERSION@/%{version}/" \
+ -e "s/@PHP_VERSION@/%{upver}/" \
-e "s:@LIBDIR@:%{_libdir}:" \
-e "s:@ETCDIR@:%{_sysconfdir}:" \
-e "s:@INCDIR@:%{_includedir}:" \
@@ -1315,8 +1309,6 @@ unset NO_INTERACTION REPORT_EXIT_STATUS MALLOC_CHECK_
%endif
%install
-[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
-
# Install the version for embedded script language in applications + php_embed.h
make -C build-embedded install-sapi install-headers \
INSTALL_ROOT=$RPM_BUILD_ROOT
@@ -1530,8 +1522,8 @@ extension=${mod}.so
EOF
fi
cat > files.${mod} <<EOF
-%attr(755,root,root) %{_libdir}/php/modules/${mod}.so
-%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php.d/${ini}
+%{_libdir}/php/modules/${mod}.so
+%config(noreplace) %{_sysconfdir}/php.d/${ini}
EOF
done
@@ -1587,7 +1579,6 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/php/modules/*.a \
rm -f README.{Zeus,QNX,CVS-RULES}
%clean
-[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
rm files.* macros.*
%if ! %{with_httpd2410}
@@ -1652,7 +1643,6 @@ fi
%{!?_licensedir:%global license %%doc}
%files
-%defattr(-,root,root)
%{_httpd_moddir}/libphp7.so
%if 0%{?scl:1}
%dir %{_libdir}/httpd
@@ -1669,7 +1659,6 @@ fi
%{_httpd_contentdir}/icons/%{name}.gif
%files common -f files.common
-%defattr(-,root,root)
%doc CODING_STANDARDS CREDITS EXTENSIONS NEWS README*
%license LICENSE TSRM_LICENSE
%license libmagic_LICENSE
@@ -1690,7 +1679,6 @@ fi
%endif
%files cli
-%defattr(-,root,root)
%{_bindir}/php
%{_bindir}/php-cgi
%{_bindir}/phar.phar
@@ -1710,7 +1698,6 @@ fi
%endif
%files dbg
-%defattr(-,root,root)
%{_bindir}/phpdbg
%{_mandir}/man1/phpdbg.1*
%doc sapi/phpdbg/{README.md,CREDITS}
@@ -1719,7 +1706,6 @@ fi
%endif
%files fpm
-%defattr(-,root,root)
%doc php-fpm.conf.default www.conf.default
%license fpm_LICENSE
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
@@ -1752,7 +1738,6 @@ fi
%if %{with_lsws}
%files litespeed
-%defattr(-,root,root)
%{_bindir}/lsphp
%if 0%{?scl:1}
%{_root_bindir}/ls%{scl}
@@ -1760,12 +1745,10 @@ fi
%endif
%files embedded
-%defattr(-,root,root,-)
%{_libdir}/libphp7.so
%{_libdir}/libphp7-%{embed_version}.so
%files devel
-%defattr(-,root,root)
%{_bindir}/php-config
%{_includedir}/php
%{_libdir}/php/build
@@ -1782,19 +1765,16 @@ fi
%files xml -f files.xml
%files xmlrpc -f files.xmlrpc
%files mbstring -f files.mbstring
-%defattr(-,root,root,-)
%license libmbfl_LICENSE
%license oniguruma_COPYING
%license ucgendat_LICENSE
%files gd -f files.gd
-%defattr(-,root,root,-)
%if ! %{with_libgd}
%license libgd_README
%license libgd_COPYING
%endif
%files soap -f files.soap
%files bcmath -f files.bcmath
-%defattr(-,root,root,-)
%license libbcmath_COPYING
%files gmp -f files.gmp
%files dba -f files.dba
@@ -1833,6 +1813,10 @@ fi
%changelog
+* Tue Apr 25 2017 Remi Collet <remi@fedoraproject.org> - 7.0.19~RC1-1
+- Update to 7.0.19RC1
+- oci8 version is now 2.1.4
+
* Tue Apr 11 2017 Remi Collet <remi@fedoraproject.org> - 7.0.18-1
- Update to 7.0.18 - http://www.php.net/releases/7_0_18.php