summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-08 08:46:13 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-08 08:46:13 +0200
commit9cc939654de0bb13b407f74b145b492e3280b6a2 (patch)
tree2d8fc1d725a579d6906b5a15b12364ee9c9b41ff /php.spec
parent92fa8d3ecee8f0f48af73baa3a72b745e06da137 (diff)
PHP 7.0.8RC1
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec24
1 files changed, 10 insertions, 14 deletions
diff --git a/php.spec b/php.spec
index 2c9d802..9619369 100644
--- a/php.spec
+++ b/php.spec
@@ -26,7 +26,6 @@
%global zendver 20151012
%global pdover 20150127
# Extension version
-%global opcachever 7.0.6-dev
%global oci8ver 2.1.1
# Adds -z now to the linker flags
@@ -125,13 +124,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.0.7
+Version: 7.0.8
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -406,10 +405,10 @@ Summary: The Zend OPcache
Group: Development/Languages
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-zendopcache = %{opcachever}
-Provides: %{?scl_prefix}php-pecl-zendopcache%{?_isa} = %{opcachever}
-Provides: %{?scl_prefix}php-pecl(opcache) = %{opcachever}
-Provides: %{?scl_prefix}php-pecl(opcache)%{?_isa} = %{opcachever}
+Provides: %{?scl_prefix}php-pecl-zendopcache = %{version}
+Provides: %{?scl_prefix}php-pecl-zendopcache%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(opcache) = %{version}
+Provides: %{?scl_prefix}php-pecl(opcache)%{?_isa} = %{version}
%description opcache
The Zend OPcache provides faster PHP execution through opcode caching and
@@ -982,13 +981,6 @@ if test "$ver" != "%{oci8ver}"; then
exit 1
fi
-ver=$(sed -n '/#define PHP_ZENDOPCACHE_VERSION /{s/.*\s"//;s/".*$//;p}' ext/opcache/ZendAccelerator.h)
-if test "$ver" != "%{opcachever}"; then
- : Error: Upstream OPCACHE version is now ${ver}, expecting %{opcachever}.
- : Update the opcachever macro and rebuild.
- exit 1
-fi
-
# https://bugs.php.net/63362 - Not needed but installed headers.
# Drop some Windows specific headers to avoid installation,
# before build to ensure they are really not needed.
@@ -1827,6 +1819,10 @@ fi
%changelog
+* Wed Jun 8 2016 Remi Collet <remi@fedoraproject.org> 7.0.8-0.1.RC1
+- Update to 7.0.8RC1
+- opcache version is now php version
+
* Wed May 25 2016 Remi Collet <remi@fedoraproject.org> 7.0.7-1
- Update to 7.0.7 - http://www.php.net/releases/7_0_7.php