summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-11 12:42:35 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-11 12:42:35 +0100
commit9129b6255f426983c0e54afd4eaca265824472b4 (patch)
treea7498f80cf56b3649f2330296581dff111e08941 /php.spec
parentd9fa5de96099e7814d3472820256e0bab3fd4287 (diff)
php 7: cleanup systemd conditions
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec13
1 files changed, 2 insertions, 11 deletions
diff --git a/php.spec b/php.spec
index db77040..9769a8c 100644
--- a/php.spec
+++ b/php.spec
@@ -1574,32 +1574,23 @@ exit 0
%endif
%post fpm
-%if 0%{?systemd_post:1}
+%if %{with_systemd}
%systemd_post %{?scl:%{scl}-}php-fpm.service
%else
if [ $1 = 1 ]; then
# Initial installation
-%if %{with_systemd}
- /bin/systemctl daemon-reload >/dev/null 2>&1 || :
-%else
/sbin/chkconfig --add %{?scl_prefix}php-fpm
-%endif
fi
%endif
%preun fpm
-%if 0%{?systemd_preun:1}
+%if %{with_systemd}
%systemd_preun %{?scl:%{scl}-}php-fpm.service
%else
if [ $1 = 0 ]; then
# Package removal, not upgrade
-%if %{with_systemd}
- /bin/systemctl --no-reload disable %{?scl_prefix}php-fpm.service >/dev/null 2>&1 || :
- /bin/systemctl stop %{?scl_prefix}php-fpm.service >/dev/null 2>&1 || :
-%else
/sbin/service %{?scl_prefix}php-fpm stop >/dev/null 2>&1
/sbin/chkconfig --del %{?scl_prefix}php-fpm
-%endif
fi
%endif