summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-28 15:15:49 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-28 15:15:49 +0100
commite65b20619abca433602471aae7333a0460148a7b (patch)
tree878c3a0f163752c6dcea33ed49ff0dbd49d2a0c3
parent2a23f4b03e0bb6ce95e2ec62b34481a07c15fa14 (diff)
PHP 7.0.17RC1
-rw-r--r--failed.txt2
-rw-r--r--php-7.0.17-dlopen.patch (renamed from php-7.0.0-dlopen.patch)18
-rw-r--r--php.spec10
3 files changed, 16 insertions, 14 deletions
diff --git a/failed.txt b/failed.txt
index 02eea0f..f061d11 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.0.16 (2017-02-16)
+===== 7.0.17RC1 (2017-03-02)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
diff --git a/php-7.0.0-dlopen.patch b/php-7.0.17-dlopen.patch
index 4047460..37a461c 100644
--- a/php-7.0.0-dlopen.patch
+++ b/php-7.0.17-dlopen.patch
@@ -1,7 +1,7 @@
-diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespeed/lsapilib.c
---- php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen 2015-08-18 23:39:17.000000000 +0200
-+++ php-7.0.0RC1/sapi/litespeed/lsapilib.c 2015-08-22 07:46:31.729721983 +0200
-@@ -582,7 +582,7 @@ static int (*fp_lve_leave)(struct liblve
+diff -up php-7.0.17RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.17RC1/sapi/litespeed/lsapilib.c
+--- php-7.0.17RC1/sapi/litespeed/lsapilib.c.dlopen 2017-02-28 12:11:33.000000000 +0100
++++ php-7.0.17RC1/sapi/litespeed/lsapilib.c 2017-02-28 13:06:07.493838664 +0100
+@@ -616,7 +616,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
static int lsapi_load_lve_lib()
{
@@ -10,16 +10,16 @@ diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespe
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-7.0.0RC1/Zend/zend_portability.h.dlopen php-7.0.0RC1/Zend/zend_portability.h
---- php-7.0.0RC1/Zend/zend_portability.h.dlopen 2015-08-18 23:39:16.000000000 +0200
-+++ php-7.0.0RC1/Zend/zend_portability.h 2015-08-22 07:46:31.729721983 +0200
-@@ -136,11 +136,11 @@
+diff -up php-7.0.17RC1/Zend/zend_portability.h.dlopen php-7.0.17RC1/Zend/zend_portability.h
+--- php-7.0.17RC1/Zend/zend_portability.h.dlopen 2017-02-28 13:06:07.493838664 +0100
++++ php-7.0.17RC1/Zend/zend_portability.h 2017-02-28 13:07:10.626118397 +0100
+@@ -146,11 +146,11 @@
# endif
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
- # elif defined(RTLD_DEEPBIND)
+ # elif defined(RTLD_DEEPBIND) && !defined(__SANITIZE_ADDRESS__)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_DEEPBIND)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND)
# else
diff --git a/php.spec b/php.spec
index f012138..bf9f335 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,3 @@
-# remirepo spec file for php70-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -124,13 +123,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.0.16
+Version: 7.0.17
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -168,7 +167,7 @@ Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch40: php-7.0.0-dlopen.patch
+Patch40: php-7.0.17-dlopen.patch
Patch42: php-7.0.0-systzdata-v14.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
@@ -1822,6 +1821,9 @@ fi
%changelog
+* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> 7.0.17-0.1.RC1
+- Update to 7.0.17RC1
+
* Tue Feb 14 2017 Remi Collet <remi@fedoraproject.org> 7.0.16-1
- Update to 7.0.16 - http://www.php.net/releases/7_0_16.php