summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-25 15:15:01 +0200
committerRemi Collet <remi@remirepo.net>2017-09-25 15:15:01 +0200
commitd771af9b902dc0b266f33f6aca18a0dbf522cf30 (patch)
tree3e67ff47d67da86eed8784de33a2c54b2bf3544e
parent6d1f3e1a833c253b472e1c1cda3efd3dce587547 (diff)
F27: php now requires php-fpm and start it with httpd / nginx
-rw-r--r--php-fpm.wants3
-rw-r--r--php.spec21
2 files changed, 21 insertions, 3 deletions
diff --git a/php-fpm.wants b/php-fpm.wants
new file mode 100644
index 0000000..29b7f93
--- /dev/null
+++ b/php-fpm.wants
@@ -0,0 +1,3 @@
+[Unit]
+Wants=php70-php-fpm.service
+
diff --git a/php.spec b/php.spec
index 794579a..634ad24 100644
--- a/php.spec
+++ b/php.spec
@@ -127,7 +127,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -153,6 +153,7 @@ Source8: php-fpm.sysconfig
Source9: php.modconf
Source10: php.conf2
Source11: php-fpm.init
+Source12: php-fpm.wants
# Configuration files for some extensions
Source50: 10-opcache.ini
Source51: opcache-default.blacklist
@@ -232,6 +233,10 @@ Requires(pre): httpd-filesystem
%else
Requires(pre): httpd
%endif
+%if 0%{?fedora} >= 27
+# httpd have threaded MPM by default
+Requires: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+%endif
# Don't provides extensions, or shared libraries (embedded)
@@ -1389,8 +1394,11 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default .
# install -m 644 php-fpm.tmpfiles $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/php-fpm.conf
# install systemd unit files and scripts for handling server startup
%if %{with_systemd}
-install -m 755 -d $RPM_BUILD_ROOT%{_unitdir}
-install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
+install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
+%if 0%{?fedora} >= 27
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
+%endif
sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
-e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
@@ -1718,6 +1726,10 @@ fi
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service
+%if 0%{?fedora} >= 27
+%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
+%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
+%endif
%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
%else
%{_root_initddir}/%{?scl_prefix}php-fpm
@@ -1808,6 +1820,9 @@ fi
%changelog
+* Mon Sep 25 2017 Remi Collet <remi@remirepo.net> - 7.0.24~RC1-3
+- F27: php now requires php-fpm and start it with httpd / nginx
+
* Thu Sep 14 2017 Remi Collet <remi@remirepo.net> - 7.0.24~RC1-2
- update builder from RHEL 7.3 to RHEL 7.4