summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-20 18:21:46 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-20 18:21:46 +0200
commit9cd8a14c37ccb9b2128582593f70cc3ff829d225 (patch)
tree8378483590e2e659787749b0313bdd3e1a937eec
parent2cde743ab69bf08f21beacf9ce767f0a8db35b5a (diff)
PHP 7.0.9
-rw-r--r--bug72564.patch67
-rw-r--r--failed.txt11
-rw-r--r--php.spec8
3 files changed, 78 insertions, 8 deletions
diff --git a/bug72564.patch b/bug72564.patch
new file mode 100644
index 0000000..4d7e5c1
--- /dev/null
+++ b/bug72564.patch
@@ -0,0 +1,67 @@
+From 99d6e09c3d6679bb522836c833d0cfd4f79c6014 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 8 Jul 2016 10:46:33 +0200
+Subject: [PATCH] Fixed Bug #72564 boolean always deserialized as "true"
+
+---
+ ext/wddx/wddx.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/wddx/wddx.c b/ext/wddx/wddx.c
+index 2cc3c8b..cb0c01e 100644
+--- a/ext/wddx/wddx.c
++++ b/ext/wddx/wddx.c
+@@ -1013,9 +1013,9 @@ static void php_wddx_process_data(void *user_data, const XML_Char *s, int len)
+
+ case ST_BOOLEAN:
+ if (!strcmp((char *)s, "true")) {
+- Z_LVAL(ent->data) = 1;
++ ZVAL_TRUE(&ent->data);
+ } else if (!strcmp((char *)s, "false")) {
+- Z_LVAL(ent->data) = 0;
++ ZVAL_FALSE(&ent->data);
+ } else {
+ zval_ptr_dtor(&ent->data);
+ if (ent->varname) {
+--
+2.1.4
+
+From bfc42211d3cc5aa6cd2bdb10ef5004ce22099acb Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 8 Jul 2016 10:45:13 +0200
+Subject: [PATCH] add test for bug #72564 (7.x regression)
+
+---
+ ext/wddx/tests/bug72564.phpt | 20 ++++++++++++++++++++
+ 1 file changed, 20 insertions(+)
+ create mode 100644 ext/wddx/tests/bug72564.phpt
+
+diff --git a/ext/wddx/tests/bug72564.phpt b/ext/wddx/tests/bug72564.phpt
+new file mode 100644
+index 0000000..4711ef8
+--- /dev/null
++++ b/ext/wddx/tests/bug72564.phpt
+@@ -0,0 +1,20 @@
++--TEST--
++Bug #72564: wddx deserialization of boolean
++--SKIPIF--
++<?php if (!extension_loaded("wddx")) print "skip"; ?>
++--FILE--
++<?php
++ foreach([true, false, NULL] as $v) {
++ $x = wddx_serialize_value($v);
++ var_dump($x, wddx_deserialize($x));
++ }
++?>
++Done
++--EXPECT--
++string(84) "<wddxPacket version='1.0'><header/><data><boolean value='true'/></data></wddxPacket>"
++bool(true)
++string(85) "<wddxPacket version='1.0'><header/><data><boolean value='false'/></data></wddxPacket>"
++bool(false)
++string(68) "<wddxPacket version='1.0'><header/><data><null/></data></wddxPacket>"
++NULL
++Done
+--
+2.1.4
+
diff --git a/failed.txt b/failed.txt
index 829c40b..c4bb775 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,22 +1,19 @@
-===== 7.0.9RC1 (2016-07-08)
+===== 7.0.9 (2016-07-21)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
-/var/lib/mock/scl70el6x/build.log:Tests failed : 3
+/var/lib/mock/scl70el6x/build.log:Tests failed : 2
/var/lib/mock/scl70el7x/build.log:Tests failed : 4
/var/lib/mock/scl70fc21x/build.log:Tests failed : 0
/var/lib/mock/scl70fc22x/build.log:Tests failed : 0
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc24x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
el6x, el7x
Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
-el6x
- Test session_set_save_handler() function : test lazy_write [ext/session/tests/session_set_save_handler_variation6.phpt]
-el7x, fc24x
- Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
el7x
+ Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
diff --git a/php.spec b/php.spec
index 0b5580e..212aa86 100644
--- a/php.spec
+++ b/php.spec
@@ -124,7 +124,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
@@ -183,6 +183,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: bug72564.patch
# Security fixes (200+)
@@ -894,6 +895,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .bug72564
# security patches
@@ -1824,6 +1826,10 @@ fi
%changelog
+* Wed Jul 20 2016 Remi Collet <remi@fedoraproject.org> 7.0.9-1
+- Update to 7.0.9 - http://www.php.net/releases/7_0_9.php
+- wddx: add upstream patch for https://bugs.php.net/72564
+
* Wed Jul 6 2016 Remi Collet <remi@fedoraproject.org> 7.0.9-0.1.RC1
- Update to 7.0.9RC1