summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-18 08:29:53 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-18 08:29:53 +0100
commit4b00a2726b1a57ae1ff56ca72f655ce127ce7ed4 (patch)
tree6e2917b7ef145474882bc47908e41476832937ba
parentf13f6ef9f08b2686a50c40c2bae9b2726af53f86 (diff)
PHP 7.0.4RC1
-rw-r--r--failed.txt6
-rw-r--r--php-bug62172.patch59
-rw-r--r--php.spec9
3 files changed, 7 insertions, 67 deletions
diff --git a/failed.txt b/failed.txt
index ed254a9..bbe9dfd 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,9 +1,9 @@
-===== 7.0.3 (2016-02-03)
+===== 7.0.4RC1 (2016-02-18)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
/var/lib/mock/scl70el6x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
-/var/lib/mock/scl70el7x/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70el7x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc20x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%
/var/lib/mock/scl70fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
@@ -12,7 +12,5 @@ $ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
el6x, el7x, fc20x
Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
-el7x
- Test session_set_save_handler() function : test lazy_write [ext/session/tests/session_set_save_handler_variation6.phpt]
* proc_open give erratic test results :(
diff --git a/php-bug62172.patch b/php-bug62172.patch
deleted file mode 100644
index 81ccc35..0000000
--- a/php-bug62172.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 07d2dcdf09fcfbd617031bd341384efb236de12c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 29 Jan 2016 10:20:42 +0100
-Subject: [PATCH] Fixed Bug #62172 FPM not working with Apache httpd 2.4
- balancer/fcgi setup
-
-Only needed with Apache version < 2.4.12 (ex RHEL-7)
----
- sapi/fpm/fpm/fpm_main.c | 26 +++++++++++++++++++++++++-
- 1 file changed, 25 insertions(+), 1 deletion(-)
-
-diff --git a/sapi/fpm/fpm/fpm_main.c b/sapi/fpm/fpm/fpm_main.c
-index f3c8ccc..d12ac01 100644
---- a/sapi/fpm/fpm/fpm_main.c
-+++ b/sapi/fpm/fpm/fpm_main.c
-@@ -1108,11 +1108,14 @@ static void init_request_info(TSRMLS_D)
- }
-
- #define APACHE_PROXY_FCGI_PREFIX "proxy:fcgi://"
-- /* Fix proxy URLs in SCRIPT_FILENAME generated by Apache mod_proxy_fcgi:
-+#define APACHE_PROXY_BALANCER_PREFIX "proxy:balancer://"
-+ /* Fix proxy URLs in SCRIPT_FILENAME generated by Apache mod_proxy_fcgi and mod_proxy_balancer:
- * proxy:fcgi://localhost:9000/some-dir/info.php/test?foo=bar
-+ * proxy:balancer://localhost:9000/some-dir/info.php/test?foo=bar
- * should be changed to:
- * /some-dir/info.php/test
- * See: http://bugs.php.net/bug.php?id=54152
-+ * http://bugs.php.net/bug.php?id=62172
- * https://issues.apache.org/bugzilla/show_bug.cgi?id=50851
- */
- if (env_script_filename &&
-@@ -1136,6 +1139,27 @@ static void init_request_info(TSRMLS_D)
- }
- }
-
-+ if (env_script_filename &&
-+ strncasecmp(env_script_filename, APACHE_PROXY_BALANCER_PREFIX, sizeof(APACHE_PROXY_BALANCER_PREFIX) - 1) == 0) {
-+ /* advance to first character of hostname */
-+ char *p = env_script_filename + (sizeof(APACHE_PROXY_BALANCER_PREFIX) - 1);
-+ while (*p != '\0' && *p != '/') {
-+ p++; /* move past hostname and port */
-+ }
-+ if (*p != '\0') {
-+ /* Copy path portion in place to avoid memory leak. Note
-+ * that this also affects what script_path_translated points
-+ * to. */
-+ memmove(env_script_filename, p, strlen(p) + 1);
-+ apache_was_here = 1;
-+ }
-+ /* ignore query string if sent by Apache (RewriteRule) */
-+ p = strchr(env_script_filename, '?');
-+ if (p) {
-+ *p =0;
-+ }
-+ }
-+
- if (CGIG(fix_pathinfo)) {
- struct stat st;
- char *real_path = NULL;
diff --git a/php.spec b/php.spec
index 6859e8b..a04d172 100644
--- a/php.spec
+++ b/php.spec
@@ -125,13 +125,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.0.3
+Version: 7.0.4
%if 0%{?gh_date}
Release: 0.%{rpmrel}.%{gh_date}git%{gh_short}%{?dist}
%else
@@ -206,7 +206,6 @@ Patch300: php-5.6.3-datetests.patch
Patch301: php-7.0.0-oldpcre.patch
# WIP
-Patch401: php-bug62172.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -923,7 +922,6 @@ fi
%endif
# WIP patch
-%patch401 -p1 -b .bug62172
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1828,6 +1826,9 @@ fi
%changelog
+* Thu Feb 18 2016 Remi Collet <remi@fedoraproject.org> 7.0.4-0.1.0RC1
+- Update to 7.0.4RC1
+
* Wed Feb 3 2016 Remi Collet <remi@fedoraproject.org> 7.0.3-1
- Update to 7.0.3
http://www.php.net/releases/7_0_3.php