summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-31 07:58:02 +0200
committerRemi Collet <remi@remirepo.net>2017-08-31 07:58:02 +0200
commit387f3f0ce967673eda5787141eeb610355f29cf1 (patch)
tree77ae62898faa852fce54eee3ae39c38f2a3e1644
parent8271e713970acd9814e4dc91d2ebfa4230da2c2d (diff)
add patch for EL-6, fix undefined symbol: sqlite3_errstr
-rw-r--r--failed.txt1
-rw-r--r--php-upstream.patch30
-rw-r--r--php.spec9
3 files changed, 37 insertions, 3 deletions
diff --git a/failed.txt b/failed.txt
index fa5d66e..196501d 100644
--- a/failed.txt
+++ b/failed.txt
@@ -4,7 +4,6 @@ $ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
/var/lib/mock/scl70el6x/build.log:Tests failed : 0
/var/lib/mock/scl70el7x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
/var/lib/mock/scl70fc26x/build.log:Tests failed : 0
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..448fd7c
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,30 @@
+From 3239f6d6798d86fdbf8e03aa741d9990bcfffe79 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 31 Aug 2017 07:55:45 +0200
+Subject: [PATCH] move AC_DEFINE in the right position (in bundled lib
+ conditon)
+
+---
+ ext/sqlite3/config0.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
+index 0e5fbc5..78fd622 100644
+--- a/ext/sqlite3/config0.m4
++++ b/ext/sqlite3/config0.m4
+@@ -85,11 +85,11 @@ if test $PHP_SQLITE3 != "no"; then
+ other_flags="$other_flags -DSQLITE_ENABLE_ICU=1"
+ fi
+
++ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
+ PHP_INSTALL_HEADERS([ext/sqlite3/libsqlite/sqlite3.h])
+ fi
+
+- AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ AC_DEFINE(HAVE_SQLITE3,1,[ ])
+
+ sqlite3_sources="sqlite3.c $sqlite3_extra_sources"
+--
+2.1.4
+
diff --git a/php.spec b/php.spec
index c395fb1..aa7b694 100644
--- a/php.spec
+++ b/php.spec
@@ -62,7 +62,7 @@
# Regression tests take a long time, you can skip 'em with this
%{!?runselftest: %global runselftest 1}
-#global runselftest 0
+%global runselftest 0
# Use the arch-specific mysql_config binary to avoid mismatch with the
# arch detection heuristic used by bindir/mysql_config.
@@ -127,7 +127,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -183,6 +183,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -892,6 +893,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -1808,6 +1810,9 @@ fi
%changelog
+* Thu Aug 31 2017 Remi Collet <remi@fedoraproject.org> - 7.0.23-2
+- add patch for EL-6, fix undefined symbol: sqlite3_errstr
+
* Tue Aug 29 2017 Remi Collet <remi@fedoraproject.org> - 7.0.23-1
- Update to 7.0.23 - http://www.php.net/releases/7_0_23.php