summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-28 17:15:58 +0200
committerRemi Collet <fedora@famillecollet.com>2017-03-28 17:15:58 +0200
commit12b60c1c6fe5659696f1abad62665da58d307874 (patch)
treecab26ce28b58aaf3c14e93bafd07461b3b2effd3
parent749045275ecc627a1ed822a6fba079b9168347a5 (diff)
PHP 7.0.18RC1
-rw-r--r--.gitignore2
-rw-r--r--failed.txt26
-rw-r--r--php-7.0.10-datetests.patch24
-rw-r--r--php.spec7
4 files changed, 16 insertions, 43 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..df4c9dc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+php-*.tar.xz
+php70-php-*src.rpm
diff --git a/failed.txt b/failed.txt
index 3987636..f9f7117 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,26 +1,18 @@
-===== 7.0.17 (2017-03-16)
+===== 7.0.18RC1 (2017-03-30)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
-/var/lib/mock/scl70el6x/build.log:Tests failed : 0
-/var/lib/mock/scl70el7x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc22x/build.log:Tests failed : 0
+/var/lib/mock/scl70el6x/build.log:Tests failed : 1
+/var/lib/mock/scl70el7x/build.log:Tests failed : 1
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc25x/build.log:Tests failed : 0
-/var/lib/mock/scl70fc26x/build.log:Tests failed : 8
+/var/lib/mock/scl70fc24x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc25x/build.log:Tests failed : 1
+/var/lib/mock/scl70fc26x/build.log:Tests failed : 1
-fc26x
- Bug #20382 [2] (strtotime ("Monday", $date) produces wrong result on DST changeover) [ext/date/tests/bug20382-2.phpt]
- Bug #27780 (strtotime(+1 xxx) returns a wrong date/time) [ext/date/tests/bug27780.phpt]
- Bug #32086 (strtotime don't work in DST) [ext/date/tests/bug32086.phpt]
- Bug #33414 [1] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-1.phpt]
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
- Bug #33415 [1] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-1.phpt]
- Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
- date_modify() function [1] [ext/date/tests/date_modify-1.phpt]
+fc24x, fc25x, fc26x
+ *** Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
* proc_open give erratic test results :(
** fixed upstream
-*** f26x bugs related to tzdata 2016j vs 2017a
+*** bugs related to tzdata 2017a (repo) vs 2017b (php)
diff --git a/php-7.0.10-datetests.patch b/php-7.0.10-datetests.patch
index c3a65e9..7df99a5 100644
--- a/php-7.0.10-datetests.patch
+++ b/php-7.0.10-datetests.patch
@@ -42,27 +42,3 @@ diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strto
string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
bool(false)
string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
-diff -up ./ext/date/tests/bug33414-2.phpt.datetests ./ext/date/tests/bug33414-2.phpt
---- ./ext/date/tests/bug33414-2.phpt.datetests 2016-07-21 02:23:03.000000000 +0200
-+++ ./ext/date/tests/bug33414-2.phpt 2016-07-26 07:28:10.323598643 +0200
-@@ -74,7 +74,7 @@ $strtotime_tstamp = strtotime("next Frid
- print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
- print "wanted=Friday 00:00:00\n\n";
- ?>
----EXPECT--
-+--EXPECTF--
- TZ=Pacific/Rarotonga - wrong day.
- tStamp=Thursday 1970-01-01 17:17:17 CKT 0
- result=Tuesday 1970-01-06 00:00:00 CKT 0
-@@ -106,8 +106,8 @@ result=Tuesday 2005-04-12 00:00:00 CDT 1
- wanted=Tuesday 00:00:00
-
- TZ=Pacific/Pitcairn - wrong day.
--tStamp=Thursday 1970-01-01 17:17:17 PNT 0
--result=Wednesday 1970-01-07 00:00:00 PNT 0
-+tStamp=Thursday 1970-%s
-+result=Wednesday 1970-%s
- wanted=Wednesday 00:00:00
-
- TZ=Pacific/Fakaofo - wrong day.
-
diff --git a/php.spec b/php.spec
index 4e00fde..08e31f9 100644
--- a/php.spec
+++ b/php.spec
@@ -123,13 +123,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.0.17
+Version: 7.0.18
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -1833,6 +1833,9 @@ fi
%changelog
+* Tue Mar 28 2017 Remi Collet <remi@fedoraproject.org> 7.0.18-0.1.RC1
+- Update to 7.0.18RC1
+
* Tue Mar 14 2017 Remi Collet <remi@fedoraproject.org> 7.0.17-1
- Update to 7.0.17 - http://www.php.net/releases/7_0_17.php