summaryrefslogtreecommitdiffstats
path: root/php56.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php56.spec')
-rw-r--r--php56.spec147
1 files changed, 147 insertions, 0 deletions
diff --git a/php56.spec b/php56.spec
new file mode 100644
index 0000000..b7b573a
--- /dev/null
+++ b/php56.spec
@@ -0,0 +1,147 @@
+%global scl_name_base php
+%global scl_name_version 56
+%global scl %{scl_name_base}%{scl_name_version}
+%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_root_sysconfdir}/rpm; echo $d)
+%scl_package %scl
+
+# do not produce empty debuginfo package
+%global debug_package %{nil}
+
+Summary: Package that installs PHP 5.6
+Name: %scl_name
+Version: 1.0
+Release: 1%{?dist}
+Group: Development/Languages
+License: GPLv2+
+
+Source0: macros-build
+Source1: README
+Source2: LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: scl-utils-build
+BuildRequires: help2man
+# Temporary work-around
+BuildRequires: iso-codes
+
+Requires: %{?scl_prefix}php-common
+Requires: %{?scl_prefix}php-cli
+Requires: %{?scl_prefix}php-pear
+Requires: %{?scl_name}-runtime
+
+%description
+This is the main package for %scl Software Collection,
+that install PHP 5.5 language.
+
+
+%package runtime
+Summary: Package that handles %scl Software Collection.
+Group: Development/Languages
+Requires: scl-utils
+
+%description runtime
+Package shipping essential scripts to work with %scl Software Collection.
+
+
+%package build
+Summary: Package shipping basic build configuration
+Group: Development/Languages
+Requires: scl-utils-build
+Requires: %{?scl_name}-runtime
+
+%description build
+Package shipping essential configuration macros
+to build %scl Software Collection.
+
+
+%package scldevel
+Summary: Package shipping development files for %scl
+Group: Development/Languages
+Requires: %{?scl_name}-runtime
+
+%description scldevel
+Package shipping development files, especially usefull for development of
+packages depending on %scl Software Collection.
+
+
+%prep
+%setup -c -T
+
+cat <<EOF | tee enable
+export PATH=%{_bindir}:%{_sbindir}\${PATH:+:\${PATH}}
+export MANPATH=%{_mandir}:\${MANPATH}
+EOF
+
+# generate rpm macros file for depended collections
+cat << EOF | tee scldev
+%%scl_%{scl_name_base} %{scl}
+%%scl_prefix_%{scl_name_base} %{scl_prefix}
+EOF
+
+# This section generates README file from a template and creates man page
+# from that file, expanding RPM macros in the template file.
+cat >README <<'EOF'
+%{expand:%(cat %{SOURCE1})}
+EOF
+
+# copy the license file so %%files section sees it
+cp %{SOURCE2} .
+
+
+%build
+# generate a helper script that will be used by help2man
+cat >h2m_helper <<'EOF'
+#!/bin/bash
+[ "$1" == "--version" ] && echo "%{scl_name} %{version} Software Collection" || cat README
+EOF
+chmod a+x h2m_helper
+
+# generate the man page
+help2man -N --section 7 ./h2m_helper -o %{scl_name}.7
+
+
+%install
+install -D -m 644 enable %{buildroot}%{_scl_scripts}/enable
+install -D -m 644 scldev %{buildroot}%{macrosdir}/macros.%{scl_name_base}-scldevel
+install -D -m 644 %{scl_name}.7 %{buildroot}%{_mandir}/man7/%{scl_name}.7
+
+%scl_install
+
+# Add the scl_package_override macro
+sed -e 's/@SCL@/%{scl}/g' %{SOURCE0} \
+ | tee -a %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
+
+# Move in correct location, if needed
+if [ "%{_root_sysconfdir}/rpm" != "%{macrosdir}" ]; then
+ mv %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config \
+ %{buildroot}%{macrosdir}/macros.%{scl}-config
+fi
+
+
+%files
+
+
+%if 0%{?fedora} < 19 && 0%{?rhel} < 7
+%files runtime
+%else
+%files runtime -f filesystem
+%endif
+%defattr(-,root,root)
+%doc README LICENSE
+%scl_files
+%{_mandir}/man7/%{scl_name}.*
+
+
+%files build
+%defattr(-,root,root)
+%{macrosdir}/macros.%{scl}-config
+
+
+%files scldevel
+%defattr(-,root,root)
+%{macrosdir}/macros.%{scl_name_base}-scldevel
+
+
+%changelog
+* Sun Aug 24 2014 Remi Collet <rcollet@redhat.com> 1.0-1
+- initial packaging from php55 from rhscl 1.1 \ No newline at end of file