summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-jsonc/Makefile2
-rw-r--r--php/Makefile2
-rw-r--r--php/php.spec6
3 files changed, 7 insertions, 3 deletions
diff --git a/php-pecl-jsonc/Makefile b/php-pecl-jsonc/Makefile
index 13af741..6c96298 100644
--- a/php-pecl-jsonc/Makefile
+++ b/php-pecl-jsonc/Makefile
@@ -2,3 +2,5 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../../../common/Makefile
+srpm:
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php56' -bs $(NAME).spec
diff --git a/php/Makefile b/php/Makefile
index 13af741..6c96298 100644
--- a/php/Makefile
+++ b/php/Makefile
@@ -2,3 +2,5 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../../../common/Makefile
+srpm:
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php56' -bs $(NAME).spec
diff --git a/php/php.spec b/php/php.spec
index bcdd154..c824f61 100644
--- a/php/php.spec
+++ b/php/php.spec
@@ -1519,7 +1519,7 @@ exit 0
%post fpm
%if 0%{?systemd_post:1}
-%systemd_post %{?scl_prefix}php-fpm.service
+%systemd_post %{?scl:%{scl}-}php-fpm.service
%else
if [ $1 = 1 ]; then
# Initial installation
@@ -1533,7 +1533,7 @@ fi
%preun fpm
%if 0%{?systemd_preun:1}
-%systemd_preun %{?scl_prefix}php-fpm.service
+%systemd_preun %{?scl:%{scl}-}php-fpm.service
%else
if [ $1 = 0 ]; then
# Package removal, not upgrade
@@ -1549,7 +1549,7 @@ fi
%postun fpm
%if 0%{?systemd_postun_with_restart:1}
-%systemd_postun_with_restart %{?scl_prefix}php-fpm.service
+%systemd_postun_with_restart %{?scl:%{scl}-}php-fpm.service
%else
%if %{with_systemd}
/bin/systemctl daemon-reload >/dev/null 2>&1 || :