summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-13 14:59:37 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-13 14:59:37 +0100
commit65bc19b0ce1c9c6b34a182ff288165f9e3ff72d0 (patch)
treeaf78cbe0013ed21887798e84228467a87edba938
parent349478413cdcfccf294abe8ba89343502bcf7ebe (diff)
php56: fix selinux context
-rw-r--r--php56.spec18
1 files changed, 15 insertions, 3 deletions
diff --git a/php56.spec b/php56.spec
index 26de98b..9e6e100 100644
--- a/php56.spec
+++ b/php56.spec
@@ -16,7 +16,7 @@
Summary: Package that installs PHP 5.6
Name: %scl_name
Version: 2.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Group: Development/Languages
License: GPLv2+
@@ -30,9 +30,9 @@ BuildRequires: help2man
# Temporary work-around
BuildRequires: iso-codes
-Requires: %{?scl_prefix}php-common%{?_isa} >= 5.6.7
+Requires: %{?scl_prefix}php-common%{?_isa} >= 5.6.15
Requires: %{?scl_prefix}php-cli%{?_isa}
-Requires: %{?scl_prefix}php-pear >= 1:1.9.5-9
+Requires: %{?scl_prefix}php-pear >= 1:1.10
Requires: %{?scl_name}-runtime%{?_isa} = %{version}-%{release}
%description
@@ -44,6 +44,8 @@ that install PHP 5.6 language.
Summary: Package that handles %scl Software Collection.
Group: Development/Languages
Requires: scl-utils
+Requires(post): %{_root_sbindir}/semanage
+Requires(post): %{_root_sbindir}/selinuxenabled
Provides: %{?scl_name}-runtime(%{scl_vendor})
Provides: %{?scl_name}-runtime(%{scl_vendor})%{?_isa}
@@ -148,6 +150,13 @@ if [ "%{_root_sysconfdir}/rpm" != "%{macrosdir}" ]; then
fi
+%post runtime
+# Simple copy of context from system root to SCL root.
+semanage fcontext -a -e / %{?_scl_root} &>/dev/null || :
+selinuxenabled && load_policy || :
+restorecon -R %{?_scl_root} &>/dev/null || :
+
+
%{!?_licensedir:%global license %%doc}
%files
@@ -178,6 +187,9 @@ fi
%changelog
+* Fri Nov 13 2015 Remi Collet <remi@fedoraproject.org> 2.1-2
+- fix selinux context
+
* Wed Mar 25 2015 Remi Collet <remi@fedoraproject.org> 2.1-1
- fix licenses location
- own directories for pecl packages