summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec45
1 files changed, 38 insertions, 7 deletions
diff --git a/php.spec b/php.spec
index b86bb69..e86fc2b 100644
--- a/php.spec
+++ b/php.spec
@@ -60,13 +60,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.19
+%global oraclever 19.24
+%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.19
+%global oracledir 19.24
%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
%endif
# Build for LiteSpeed Web Server (LSAPI)
@@ -139,7 +141,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: 5.6.40
-Release: 40%{?dist}
+Release: 43%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -261,6 +263,10 @@ Patch264: php-cve-2023-3823.patch
Patch265: php-cve-2023-3824.patch
Patch266: php-cve-2024-2756.patch
Patch267: php-cve-2024-3096.patch
+Patch268: php-cve-2024-5458.patch
+Patch269: php-cve-2024-8925.patch
+Patch270: php-cve-2024-8926.patch
+Patch271: php-cve-2024-8927.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -702,7 +708,7 @@ BuildRequires: oracle-instantclient%{oraclever}-devel
Requires: libclntsh.so.%{oraclelib}
AutoReq: 0
%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
@@ -930,7 +936,11 @@ Group: System Environment/Libraries
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+%if 0%{?rhel}
BuildRequires: libicu-devel = 69.1
+%else
+BuildRequires: libicu-devel
+%endif
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -1055,6 +1065,10 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch -P265 -p1 -b .cve3824
%patch -P266 -p1 -b .cve2756
%patch -P267 -p1 -b .cve3096
+%patch -P268 -p1 -b .cve5458
+%patch -P269 -p1 -b .cve8925
+%patch -P270 -p1 -b .cve8926
+%patch -P271 -p1 -b .cve8927
# Fixes for tests
%patch -P300 -p1 -b .datetests
@@ -2005,6 +2019,23 @@ EOF
%changelog
+* Thu Sep 26 2024 Remi Collet <remi@remirepo.net> - 5.6.40-43
+- Fix Bypass of CVE-2012-1823, Argument Injection in PHP-CGI
+ CVE-2024-4577
+- Fix Bypass of CVE-2024-4577, Parameter Injection Vulnerability
+ CVE-2024-8926
+- Fix cgi.force_redirect configuration is bypassable due to the environment variable collision
+ CVE-2024-8927
+- Fix Erroneous parsing of multipart form data
+ CVE-2024-8925
+
+* Wed Jul 31 2024 Remi Collet <remi@remirepo.net> - 5.6.40-42
+- use oracle client library version 23.5 on x86_64
+
+* Tue Jun 4 2024 Remi Collet <remi@remirepo.net> - 5.6.40-41
+- Fix filter bypass in filter_var FILTER_VALIDATE_URL
+ CVE-2024-5458
+
* Wed Apr 10 2024 Remi Collet <remi@remirepo.net> - 5.6.40-40
- use oracle client library version 21.13
- Fix __Host-/__Secure- cookie bypass due to partial CVE-2022-31629 fix