summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-15 09:18:05 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-15 09:18:05 +0100
commitb4b36388f28948f01e26b595b6e828d512efd95a (patch)
treedeb937f47172e54093764b904390ee6776f8d6c2 /php.spec
parentb15359b49251a6989a356d1fe71a2e5dbebee50e (diff)
php56-php: add sybase_ct extension
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec26
1 files changed, 16 insertions, 10 deletions
diff --git a/php.spec b/php.spec
index a19dde2..f07dda1 100644
--- a/php.spec
+++ b/php.spec
@@ -71,7 +71,7 @@
%global with_imap 1
%global with_interbase 1
%global with_mcrypt 1
-%global with_mssql 1
+%global with_freetds 1
%global with_tidy 1
%global with_sqlite3 1
%global with_enchant 1
@@ -132,7 +132,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: 5.6.4
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -774,7 +774,7 @@ The %{?scl_prefix}php-tidy package contains a dynamic shared object that will ad
support for using the tidy library to PHP.
%endif
-%if %{with_mssql}
+%if %{with_freetds}
%package mssql
Summary: MSSQL database module for PHP
Group: Development/Languages
@@ -783,10 +783,11 @@ License: PHP
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
BuildRequires: freetds-devel
Provides: %{?scl_prefix}php-pdo_dblib, %{?scl_prefix}php-pdo_dblib%{?_isa}
+Provides: %{?scl_prefix}php-sybase_ct, %{?scl_prefix}php-sybase_ct%{?_isa}
%description mssql
The %{?scl_prefix}php-mssql package contains a dynamic shared object that will
-add MSSQL database support to PHP. It uses the TDS (Tabular
+add MSSQL and Sybase database support to PHP. It uses the TDS (Tabular
DataStream) protocol through the freetds library, hence any
database server which supports TDS can be accessed.
%endif
@@ -846,7 +847,7 @@ support for using the enchant library to PHP.
%prep
-: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} mssql=%{with_mssql} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
+: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%setup -q -n php-%{version}%{?rcver}
@@ -1162,9 +1163,10 @@ build --libdir=%{_libdir}/php \
%if %{with_tidy}
--with-tidy=shared,%{_root_prefix} \
%endif
-%if %{with_mssql}
+%if %{with_freetds}
--with-mssql=shared,%{_root_prefix} \
--with-pdo-dblib=shared,%{_root_prefix} \
+ --with-sybase-ct=shared,%{_root_prefix} \
%endif
--enable-sysvmsg=shared --enable-sysvshm=shared --enable-sysvsem=shared \
--enable-shmop=shared \
@@ -1409,8 +1411,8 @@ for mod in pgsql odbc ldap snmp xmlrpc \
%if %{with_tidy}
tidy \
%endif
-%if %{with_mssql}
- pdo_dblib mssql \
+%if %{with_freetds}
+ pdo_dblib mssql sybase_ct \
%endif
%if %{with_recode}
recode \
@@ -1459,8 +1461,9 @@ cat files.mysql \
>> files.mysqlnd
# Split out the PDO modules
-%if %{with_mssql}
+%if %{with_freetds}
cat files.pdo_dblib >> files.mssql
+cat files.sybase_ct >> files.mssql
%endif
cat files.pdo_pgsql >> files.pgsql
cat files.pdo_odbc >> files.odbc
@@ -1731,7 +1734,7 @@ fi
%if %{with_tidy}
%files tidy -f files.tidy
%endif
-%if %{with_mssql}
+%if %{with_freetds}
%files mssql -f files.mssql
%endif
%files pspell -f files.pspell
@@ -1755,6 +1758,9 @@ fi
%changelog
+* Mon Dec 15 2014 Remi Collet <remi@fedoraproject.org> 5.6.4-2
+- add sybase_ct extension
+
* Wed Dec 10 2014 Remi Collet <remi@fedoraproject.org> 5.6.4-1
- Update to 5.6.4
http://www.php.net/releases/5_6_4.php