summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-14 15:10:54 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-14 15:10:54 +0200
commite8aab031630bc88a0ed0ec99c09e926003c4ca98 (patch)
treebbb3b8dffd2e148b38c22383fd63f12239fe72d5
parent21778ef59e73e3576c1dcf7ff532243f7a092608 (diff)
PHP 5.6.27
-rw-r--r--failed.txt15
-rw-r--r--php.spec7
-rwxr-xr-xstrip.sh22
3 files changed, 34 insertions, 10 deletions
diff --git a/failed.txt b/failed.txt
index f9ccc8b..b1bc1db 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 5.6.27RC1 (2016-09-29)
+===== 5.6.27 (2016-10-14)
$ grep -r 'Tests failed' /var/lib/mock/scl56*/build.log
@@ -7,8 +7,15 @@ $ grep -r 'Tests failed' /var/lib/mock/scl56*/build.log
/var/lib/mock/scl56fc21x/build.log:Tests failed : 0
/var/lib/mock/scl56fc22x/build.log:Tests failed : 0
/var/lib/mock/scl56fc23x/build.log:Tests failed : 0
-/var/lib/mock/scl56fc24x/build.log:Tests failed : 0
-/var/lib/mock/scl56fc25x/build.log:Tests failed : 0
+/var/lib/mock/scl56fc24x/build.log:Tests failed : 3
+/var/lib/mock/scl56fc25x/build.log:Tests failed : 3
+fc24x, fc25x:
+ *** Bug #20382 [2] (strtotime ("Monday", $date) produces wrong result on DST changeover) [ext/date/tests/bug20382-2.phpt]
+ *** Bug #33414 [1] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-1.phpt]
+ *** Bug #33415 [1] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-1.phpt]
+
+
+* proc_open have erratic results... :(
+*** Related to tzdata 2016g (f24+) vs 2016f
-* proc_open have erratic results... :(
diff --git a/php.spec b/php.spec
index acc5698..6fd42e1 100644
--- a/php.spec
+++ b/php.spec
@@ -137,7 +137,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
@@ -882,7 +882,9 @@ support for using the enchant library to PHP.
%endif
%patch40 -p1 -b .dlopen
+%if 0%{?fedora} >= 23 || 0%{?rhel} >= 5
%patch42 -p1 -b .systzdata
+%endif
%patch43 -p1 -b .headers
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
%patch45 -p1 -b .ldap_r
@@ -1814,6 +1816,9 @@ fi
%changelog
+* Fri Oct 14 2016 Remi Collet <remi@fedoraproject.org> 5.6.27-1
+- Update to 5.6.27 - http://www.php.net/releases/5_6_27.php
+
* Thu Sep 29 2016 Remi Collet <remi@fedoraproject.org> 5.6.27-0.1.RC1
- update to 5.6.27RC1
diff --git a/strip.sh b/strip.sh
index 5939bec..1bd5c25 100755
--- a/strip.sh
+++ b/strip.sh
@@ -11,15 +11,27 @@ fi
old=$(mktemp)
new=$(mktemp)
+ver=$1
+shift
+
echo "Untar..."
-tar xf php-$1.tar.xz
-rm -rf php-$1/ext/json
+tar xf php-$ver.tar.xz
+pushd php-$ver
+rm -rf ext/json
+if [ -n "$2" ]
+then
+ for i in $*
+ do
+ patch -p1 --no-backup <../$i
+ done
+fi
+popd
echo "Tar..."
-tar cJf php-$1-strip.tar.xz php-$1
+tar cJf php-$ver-strip.tar.xz php-$ver
echo "Diff..."
-tar tf php-$1.tar.xz | sort >$old
-tar tf php-$1-strip.tar.xz | sort >$new
+tar tf php-$ver.tar.xz | sort >$old
+tar tf php-$ver-strip.tar.xz | sort >$new
diff $old $new
rm -f $old $new