summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-02 08:01:18 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-02 08:01:18 +0100
commite8116421da4167f0014cbd5c2b9d4ded8881eddf (patch)
tree83b281f9aa131b32a9266671a5096c5b4d0de28c
parenta4a5ee68da16b7bcbf0f475ee6e11ba4d08fd920 (diff)
- update to 5.6.3RC1
- new version of systzdata patch, fix case sensitivity - ignore Factory in date tests - disable opcache.fast_shutdown in default config - add php56-cgi command in base system
-rw-r--r--opcache.ini2
-rw-r--r--php-5.6.0-noNO.patch43
-rw-r--r--php-5.6.3-datetests.patch23
-rw-r--r--php-5.6.3-fixheader.patch (renamed from php-5.4.9-fixheader.patch)4
-rw-r--r--php-5.6.3-includedir.patch (renamed from php-5.2.0-includedir.patch)4
-rw-r--r--php-5.6.3-ldap_r.patch (renamed from php-5.4.8-ldap_r.patch)2
-rw-r--r--php-5.6.3-libdb.patch (renamed from php-5.4.7-libdb.patch)2
-rw-r--r--php-5.6.3-oci8conf.patch (renamed from php-5.3.7-oci8conf.patch)2
-rw-r--r--php-5.6.3-phpinfo.patch (renamed from php-5.4.9-phpinfo.patch)2
-rw-r--r--php-5.6.3-systzdata-v11.patch (renamed from php-5.3.1-systzdata-v10.patch)48
-rw-r--r--php-bug68074.patch60
-rw-r--r--php.spec38
12 files changed, 89 insertions, 141 deletions
diff --git a/opcache.ini b/opcache.ini
index fb3e9a9..21f16ad 100644
--- a/opcache.ini
+++ b/opcache.ini
@@ -48,7 +48,7 @@ opcache.max_accelerated_files=4000
;opcache.load_comments=1
; If enabled, a fast shutdown sequence is used for the accelerated code
-opcache.fast_shutdown=1
+;opcache.fast_shutdown=0
; Allow file existence override (file_exists, etc.) performance feature.
;opcache.enable_file_override=0
diff --git a/php-5.6.0-noNO.patch b/php-5.6.0-noNO.patch
deleted file mode 100644
index 52f54ab..0000000
--- a/php-5.6.0-noNO.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- ext/standard/tests/strings/setlocale_variation2.phpt.orig 2014-06-11 16:10:00.259326468 +0200
-+++ ext/standard/tests/strings/setlocale_variation2.phpt 2014-06-11 16:16:14.396138997 +0200
-@@ -52,6 +52,7 @@
- //try different locale names
- $failure_locale = array();
- $success_count = 0;
-+$expected = 0;
-
- echo "-- Test setlocale() with all available locale in the system --\n";
- // gather all locales installed in the system(stored $all_system_locales),
-@@ -61,6 +62,10 @@
- if(setlocale(LC_ALL,$value )){
- $success_count++;
- }
-+ else if ($value == 'no_NO.ISO-8859-1') {
-+ // ignore this one, see rhbz #971416
-+ $expected++;
-+ }
- else{
- //failure values are put in to an array $failure_locale
- $failure_locale[] = $value;
-@@ -69,11 +74,11 @@
-
- echo "No of locales found on the machine = ".count($all_system_locales)."\n";
- echo "No of setlocale() success = ".$success_count."\n";
--echo "Expected no of failures = 0\n";
-+echo "Expected no of failures = $expected\n";
- echo "Test ";
- // check if there were any failure of setlocale() function earlier, if any
- // failure then dump the list of failing locales
--if($success_count != count($all_system_locales)){
-+if(($success_count + $expected) != count($all_system_locales)){
- echo "FAILED\n";
- echo "Names of locale() for which setlocale() failed ...\n";
- var_dump($failure_locale);
-@@ -89,6 +94,6 @@
- -- Test setlocale() with all available locale in the system --
- No of locales found on the machine = %d
- No of setlocale() success = %d
--Expected no of failures = 0
-+Expected no of failures = %d
- Test PASSED
- Done
diff --git a/php-5.6.3-datetests.patch b/php-5.6.3-datetests.patch
new file mode 100644
index 0000000..a29bb63
--- /dev/null
+++ b/php-5.6.3-datetests.patch
@@ -0,0 +1,23 @@
+--- a/ext/date/tests/bug66985.phpt 2014-10-30 07:32:03.297693403 +0100
++++ b/ext/date/tests/bug66985.phpt 2014-10-30 07:32:45.138877977 +0100
+@@ -3,7 +3,7 @@
+ --FILE--
+ <?php
+ $zones = array(
+- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
++ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
+ "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
+ "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
+ "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
+@@ -45,11 +45,6 @@
+ )
+ DateTimeZone Object
+ (
+- [timezone_type] => 3
+- [timezone] => Factory
+-)
+-DateTimeZone Object
+-(
+ [timezone_type] => 3
+ [timezone] => GB-Eire
+ )
diff --git a/php-5.4.9-fixheader.patch b/php-5.6.3-fixheader.patch
index f4e7db5..7089535 100644
--- a/php-5.4.9-fixheader.patch
+++ b/php-5.6.3-fixheader.patch
@@ -3,7 +3,7 @@ Make generated php_config.h constant across rebuilds.
--- php-5.4.9/configure.in.fixheader
+++ php-5.4.9/configure.in
-@@ -1258,7 +1258,7 @@ fi
+@@ -1275,7 +1275,7 @@ fi
EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
@@ -12,7 +12,7 @@ Make generated php_config.h constant across rebuilds.
AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
case $host_alias in
-@@ -1269,7 +1269,7 @@ case $host_alias in
+@@ -1286,7 +1286,7 @@ case $host_alias in
AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[hardcode for each of the cross compiler host])
;;
*)
diff --git a/php-5.2.0-includedir.patch b/php-5.6.3-includedir.patch
index ac4ae4a..70734cf 100644
--- a/php-5.2.0-includedir.patch
+++ b/php-5.6.3-includedir.patch
@@ -1,11 +1,11 @@
--- php-5.2.0/configure.in.includedir
+++ php-5.2.0/configure.in
-@@ -1101,7 +1101,7 @@
+@@ -1242,7 +1242,7 @@
EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
-INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR
-+INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR:${EXPANDED_DATADIR}/php:/usr/share/pear:/usr/share/php
++INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR:${EXPANDED_DATADIR}/php
exec_prefix=$old_exec_prefix
libdir=$old_libdir
diff --git a/php-5.4.8-ldap_r.patch b/php-5.6.3-ldap_r.patch
index 6d6924f..b335488 100644
--- a/php-5.4.8-ldap_r.patch
+++ b/php-5.6.3-ldap_r.patch
@@ -3,7 +3,7 @@ Use -lldap_r by default.
--- php-5.4.8/ext/ldap/config.m4.ldap_r
+++ php-5.4.8/ext/ldap/config.m4
-@@ -95,7 +95,10 @@ if test "$PHP_LDAP" != "no"; then
+@@ -117,7 +117,10 @@ if test "$PHP_LDAP" != "no"; then
LDAP_PTHREAD=
fi
diff --git a/php-5.4.7-libdb.patch b/php-5.6.3-libdb.patch
index bc4e1fc..dc0e40b 100644
--- a/php-5.4.7-libdb.patch
+++ b/php-5.6.3-libdb.patch
@@ -73,7 +73,7 @@
/* {{{ arginfo */
ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
ZEND_ARG_INFO(0, path)
-@@ -522,6 +526,10 @@
+@@ -535,6 +539,10 @@
php_info_print_table_start();
php_info_print_table_row(2, "DBA support", "enabled");
diff --git a/php-5.3.7-oci8conf.patch b/php-5.6.3-oci8conf.patch
index 4a5c44f..f2d8f99 100644
--- a/php-5.3.7-oci8conf.patch
+++ b/php-5.6.3-oci8conf.patch
@@ -13,7 +13,7 @@ diff -up php5.3-201104170830/ext/ldap/php_ldap.h.remi-oci8 php5.3-201104170830/e
diff -up php5.3-201104170830/ext/oci8/config.m4.remi-oci8 php5.3-201104170830/ext/oci8/config.m4
--- php5.3-201104170830/ext/oci8/config.m4.remi-oci8 2011-03-30 00:35:22.000000000 +0200
+++ php5.3-201104170830/ext/oci8/config.m4 2011-04-17 11:55:25.628871315 +0200
-@@ -291,6 +291,7 @@ if test "$PHP_OCI8" != "no"; then
+@@ -376,6 +376,7 @@ if test "$PHP_OCI8" != "no"; then
dnl Header directory for Instant Client SDK RPM install
OCISDKRPMINC=`echo "$PHP_OCI8_INSTANT_CLIENT" | $PHP_OCI8_SED -e 's!^/usr/lib/oracle/\(.*\)/client\('${PHP_OCI8_IC_LIBDIR_SUFFIX}'\)*/lib[/]*$!/usr/include/oracle/\1/client\2!'`
diff --git a/php-5.4.9-phpinfo.patch b/php-5.6.3-phpinfo.patch
index b52a2f8..a11a298 100644
--- a/php-5.4.9-phpinfo.patch
+++ b/php-5.6.3-phpinfo.patch
@@ -5,7 +5,7 @@ The available extensions are not related to this command.
--- php-5.4.9/ext/standard/info.c.orig 2012-12-11 10:43:02.450578276 +0100
+++ php-5.4.9/ext/standard/info.c 2012-12-11 10:44:12.530820821 +0100
-@@ -704,9 +704,6 @@
+@@ -743,9 +743,6 @@
#ifdef ARCHITECTURE
php_info_print_table_row(2, "Architecture", ARCHITECTURE);
#endif
diff --git a/php-5.3.1-systzdata-v10.patch b/php-5.6.3-systzdata-v11.patch
index b262fae..bfca49b 100644
--- a/php-5.3.1-systzdata-v10.patch
+++ b/php-5.6.3-systzdata-v11.patch
@@ -2,7 +2,9 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
-r10 : make timezone case insensitive
+r11: use canonical names to avoid more case sensitivity issues
+ round lat/long from zone.tab towards zero per builtin db
+r10: make timezone case insensitive
r9: fix another compile error without --with-system-tzdata configured (Michael Heimpold)
r8: fix compile error without --with-system-tzdata configured
r7: improve check for valid timezone id to exclude directories
@@ -17,6 +19,8 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
+diff --git a/ext/date/lib/parse_tz.c b/ext/date/lib/parse_tz.c
+index 5d2aec9..671b398 100644
--- a/ext/date/lib/parse_tz.c
+++ b/ext/date/lib/parse_tz.c
@@ -20,6 +20,16 @@
@@ -67,7 +71,7 @@ r1: initial revision
/* read BC flag */
tz->bc = (**tzf == '\1');
*tzf += 1;
-@@ -256,7 +276,405 @@
+@@ -256,7 +276,418 @@ void timelib_dump_tzinfo(timelib_tzinfo *tz)
}
}
@@ -165,7 +169,7 @@ r1: initial revision
+ /* Round to five decimal place, not because it's a good idea,
+ * but, because the builtin data uses rounded data, so, match
+ * that. */
-+ *result = round(v * sign * 100000.0) / 100000.0;
++ *result = trunc(v * sign * 100000.0) / 100000.0;
+
+ return p;
+}
@@ -293,7 +297,7 @@ r1: initial revision
+{
+ const timelib_tzdb_index_entry *alpha = first, *beta = second;
+
-+ return strcmp(alpha->id, beta->id);
++ return strcasecmp(alpha->id, beta->id);
+}
+
+
@@ -431,6 +435,26 @@ r1: initial revision
+ return S_ISREG(st->st_mode) && st->st_size > 20;
+}
+
++/* To allow timezone names to be used case-insensitively, find the
++ * canonical name for this timezone, if possible. */
++static const char *canonical_tzname(const char *timezone)
++{
++ if (timezonedb_system) {
++ timelib_tzdb_index_entry *ent, lookup;
++
++ lookup.id = (char *)timezone;
++
++ ent = bsearch(&lookup, timezonedb_system->index,
++ timezonedb_system->index_size, sizeof lookup,
++ sysdbcmp);
++ if (ent) {
++ return ent->id;
++ }
++ }
++
++ return timezone;
++}
++
+/* Return the mmap()ed tzfile if found, else NULL. On success, the
+ * length of the mapped data is placed in *length. */
+static char *map_tzfile(const char *timezone, size_t *length)
@@ -444,14 +468,7 @@ r1: initial revision
+ return NULL;
+ }
+
-+ if (system_location_table) {
-+ const struct location_info *li;
-+ if ((li = find_zone_info(system_location_table, timezone)) != NULL) {
-+ /* Use the stored name to avoid case issue */
-+ timezone = li->name;
-+ }
-+ }
-+ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
++ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
+
+ fd = open(fname, O_RDONLY);
+ if (fd == -1) {
@@ -474,7 +491,7 @@ r1: initial revision
{
int left = 0, right = tzdb->index_size - 1;
#ifdef HAVE_SETLOCALE
-@@ -295,36 +713,135 @@
+@@ -295,36 +726,135 @@ static int seek_to_tz_position(const unsigned char **tzf, char *timezone, const
return 0;
}
@@ -556,7 +573,7 @@ r1: initial revision
+ }
+ }
+
-+ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
++ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
+
+ return stat(fname, &st) == 0 && is_valid_tzfile(&st);
+ }
@@ -613,6 +630,8 @@ r1: initial revision
} else {
tmp = NULL;
}
+diff --git a/ext/date/lib/timelib.m4 b/ext/date/lib/timelib.m4
+index c725572..4c837c7 100644
--- a/ext/date/lib/timelib.m4
+++ b/ext/date/lib/timelib.m4
@@ -78,3 +78,17 @@ stdlib.h
@@ -633,3 +652,4 @@ r1: initial revision
+ fi
+fi
+
+
diff --git a/php-bug68074.patch b/php-bug68074.patch
deleted file mode 100644
index 04451c1..0000000
--- a/php-bug68074.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 0d776ef87b7b0c1e970c424cc5dcdf4cd6f500ac Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 24 Sep 2014 10:34:55 +0200
-Subject: [PATCH] Fix bug #68074 Allow to use system cipher list instead of
- hardcoded value
-
----
- ext/openssl/config0.m4 | 6 ++++++
- ext/openssl/xp_ssl.c | 9 ++++++---
- 2 files changed, 12 insertions(+), 3 deletions(-)
-
-diff --git a/ext/openssl/config0.m4 b/ext/openssl/config0.m4
-index a97114f..701e488 100644
---- a/ext/openssl/config0.m4
-+++ b/ext/openssl/config0.m4
-@@ -8,6 +8,9 @@ PHP_ARG_WITH(openssl, for OpenSSL support,
- PHP_ARG_WITH(kerberos, for Kerberos support,
- [ --with-kerberos[=DIR] OPENSSL: Include Kerberos support], no, no)
-
-+PHP_ARG_WITH(system-ciphers, whether to use system default cipher list instead of hardcoded value,
-+[ --with-system-ciphers OPENSSL: Use system default cipher list instead of hardcoded value], no, no)
-+
- if test "$PHP_OPENSSL" != "no"; then
- PHP_NEW_EXTENSION(openssl, openssl.c xp_ssl.c, $ext_shared)
- PHP_SUBST(OPENSSL_SHARED_LIBADD)
-@@ -25,4 +28,7 @@ if test "$PHP_OPENSSL" != "no"; then
- ], [
- AC_MSG_ERROR([OpenSSL check failed. Please check config.log for more information.])
- ])
-+ if test "$PHP_SYSTEM_CIPHERS" != "no"; then
-+ AC_DEFINE(USE_OPENSSL_SYSTEM_CIPHERS,1,[ Use system default cipher list instead of hardcoded value ])
-+ fi
- fi
-diff --git a/ext/openssl/xp_ssl.c b/ext/openssl/xp_ssl.c
-index de9e991..2f81dc7 100644
---- a/ext/openssl/xp_ssl.c
-+++ b/ext/openssl/xp_ssl.c
-@@ -1476,13 +1476,16 @@ int php_openssl_setup_crypto(php_stream *stream,
- }
-
- GET_VER_OPT_STRING("ciphers", cipherlist);
-+#ifndef USE_OPENSSL_SYSTEM_CIPHERS
- if (!cipherlist) {
- cipherlist = OPENSSL_DEFAULT_STREAM_CIPHERS;
- }
-- if (SSL_CTX_set_cipher_list(sslsock->ctx, cipherlist) != 1) {
-- return FAILURE;
-+#endif
-+ if (cipherlist) {
-+ if (SSL_CTX_set_cipher_list(sslsock->ctx, cipherlist) != 1) {
-+ return FAILURE;
-+ }
- }
--
- if (FAILURE == set_local_cert(sslsock->ctx, stream TSRMLS_CC)) {
- return FAILURE;
- }
---
-2.1.0
-
diff --git a/php.spec b/php.spec
index 720f302..5c71b09 100644
--- a/php.spec
+++ b/php.spec
@@ -124,10 +124,11 @@
%global db_devel libdb-devel
%endif
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 5.6.2
-Release: 1%{?dist}
+Version: 5.6.3
+Release: 0.1.RC1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -153,9 +154,9 @@ Source50: opcache.ini
Source51: opcache-default.blacklist
# Build fixes
-Patch5: php-5.2.0-includedir.patch
+Patch5: php-5.6.3-includedir.patch
Patch7: php-5.3.0-recode.patch
-Patch8: php-5.4.7-libdb.patch
+Patch8: php-5.6.3-libdb.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
@@ -163,29 +164,28 @@ Patch21: php-5.4.7-odbctimer.patch
# Functional changes
Patch40: php-5.4.0-dlopen.patch
-Patch42: php-5.3.1-systzdata-v10.patch
+Patch42: php-5.6.3-systzdata-v11.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
-Patch45: php-5.4.8-ldap_r.patch
+Patch45: php-5.6.3-ldap_r.patch
# Make php_config.h constant across builds
-Patch46: php-5.4.9-fixheader.patch
+Patch46: php-5.6.3-fixheader.patch
# drop "Configure command" from phpinfo output
-Patch47: php-5.4.9-phpinfo.patch
+Patch47: php-5.6.3-phpinfo.patch
# RC Patch
-Patch91: php-5.3.7-oci8conf.patch
+Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug68074.patch
# Security fixes (200+)
# Fixes for tests (300+)
+# Factory is droped from system tzdata
+Patch300: php-5.6.3-datetests.patch
# Revert changes for pcre < 8.34
Patch301: php-5.6.0-oldpcre.patch
-# see https://bugzilla.redhat.com/971416
-Patch302: php-5.6.0-noNO.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -853,18 +853,17 @@ support for using the enchant library to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .bug68074
# security patches
# Fixes for tests
+%patch300 -p1 -b .datetests
%if %{with_libpcre}
%if 0%{?fedora} < 21
# Only apply when system libpcre < 8.34
%patch301 -p1 -b .pcre834
%endif
%endif
-%patch302 -p0 -b .971416
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1343,6 +1342,7 @@ install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
%if 0%{?scl:1}
install -m 755 -d $RPM_BUILD_ROOT%{_root_bindir}
ln -s %{_bindir}/php $RPM_BUILD_ROOT%{_root_bindir}/%{scl}
+ln -s %{_bindir}/php-cgi $RPM_BUILD_ROOT%{_root_bindir}/%{scl}-cgi
ln -s %{_bindir}/phar.phar $RPM_BUILD_ROOT%{_root_bindir}/%{scl_prefix}phar
ln -s %{_bindir}/phpdbg $RPM_BUILD_ROOT%{_root_bindir}/%{scl_prefix}phpdbg
%if %{with_lsws}
@@ -1603,6 +1603,7 @@ fi
%doc sapi/cgi/README* sapi/cli/README
%if 0%{?scl:1}
%{_root_bindir}/%{scl}
+%{_root_bindir}/%{scl}-cgi
%{_root_bindir}/%{scl_prefix}phar
%endif
@@ -1718,7 +1719,14 @@ fi
%changelog
-* Thu Oct 16 2014 Remi Collet <remi@fedoraproject.org> 5.6.1-1
+* Sun Nov 2 2014 Remi Collet <remi@fedoraproject.org> 5.6.3-0.1.RC1
+- update to 5.6.3RC1
+- new version of systzdata patch, fix case sensitivity
+- ignore Factory in date tests
+- disable opcache.fast_shutdown in default config
+- add php56-cgi command in base system
+
+* Thu Oct 16 2014 Remi Collet <remi@fedoraproject.org> 5.6.2-1
- Update to PHP 5.6.2
http://php.net/releases/5_6_2.php