summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-28 08:48:40 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-28 08:48:40 +0200
commitdc87b88a5870933118246b4e7755312875537a31 (patch)
tree19633e6f6c548e733a1486a2e37140b450b2da97
parent625cf3d0d498a46123a95be59172d0bb69af0e7e (diff)
PHP 5.6.21
-rw-r--r--failed.txt6
-rw-r--r--php-5.4.7-odbctimer.patch58
-rw-r--r--php.spec6
3 files changed, 8 insertions, 62 deletions
diff --git a/failed.txt b/failed.txt
index c9bb9d8..7bea71f 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,9 +1,9 @@
-===== 5.6.21RC1 (2016-04-18)
+===== 5.6.21 (2016-04-24)
$ grep -r 'Tests failed' /var/lib/mock/scl56*/build.log
-/var/lib/mock/scl56el6x/build.log:Tests failed : 5
-/var/lib/mock/scl56el7x/build.log:Tests failed : 5
+/var/lib/mock/scl56el6x/build.log:Tests failed : 5
+/var/lib/mock/scl56el7x/build.log:Tests failed : 5
/var/lib/mock/scl56fc21x/build.log:Tests failed : 0
/var/lib/mock/scl56fc22x/build.log:Tests failed : 0
/var/lib/mock/scl56fc23x/build.log:Tests failed : 0
diff --git a/php-5.4.7-odbctimer.patch b/php-5.4.7-odbctimer.patch
deleted file mode 100644
index 88c4da4..0000000
--- a/php-5.4.7-odbctimer.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 657494235eafe048e9fa6a19dcdb3c73a0cbe6ec Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 27 Sep 2012 13:45:32 +0200
-Subject: [PATCH] Fixed bug #63171, script hangs if odbc call during timeout
-
----
- ext/odbc/php_odbc.c | 21 ++++++++++++++-------
- 1 file changed, 14 insertions(+), 7 deletions(-)
-
-diff --git a/ext/odbc/php_odbc.c b/ext/odbc/php_odbc.c
-index 52d46b2..2169e65 100644
---- a/ext/odbc/php_odbc.c
-+++ b/ext/odbc/php_odbc.c
-@@ -431,7 +431,8 @@ static void _free_odbc_result(zend_rsrc_list_entry *rsrc TSRMLS_DC)
- efree(res->values);
- res->values = NULL;
- }
-- if (res->stmt) {
-+ /* If aborted via timer expiration, don't try to call any unixODBC function */
-+ if (res->stmt && !(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
- #if defined(HAVE_SOLID) || defined(HAVE_SOLID_30) || defined(HAVE_SOLID_35)
- SQLTransact(res->conn_ptr->henv, res->conn_ptr->hdbc,
- (SQLUSMALLINT) SQL_COMMIT);
-@@ -484,9 +485,12 @@ static void _close_odbc_conn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
- }
- }
-
-- safe_odbc_disconnect(conn->hdbc);
-- SQLFreeConnect(conn->hdbc);
-- SQLFreeEnv(conn->henv);
-+ /* If aborted via timer expiration, don't try to call any unixODBC function */
-+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
-+ safe_odbc_disconnect(conn->hdbc);
-+ SQLFreeConnect(conn->hdbc);
-+ SQLFreeEnv(conn->henv);
-+ }
- efree(conn);
- ODBCG(num_links)--;
- }
-@@ -512,9 +516,12 @@ static void _close_odbc_pconn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
- }
- }
-
-- safe_odbc_disconnect(conn->hdbc);
-- SQLFreeConnect(conn->hdbc);
-- SQLFreeEnv(conn->henv);
-+ /* If aborted via timer expiration, don't try to call any unixODBC function */
-+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
-+ safe_odbc_disconnect(conn->hdbc);
-+ SQLFreeConnect(conn->hdbc);
-+ SQLFreeEnv(conn->henv);
-+ }
- free(conn);
-
- ODBCG(num_links)--;
---
-1.7.10
-
diff --git a/php.spec b/php.spec
index 333c5be..4bd4914 100644
--- a/php.spec
+++ b/php.spec
@@ -137,7 +137,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
@@ -1807,6 +1807,10 @@ fi
%changelog
+* Thu Apr 28 2016 Remi Collet <remi@fedoraproject.org> 5.6.21-1
+- Update to 5.6.21
+ http://www.php.net/releases/5_6_21.php
+
* Mon Apr 18 2016 Remi Collet <remi@fedoraproject.org> 5.6.21-0.1.RC1
- update to 5.6.21RC1
- bump oci8 version to 2.0.11