summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-13 13:54:30 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-13 13:54:30 +0100
commitb0dde6965223098ea5611c499eb004c8af059143 (patch)
tree6c80036d0971d3c0a5e91a0bbff866689b8baecc
parentfa24247a355ed8e300d34e7b890e416c508b59e2 (diff)
php: cleanup PIDFile and EnvironmentFile
-rw-r--r--php-fpm.service1
-rw-r--r--php.spec6
2 files changed, 6 insertions, 1 deletions
diff --git a/php-fpm.service b/php-fpm.service
index b4d528f..687dfc0 100644
--- a/php-fpm.service
+++ b/php-fpm.service
@@ -8,7 +8,6 @@ After=syslog.target network.target
[Service]
Type=notify
-PIDFile=/run/php-fpm/php-fpm.pid
EnvironmentFile=/etc/sysconfig/php-fpm
ExecStart=/usr/sbin/php-fpm --nodaemonize
ExecReload=/bin/kill -USR2 $MAINPID
diff --git a/php.spec b/php.spec
index 4c2e13f..ac610a1 100644
--- a/php.spec
+++ b/php.spec
@@ -1421,10 +1421,14 @@ sed -e 's:/run:%{_localstatedir}/run:' \
-i $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
# Environment file
+%if 0%{?fedora} >= 26
+sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_root_initddir}/%{?scl_prefix}php-fpm
+%else
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
sed -e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
+%endif
# make the cli commands available in standard root for SCL build
%if 0%{?scl:1}
@@ -1724,7 +1728,9 @@ fi
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
+%if 0%{?fedora} < 26
%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
+%endif
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service