summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-08 07:54:01 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-08 07:54:01 +0100
commit902380c4327684e86ea09cab854640c5b954fd12 (patch)
tree3667b199007526175d6d7b0ffd42eed19beee8a6
parent712c6fe33a3f148783528a2eee1fd739443abd55 (diff)
PHP 5.6.7RC1 (as SCL)
-rw-r--r--php-odbc.patch40
-rw-r--r--php.spec30
2 files changed, 58 insertions, 12 deletions
diff --git a/php-odbc.patch b/php-odbc.patch
new file mode 100644
index 0000000..12bff99
--- /dev/null
+++ b/php-odbc.patch
@@ -0,0 +1,40 @@
+From 89f86119d612d539a4ec189aff4d3c077cb608a1 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Sun, 8 Mar 2015 07:34:51 +0100
+Subject: [PATCH] Fix odbc build as shared
+
+Broken since a41aa46759d20e23af92df00b917ca66c6102412
+---
+ ext/odbc/config.m4 | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/ext/odbc/config.m4 b/ext/odbc/config.m4
+index f79c461..9555efd 100644
+--- a/ext/odbc/config.m4
++++ b/ext/odbc/config.m4
+@@ -99,6 +99,11 @@ AC_DEFUN([PHP_ODBC_FIND_EMPRESS_BCS_LIBS],[
+ dnl
+ dnl configure options
+ dnl
++
++PHP_ARG_WITH(odbcver,,
++[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
++ Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
++
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(adabas,,
+ [ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
+@@ -490,10 +495,6 @@ PHP_ARG_WITH(dbmaker,,
+ fi
+ fi
+
+-PHP_ARG_WITH(odbcver,,
+-[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
+- Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
+-
+ if test "no" != "$PHP_ODBCVER"; then
+ if test "$PHP_ODBCVER" != "0"; then
+ AC_DEFINE_UNQUOTED(ODBCVER, $PHP_ODBCVER, [ The highest supported ODBC version ])
+--
+2.1.4
+
diff --git a/php.spec b/php.spec
index 0f35f7a..d86a9bc 100644
--- a/php.spec
+++ b/php.spec
@@ -127,11 +127,11 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 5.6.6
+Version: 5.6.7
Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -183,6 +183,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-odbc.patch
# Security fixes (200+)
@@ -869,6 +870,8 @@ support for using the enchant library to PHP.
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
+%patch100 -p1 -b .odbc
+
%patch91 -p1 -b .remi-oci8
# upstream patches
@@ -1306,13 +1309,13 @@ cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
%endif
%endif
-sed -e 's:/var/lib:%{_localstatedir}/lib:' \
+sed -e 's:/var/lib:%{_sharedstatedir}:' \
-i $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php.d
-install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
-install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
-install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
+install -m 755 -d $RPM_BUILD_ROOT%{_sharedstatedir}/php
+install -m 700 -d $RPM_BUILD_ROOT%{_sharedstatedir}/php/session
+install -m 700 -d $RPM_BUILD_ROOT%{_sharedstatedir}/php/wsdlcache
%if %{with_lsws}
install -m 755 build-apache/sapi/litespeed/php $RPM_BUILD_ROOT%{_bindir}/lsphp
@@ -1330,7 +1333,7 @@ sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/etc:%{_sysconfdir}:' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf
install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf
-sed -e 's:/var/lib:%{_localstatedir}/lib:' \
+sed -e 's:/var/lib:%{_sharedstatedir}:' \
-e 's:/var/log:%{_localstatedir}/log:' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf
mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf.default .
@@ -1607,8 +1610,8 @@ fi
%dir %{_libdir}/httpd/modules
%{_root_httpd_moddir}/lib%{name}5.so
%endif
-%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
-%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
+%attr(0770,root,apache) %dir %{_sharedstatedir}/php/session
+%attr(0770,root,apache) %dir %{_sharedstatedir}/php/wsdlcache
%config(noreplace) %{_httpd_confdir}/%{name}.conf
%if "%{_httpd_modconfdir}" != "%{_httpd_confdir}"
%config(noreplace) %{_httpd_modconfdir}/10-%{name}.conf
@@ -1626,7 +1629,7 @@ fi
%dir %{_sysconfdir}/php.d
%dir %{_libdir}/php
%dir %{_libdir}/php/modules
-%dir %{_localstatedir}/lib/php
+%dir %{_sharedstatedir}/php
%dir %{_datadir}/php
%files cli
@@ -1662,8 +1665,8 @@ fi
%defattr(-,root,root)
%doc php-fpm.conf.default
%license fpm_LICENSE
-%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
-%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
+%attr(0770,root,apache) %dir %{_sharedstatedir}/php/session
+%attr(0770,root,apache) %dir %{_sharedstatedir}/php/wsdlcache
%if %{with_httpd2410}
%config(noreplace) %{_httpd_confdir}/%{name}.conf
%endif
@@ -1766,6 +1769,9 @@ fi
%changelog
+* Sun Mar 8 2015 Remi Collet <remi@fedoraproject.org> 5.6.7-0.1.RC1
+- update to 5.6.7RC1
+
* Thu Feb 19 2015 Remi Collet <remi@fedoraproject.org> 5.6.6-1
- Update to 5.6.6
http://www.php.net/releases/5_6_6.php