summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-20 14:05:58 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-20 14:05:58 +0100
commit5e147a6dafc8bc2442cc5229c8c6478819cc8680 (patch)
tree124cce446519229bd521ef3a1d3ab0aa5bc27b28
parent18395ff3cd298d695cebf7fddfb4b5b3c68b562c (diff)
php56-php: fix php-fpm.service.d location
-rw-r--r--php-fpm.service3
-rw-r--r--php-fpm.sysconfig5
-rw-r--r--php.spec16
3 files changed, 14 insertions, 10 deletions
diff --git a/php-fpm.service b/php-fpm.service
index 41f6bfe..05fc52d 100644
--- a/php-fpm.service
+++ b/php-fpm.service
@@ -1,6 +1,7 @@
# It's not recommended to modify this file in-place, because it will be
# overwritten during package upgrades. If you want to customize, the
-# best way is to create a file "/etc/systemd/system/php-fpm.service".
+# best way is to drop a file with the suffix .conf in
+# /etc/systemd/system/php-fpm.service.d
[Unit]
Description=The PHP FastCGI Process Manager
diff --git a/php-fpm.sysconfig b/php-fpm.sysconfig
index 04314e1..4099ed6 100644
--- a/php-fpm.sysconfig
+++ b/php-fpm.sysconfig
@@ -3,11 +3,6 @@
# This file is deprecated when systemd is used and
# will be removed in the future
-# To alter the FPM environment, copy the unit file
-# from /usr/lib/systemd/system/php-fpm.service
-# to /etc/systemd/system/php-fpm.service
-# and add an Environment line
-
# With systemd >= 204 you can simply drop a file with the
# suffix .conf in /etc/systemd/system/php-fpm.service.d, with
# [Service]
diff --git a/php.spec b/php.spec
index 995a4c1..e27b539 100644
--- a/php.spec
+++ b/php.spec
@@ -132,7 +132,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: 5.6.5
-Release: 0.1.RC1%{?dist}
+Release: 0.2.RC1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -1341,11 +1341,12 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf.default .
install -m 755 -d $RPM_BUILD_ROOT%{_unitdir}
install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
sed -e 's:/run:%{_localstatedir}/run:' \
- -e 's:/etc:%{_sysconfdir}:' \
+ -e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
+ -e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
-e 's:/usr/sbin:%{_sbindir}:' \
-i $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
# this folder requires systemd >= 204
-install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
+install -m 755 -d $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
%else
# Service
install -m 755 -d $RPM_BUILD_ROOT%{_root_initddir}
@@ -1365,9 +1366,13 @@ install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_
sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/var/log:%{_localstatedir}/log:' \
-i $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
+
# Environment file
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
+sed -e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
+ -i $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
+
# Fix the link
(cd $RPM_BUILD_ROOT%{_bindir}; ln -sfn phar.phar phar)
@@ -1668,7 +1673,7 @@ fi
# %{_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service
-%dir %{_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
+%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
%else
%{_root_initddir}/%{?scl_prefix}php-fpm
%endif
@@ -1760,6 +1765,9 @@ fi
%changelog
+* Tue Jan 20 2015 Remi Collet <rcollet@redhat.com> 5.6.5-0.2.RC1
+- fix php-fpm.service.d location
+
* Fri Jan 9 2015 Remi Collet <remi@fedoraproject.org> 5.6.5-0.1.RC1
- update to 5.6.5RC1
- add base system path in default include path