summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-06 10:14:33 +0200
committerRemi Collet <remi@remirepo.net>2017-07-06 10:14:33 +0200
commit37a741093e330edeff4aed2e36d52c4160dabeb8 (patch)
treeeddb0b125584137f0222097b2d38dff3814e6cb9
parent9d7d861262f988fd637982ee0e6423fef091782b (diff)
refresh openssl 1.1 patch for F26
-rw-r--r--failed.txt9
-rw-r--r--php-5.6.31-openssl11.patch6
-rw-r--r--php.spec5
3 files changed, 10 insertions, 10 deletions
diff --git a/failed.txt b/failed.txt
index eaf2f3a..8d01e3e 100644
--- a/failed.txt
+++ b/failed.txt
@@ -7,11 +7,12 @@ $ grep -r 'Tests failed' /var/lib/mock/scl56*/build.log
/var/lib/mock/scl56fc23x/build.log:Tests failed : 9
/var/lib/mock/scl56fc24x/build.log:Tests failed : 4
/var/lib/mock/scl56fc25x/build.log:Tests failed : 4
-/var/lib/mock/scl56fc25x/build.log:Tests failed : 2
+/var/lib/mock/scl56fc26x/build.log:Tests failed : 1
el6x, el7x
4 Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+el6x, el7x, fc23x, fc24x, fc25x, fc26x:
4 Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
fc23x
4 Bug #32086 (strtotime don't work in DST) [ext/date/tests/bug32086.phpt]
@@ -19,14 +20,10 @@ fc23x
4 Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
4 Bug #33415 [1] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-1.phpt]
4 date_modify() function [1] [ext/date/tests/date_modify-1.phpt]
-fc23x,fc26x, fc25x:
- 4 Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
+fc23x, fc24x, fc25x:
3 Bug #65538: SSL context "cafile" disallows URL stream wrappers [ext/openssl/tests/bug65538_002.phpt]
3 gethostbyname() function - basic return valid ip address test [ext/standard/tests/network/gethostbyname_error004.phpt]
3 getmxrr() test [ext/standard/tests/network/getmxrr.phpt]
-fc26x:
- 4 Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt]
- Bug #74651: negative-size-param (-1) in memcpy in zif_openssl_seal() [ext/openssl/tests/bug74651.phpt]
1 proc_open have erratic results... :(
diff --git a/php-5.6.31-openssl11.patch b/php-5.6.31-openssl11.patch
index 267b969..4706391 100644
--- a/php-5.6.31-openssl11.patch
+++ b/php-5.6.31-openssl11.patch
@@ -1,4 +1,4 @@
-From d0c386012affb194ea4600ff2b6dbe447ff1898e Mon Sep 17 00:00:00 2001
+From 4ca75ff1f3c341b83932f85310595f5c0a10f57e Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Mon, 20 Mar 2017 11:45:54 +0100
Subject: [PATCH] backport needed changes for OpenSSL 1.1
@@ -15,7 +15,7 @@ Subject: [PATCH] backport needed changes for OpenSSL 1.1
8 files changed, 371 insertions(+), 206 deletions(-)
diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
-index a78a8fb..fc9a708 100644
+index a78a8fb..eda68f2 100644
--- a/ext/openssl/openssl.c
+++ b/ext/openssl/openssl.c
@@ -68,7 +68,9 @@
@@ -753,7 +753,7 @@ index a78a8fb..fc9a708 100644
- if (EVP_SealInit(&ctx, cipher, eks, eksl, NULL, pkeys, nkeys) <= 0 ||
- !EVP_SealUpdate(&ctx, buf, &len1, (unsigned char *)data, data_len) ||
- !EVP_SealFinal(&ctx, buf + len1, &len2)) {
-+ if (!EVP_SealInit(ctx, cipher, eks, eksl, NULL, pkeys, nkeys) ||
++ if (EVP_SealInit(ctx, cipher, eks, eksl, NULL, pkeys, nkeys) <= 0 ||
+ !EVP_SealUpdate(ctx, buf, &len1, (unsigned char *)data, data_len) ||
+ !EVP_SealFinal(ctx, buf + len1, &len2)) {
RETVAL_FALSE;
diff --git a/php.spec b/php.spec
index 0ecc889..0ae2547 100644
--- a/php.spec
+++ b/php.spec
@@ -138,7 +138,7 @@
%endif
#global rcver RC1
-%global rpmrel 1
+%global rpmrel 2
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -1833,6 +1833,9 @@ fi
%changelog
+* Thu Jul 6 2017 Remi Collet <remi@fedoraproject.org> 5.6.31-2
+- refresh openssl 1.1 patch for F26
+
* Thu Jul 6 2017 Remi Collet <remi@fedoraproject.org> 5.6.31-1
- Update to 5.6.31 - http://www.php.net/releases/5_6_31.php
- use oracle instant client version 12.2