summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-15 09:17:05 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-15 09:17:05 +0100
commitd74a236f7da10cfef7a4b15f90a2f0dc9a8a3e6a (patch)
tree94c08f178ff4d1bcb175c092e0ccd20445192ea9
parent7cb222cebcee54e53dddb910161fc1e549a90b23 (diff)
php55-php: add sybase_ct extension
-rw-r--r--php.spec26
1 files changed, 16 insertions, 10 deletions
diff --git a/php.spec b/php.spec
index ca63263..f15b553 100644
--- a/php.spec
+++ b/php.spec
@@ -71,7 +71,7 @@
%global with_imap 1
%global with_interbase 1
%global with_mcrypt 1
-%global with_mssql 1
+%global with_freetds 1
%global with_tidy 1
%global with_sqlite3 1
%global with_enchant 1
@@ -132,7 +132,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: 5.5.20
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -761,7 +761,7 @@ The %{?scl_prefix}php-tidy package contains a dynamic shared object that will ad
support for using the tidy library to PHP.
%endif
-%if %{with_mssql}
+%if %{with_freetds}
%package mssql
Summary: MSSQL database module for PHP
Group: Development/Languages
@@ -770,10 +770,11 @@ License: PHP
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
BuildRequires: freetds-devel
Provides: %{?scl_prefix}php-pdo_dblib, %{?scl_prefix}php-pdo_dblib%{?_isa}
+Provides: %{?scl_prefix}php-sybase_ct, %{?scl_prefix}php-sybase_ct%{?_isa}
%description mssql
The %{?scl_prefix}php-mssql package contains a dynamic shared object that will
-add MSSQL database support to PHP. It uses the TDS (Tabular
+add MSSQL and Sybase database support to PHP. It uses the TDS (Tabular
DataStream) protocol through the freetds library, hence any
database server which supports TDS can be accessed.
%endif
@@ -833,7 +834,7 @@ support for using the enchant library to PHP.
%prep
-: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} mssql=%{with_mssql} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
+: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%setup -q -n php-%{version}%{?rcver}
@@ -1139,9 +1140,10 @@ build --libdir=%{_libdir}/php \
%if %{with_tidy}
--with-tidy=shared,%{_root_prefix} \
%endif
-%if %{with_mssql}
+%if %{with_freetds}
--with-mssql=shared,%{_root_prefix} \
--with-pdo-dblib=shared,%{_root_prefix} \
+ --with-sybase-ct=shared,%{_root_prefix} \
%endif
--enable-sysvmsg=shared --enable-sysvshm=shared --enable-sysvsem=shared \
--enable-shmop=shared \
@@ -1393,8 +1395,8 @@ for mod in pgsql odbc ldap snmp xmlrpc \
%if %{with_tidy}
tidy \
%endif
-%if %{with_mssql}
- pdo_dblib mssql \
+%if %{with_freetds}
+ pdo_dblib mssql sybase_ct \
%endif
%if %{with_recode}
recode \
@@ -1437,8 +1439,9 @@ cat files.mysqlnd_mysql \
>> files.mysqlnd
# Split out the PDO modules
-%if %{with_mssql}
+%if %{with_freetds}
cat files.pdo_dblib >> files.mssql
+cat files.sybase_ct >> files.mssql
%endif
cat files.pdo_pgsql >> files.pgsql
cat files.pdo_odbc >> files.odbc
@@ -1700,7 +1703,7 @@ fi
%if %{with_tidy}
%files tidy -f files.tidy
%endif
-%if %{with_mssql}
+%if %{with_freetds}
%files mssql -f files.mssql
%endif
%files pspell -f files.pspell
@@ -1724,6 +1727,9 @@ fi
%changelog
+* Mon Dec 15 2014 Remi Collet <remi@fedoraproject.org> 5.5.20-2
+- add sybase_ct extension
+
* Wed Dec 10 2014 Remi Collet <remi@fedoraproject.org> 5.5.20-1
- Update to 5.5.20
http://www.php.net/releases/5_5_20.php