summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
commit9fab5e035ab13dd62e79aea3dc654511796b8a19 (patch)
treebf9fc11ff871dc310c8cf0b4590d8b3fd3df248f
parent8a5a6dd3adfcb61ca58d23a1aca6d7b9d52541b4 (diff)
php/curl: add CURL_SSLVERSION_TLSv1_x constant
-rw-r--r--php-5.5.30-curl.patch14
-rw-r--r--php.spec9
2 files changed, 22 insertions, 1 deletions
diff --git a/php-5.5.30-curl.patch b/php-5.5.30-curl.patch
new file mode 100644
index 0000000..0c72d56
--- /dev/null
+++ b/php-5.5.30-curl.patch
@@ -0,0 +1,14 @@
+diff -up php-5.5.30/ext/curl/interface.c.old php-5.5.30/ext/curl/interface.c
+--- php-5.5.30/ext/curl/interface.c.old 2015-12-14 13:58:27.911676702 +0100
++++ php-5.5.30/ext/curl/interface.c 2015-12-14 14:08:04.581124497 +0100
+@@ -1213,7 +1213,9 @@ PHP_MINIT_FUNCTION(curl)
+ REGISTER_CURL_CONSTANT(CURLSSLOPT_ALLOW_BEAST);
+ #endif
+
+-#if LIBCURL_VERSION_NUM >= 0x072200 /* Available since 7.34.0 */
++#if LIBCURL_VERSION_NUM >= 0x071300 /* Available since 7.19.0 (in upstream curl 7.34)
++ backported in RHEL-7 curl-7.29.0-16.el7 rhbz#1012136
++ backported in RHEL-6 curl-7.19.7-43.el6 rhbz#1036789 */
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_0);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_1);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_2);
diff --git a/php.spec b/php.spec
index 6f855a9..37a7c72 100644
--- a/php.spec
+++ b/php.spec
@@ -170,6 +170,7 @@ Patch5: php-5.2.0-includedir.patch
Patch6: php-5.5.19-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.4.7-libdb.patch
+Patch9: php-5.5.30-curl.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
@@ -860,6 +861,9 @@ support for using the enchant library to PHP.
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
%patch8 -p1 -b .libdb
+%if 0%{?rhel}
+%patch9 -p1 -b .curltls
+%endif
%patch21 -p1 -b .odbctimer
@@ -1662,7 +1666,7 @@ fi
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
-# %{_prefix}/lib/tmpfiles.d/php-fpm.conf
+# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service
%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
@@ -1757,6 +1761,9 @@ fi
%changelog
+* Mon Dec 14 2015 Remi Collet <remi@fedoraproject.org> 5.5.30-1.1
+- curl: add CURL_SSLVERSION_TLSv1_x constant
+
* Thu Oct 1 2015 Remi Collet <remi@fedoraproject.org> 5.5.30-1
- Update to 5.5.30
http://www.php.net/releases/5_5_30.php